LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-13-2003, 10:42 PM   #1
feetyouwell
Member
 
Registered: Dec 2003
Location: NC, US
Distribution: Novell Linux Eval (2.6.5)
Posts: 240

Rep: Reputation: 30
Unhappy Need help -- XMMS will not work with mp3


I am running Ximian on RH9. XMMS will not play my mp3 at all, i am using the player that's bundled with Limewire to play my mp3 right now --> kinda frustrating. I am running the latest XMMS (whatever version it is). When I try to play the file in XMMS, it acts if it was playing and it goes through a 5 min song in, like 10 sec, and of couse there is no audio coming out of my speakers. Need help!! THANKS!!
 
Old 12-13-2003, 10:47 PM   #2
sudhir
Member
 
Registered: Feb 2003
Distribution: redhat
Posts: 58

Rep: Reputation: 15
Try using this

http://ftp.freshrpms.net/pub/freshrp...at/9/xmms-mp3/

Download the rpm's and install it... This shud work with RH9 !!!

Forgot to mention... U cna either get the binary package alone and install the rpm or u can download the source rpm and compile it !!!

If I remember right, RH 8 was kinda hadicapped with xmms playing mp3's.... they did not ship it with the mp3 decoders I guess... I dunno if this is the same with RH9 !!

Another possible way wud be to compile and install from source...

http://www.xmms.org/download.html

Last edited by sudhir; 12-13-2003 at 10:53 PM.
 
Old 12-14-2003, 02:17 AM   #3
feetyouwell
Member
 
Registered: Dec 2003
Location: NC, US
Distribution: Novell Linux Eval (2.6.5)
Posts: 240

Original Poster
Rep: Reputation: 30
Didn't work

Thanks for replying. I tried to install it but it didn't work. It gave me several errors while installing but i think it installed anyway, it didn't work.
 
Old 12-14-2003, 02:29 AM   #4
sudhir
Member
 
Registered: Feb 2003
Distribution: redhat
Posts: 58

Rep: Reputation: 15
Okie then... Why dont u try this ?? (I remember reading this somewhere)

Have ur xmms installed (preferably without errors.. may be the errors got something to do with ur xmms not playing mp3's) Did U have a look at the errors ???

And get the mpg123 plugins and install them separately !!!!
 
Old 12-14-2003, 08:36 AM   #5
NOT_a_n00b
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Rep: Reputation: 0
try this.....http://staff.xmms.org/priv/redhat8/
 
Old 12-14-2003, 10:29 AM   #6
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
I think you'd need to make sure you have the mpeg libraries in order to play mp3s on anything...you can install all the players in the world and still not hear anything if you don't have the decompression
 
Old 12-14-2003, 11:01 AM   #7
Oxyd
Member
 
Registered: Oct 2003
Distribution: Fedora Core 3
Posts: 34

Rep: Reputation: 15
It's possible that you've set up your output plugin to disk-writer - it acts as you described.
 
Old 12-14-2003, 11:25 AM   #8
NOT_a_n00b
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Rep: Reputation: 0
Try changing Right click->Options-Perferences->Output Plugins

Make sure you don't have Disk Write instead of ALSA or OSS.

Also try other players.

Last edited by NOT_a_n00b; 12-14-2003 at 11:30 AM.
 
Old 12-14-2003, 01:01 PM   #9
feetyouwell
Member
 
Registered: Dec 2003
Location: NC, US
Distribution: Novell Linux Eval (2.6.5)
Posts: 240

Original Poster
Rep: Reputation: 30
That worked!!!

Thanks man, that worked. I have the wrong output plug-in selected.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms mp3 idioticneophyte Fedora 4 02-06-2005 12:06 AM
.m3u files from xmms won't work with mp3 player ? matt_w_lambert Linux - Software 1 10-06-2004 02:23 AM
XMMS and MP3 sihere Linux - Software 15 06-05-2004 03:06 PM
xmms mp3 patch doesnt work now what? RichardSimmons Linux - Newbie 12 03-25-2004 08:23 PM
xmms mp3 hadi Linux - Newbie 5 10-29-2003 07:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration