-   Linux - Software (
-   -   need help with xsane and sane (

jbzy3000 08-09-2004 03:40 PM

need help with xsane and sane
I just installed suse 9.1 but cant use my scanner. Immediately when i start a scan in xsane 9.2 i get "error during read: Error during device I/O." everything else works fine. But I do a lot of scanning for a realestate office. I am trying to convert them from microsoft to linux. Everything else is fine. They will need this one function to work. I uninstalled xsane and sane and tried older version but they didnt work.
the scanner is usb hp 5200c

thanks ahead of time

rshaw 08-09-2004 03:57 PM

did you configure it with yast2 before you tried to use it. it's one of the few things that the install routine doesn't configure for you

jbzy3000 08-09-2004 04:02 PM

yes i did
but the other problem is it shows up in the hardware list 3 times

rshaw 08-09-2004 04:13 PM

right click the suse hardware tool (little net card looking thing down by the clock) select configure, unselect "inform me of new hardware", select 'OK'. open yast2/hardware/scanner and remove all scanners. select finish. open 'scanner' again and reconfigure.

jbzy3000 08-09-2004 04:21 PM

still didnt work
get the same error
any more suggestions
i rechecked the hardware tool it still has 3 scanners in it
and the x is in the inform me about new hardware

arno 08-09-2004 04:29 PM

For a HP scanner, you need to change /usr/local/etc/sane.d/hp.conf to contain just the following two lines:

option connect-device

jbzy3000 08-09-2004 04:54 PM

i dont have the etc file
or i cant find the directory

jbzy3000 08-09-2004 04:58 PM

found the directory
not under user but there is a lot of stuff in my file
should i delete it all out
and just put those lines in there

scsi HP
# Uncomment the following if you have "Error during device I/O" on SCSI
# option dumb-read
# The usual place for a SCSI-scanner on Linux

# USB-scanners supported by the hp-backend
# HP ScanJet 4100C
usb 0x03f0 0x0101
# HP ScanJet 5200C
usb 0x03f0 0x0401
# HP ScanJet 62X0C
usb 0x03f0 0x0201
# HP ScanJet 63X0C
usb 0x03f0 0x0601

# from usermap
usb 0x03f0 0x0102
usb 0x03f0 0x0105
usb 0x03f0 0x0205
usb 0x03f0 0x0305
usb 0x03f0 0x0405
usb 0x03f0 0x0705
usb 0x03f0 0x0805
usb 0x03f0 0x0901
usb 0x03f0 0x0a01
usb 0x03f0 0x1205
usb 0x03f0 0x1305
usb 0x03f0 0x2005
usb 0x03f0 0x2205

# Uncomment the following if your scanner is connected by USB,
# but you are not using libusb
# /dev/usb/scanner0
# option connect-device
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401
usb 0x3f0 0x401

rshaw 08-09-2004 05:20 PM

just uncomment these:
# /dev/usb/scanner0
# option connect-device

leave the rest for now.

jbzy3000 08-09-2004 05:41 PM

it is installing the driver as device libusb
think that is where the problem is
yast wont let me install it any other way

jbzy3000 08-09-2004 09:25 PM

is there any other scanning program other than sane

jbzy3000 08-10-2004 12:11 AM

just did a reinstall
so far works just fine
have to keep an eye on it
the only change i made was some downloaded updates
thanks for the help

All times are GMT -5. The time now is 08:14 AM.