-   Linux - Software (
-   -   Need help with Squirrelmail with Dovecot & Sendmail (

cojo 11-14-2005 06:37 PM

Need help with Squirrelmail with Dovecot & Sendmail
I have configured my server with Sendmail and Dovecot as a pop3 & imap server. I'm able to send and receive mail from Outlook or Thunderbird via pop. But, when I tried to login from my web interface I get permission denied. So, I ran the configtest.php and I get this error return:

SquirrelMail configtest

This script will try to check some aspects of your SquirrelMail configuration and point you to errors whereever it can find them. You need to go run in the config/ directory first before you run this script.

SquirrelMail version: 1.4.6 [CVS]-0.cvs20050812.1.fc3
Config file version: 1.4.0
Config file last modified: 14 November 2005 17:00:45
Checking PHP configuration...
PHP version 4.3.11 OK.
PHP extensions OK.
Checking paths...
Data dir OK.
Attachment dir OK.
Plugins OK.
Themes OK.
Default language OK.
Base URL detected as:
Checking outgoing mail service....

ERROR: Location of sendmail program incorrect (/usr/sbin/sendmail)!

I don't get it. Can any help????


cojo 11-15-2005 02:15 AM

Anyone out there might have an answer?????

ai6ksb 11-15-2005 07:55 AM

Hi I had a similiar issue, I changed the location to usr/lib/sendmail and the error moved on (this was on a Fedora Core 4 system), basically check the location of where send mail is.

cojo 11-15-2005 09:10 AM


I'm using FC3. Sendmail is location in "/usr/sbin/sendmail". Why it won't find it?

cojo 11-15-2005 09:16 AM


I changed the location to /usr/lib/sendmail and I still get the same error. Any other suggestion?

ai6ksb 11-16-2005 01:43 AM

My mistake I am using Postfix instead of Sendmail, as it is supposed to be more secure and easier to configure. The configtest.php passes the stage where it looks for sendmail, however if fails IMAP, (thats another problem all together), hope that helps

cojo 11-17-2005 01:48 AM


I found the cause of my problem. It's SELinux which prevent accessing sendmail and imap through httpd. So, if I turn off SELinux by:

setenforce 0

Squirrelmail worked perfectly. But, as soon I turned SELinux back on by:

setenforce 1

Squirrelmail will get permission denied when I tried to login. So, now I need to figure out how to change SELinux to work with Squirrelmail. Because, I don't want to disable SELinux on my server. Any ideas????

jayakrishnan 11-17-2005 03:31 AM

c if this helps

ai6ksb 11-17-2005 03:46 PM

I've just built fc3 box and got the same errors, i'd be interested if you find a solution to this problen

ai6ksb 11-17-2005 03:52 PM

Thanks jayakrishnan
I enabled httpd_can_connect and it worked
I just need to know what it means and what are the implications of doing this?

Can you help?

cojo 11-18-2005 10:09 AM


where do you enable httpd_can_connect? How do you restart SELinux without rebooting the server?

ai6ksb 11-18-2005 01:10 PM

Try this System Settings -> security -> SELinux -> Other

cojo 11-18-2005 04:27 PM


"httpd_can_connect" is not on the list. Also, I use shell via ssh to do most of my work.

fhleung 04-23-2006 12:43 AM

Sendmail config howto? Any Sendmail expert here?
I having FC5 and would like to setup simple mail server with Sendmail, Dovecot and SquirrelMail.

In the very begining, I can not login via SquirrelMail webmail interface. The problem of this thread just same as mine so I turn off the SELinux.

But now I want to go back how to configure sendmail. Are there any expert here?


cojo 04-24-2006 11:50 AM


it's actually quite easy to fixed. Is your webmail work fine if you turn selinux off? If yes, you will need to install the selinux Policy targeted sources. Just follow these steps:

1. yum -y install selinux-targeted-sources
2. setenforce 0
3. audit2allow -l -i /var/log/messages >> /etc/selinux/targeted/src/policy/domains/misc/local.te
4. /usr/bin/make -C /etc/selinux/targeted/src/policy/ reload
5. setenforce 1
6. try to login again
7. repeat step 2 thru 6 if neccessary

This should fix your problem. Let me know if you need help.


All times are GMT -5. The time now is 06:43 PM.