LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-14-2005, 03:45 PM   #1
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Rep: Reputation: 15
Need Help With Captive-ntfs on Suse 9.3


Well i found this captive program and thoguht I'd might give it a try to mount my windows hdd as rw

So I installed the rpm, worked perfectly, ran the install-acquire, and it fetched the ntfs file from the sp1.
But I still get an error when mounting:

Code:
linux:/usr/share/lufs # mount.captive-ntfs /dev/sdb1 /mnt/captive-noname2
Captive NTFS v1.1.5.  Check a new version at: http://www.jankratochvil.net/
Preparing LUFS kernel module... Run /usr/share/lufs/prepmod if problems occur.
lufs module not loaded: Try running /usr/share/lufs/prepmod to see more. at /usr/bin/captive-lufsd line 180
and when I run /usr/share/lufs/prepmod it gives me this:

Code:
linux:/usr/share/lufs # /usr/share/lufs/prepmod
+ /sbin/modprobe lufs 2>/dev/null
Preparing LUFS kernel module... Run /usr/share/lufs/prepmod if problems occur.
Running kernel version: 2.6.11.4-21.8- (base version 2.6.11.4)
Destination module directory: /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs
Using kernel sources: /usr/src/linux
+ set -e; /bin/mkdir -p `dirname /var/lib/lufs/lufs.ko`; /bin/rm -f /var/lib/lufs/lufs.ko; cd /var/lib/lufs; /usr/bin/gcc -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -D__KERNEL__ -DMODULE -DLINUX -DKBUILD_MODNAME=lufs   -I/usr/src/linux/include -I/usr/src/linux/include/asm-i386/mach-default -DMODVERSIONS -include /usr/src/linux/include/linux/version.h -include /usr/src/linux/include/linux/modversions.h -c /usr/share/lufs/2.6/proc.c /usr/share/lufs/2.6/inode.c /usr/share/lufs/2.6/dir.c /usr/share/lufs/2.6/file.c /usr/share/lufs/2.6/symlink.c; /usr/bin/ld -r -o /var/lib/lufs/lufs.ko proc.o inode.o dir.o file.o symlink.o; /bin/rm -f proc.o inode.o dir.o file.o symlink.o
+ rm -f /usr/src/linux/.config
+ /bin/rm -rf /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs; /bin/mkdir -p /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs; /bin/ln -s /var/lib/lufs/lufs.ko /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko
+ /sbin/rmmod lufs 2>/dev/null; /sbin/insmod /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko 2>/dev/null
Failed to prepare lufs.ko module for your Linux kernel 2.6.11.4-21.8-.
Detected Linux kernel sources "/usr/src/linux" do not appear to be valid.
Please install kernel-source-x.y.z.i386.rpm or kernel-headers_x.y.z_i386.deb.
The following directory paths were search (first existing directory used):
                /lib/modules/2.6.11.4-21.8-/build
                /usr/src/kernel-headers-2.6.11.4-21.8-
                /usr/src/linux-2.6.11.4-21.8-
                /usr/src/linux-2.6.11.4
                /usr/src/linux
                /usr/src/kernel-source-2.6.11.4-21.8-
 at /usr/share/lufs/prepmod line 181
My kernel sources are installed correctly though.

Here's my fstab btw:

Code:
/dev/sda3            /                    reiserfs   acl,user_xattr        1 1
/dev/sda1            /data                reiserfs   acl,user_xattr        0 0
/dev/sda2            swap                 swap       pri=42                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
proc                 /proc                proc       defaults              0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
sysfs                /sys                 sysfs      noauto                0 0
/dev/dvd             /media/dvd           subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdrecorder     /media/dvdrecorder   subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0             /media/floppy        subfs      noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/cdrom           /media/cdrom         subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/sda4            /data2               reiserfs   acl,user_xattr        1 2
/dev/sdb5 /mnt/captive-noname captive-ntfs defaults,noauto 0 0
/dev/sdb1 /mnt/captive-noname2 captive-ntfs defaults,noauto 0 0
Anyone have an idea of how I could fix this? I'm sure it's something simple, maybe some file which should be copied to a different dir or smth.

P.S. "modprobe lufs" gives me:
Code:
FATAL: Error inserting lufs (/lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko): Invalid module format
 
Old 08-16-2005, 04:06 AM   #2
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Original Poster
Rep: Reputation: 15
I searched a bit on google and someone said that you need to type the following to get it working under suse 9.2:

"make cloneconfig modules modules_install" so I did that (inside of /lib/modules/....) and now the error message is slightly different:

Code:
linux:/home/koy # /usr/share/lufs/captive-prepmod
+ /sbin/modprobe lufs 2>/dev/null
Preparing LUFS kernel module... Run /usr/share/lufs/prepmod if problems occur.
Running kernel version: 2.6.11.4-21.8- (base version 2.6.11.4)
Destination module directory: /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs
Using kernel sources: /usr/src/linux
+ set -e; /bin/mkdir -p `dirname /var/lib/lufs/lufs.ko`; /bin/rm -f /var/lib/lufs/lufs.ko; make -C /usr/src/linux SUBDIRS="/usr/share/lufs/2.6" modules EXTRA_CFLAGS=""; /bin/mv -f /usr/share/lufs/2.6/lufs.ko /var/lib/lufs/lufs.ko; /bin/rm -f /usr/share/lufs/2.6/proc.o /usr/share/lufs/2.6/.proc.o.flags /usr/share/lufs/2.6/.proc.o.cmd /usr/share/lufs/2.6/inode.o /usr/share/lufs/2.6/.inode.o.flags /usr/share/lufs/2.6/.inode.o.cmd /usr/share/lufs/2.6/dir.o /usr/share/lufs/2.6/.dir.o.flags /usr/share/lufs/2.6/.dir.o.cmd /usr/share/lufs/2.6/file.o /usr/share/lufs/2.6/.file.o.flags /usr/share/lufs/2.6/.file.o.cmd /usr/share/lufs/2.6/symlink.o /usr/share/lufs/2.6/.symlink.o.flags /usr/share/lufs/2.6/.symlink.o.cmd /usr/share/lufs/2.6/lufs.mod.o /usr/share/lufs/2.6/.lufs.mod.o.flags /usr/share/lufs/2.6/.lufs.mod.o.cmd /usr/share/lufs/2.6/lufs.o /usr/share/lufs/2.6/.lufs.o.flags /usr/share/lufs/2.6/.lufs.o.cmd /usr/share/lufs/2.6/lufs.mod.c /usr/share/lufs/2.6/.lufs.ko.cmd;
make: Entering directory `/usr/src/linux-2.6.11.4-21.8'
  CC [M]  /usr/share/lufs/2.6/dir.o
  CC [M]  /usr/share/lufs/2.6/file.o
  CC [M]  /usr/share/lufs/2.6/inode.o
  CC [M]  /usr/share/lufs/2.6/proc.o
  CC [M]  /usr/share/lufs/2.6/symlink.o
  LD [M]  /usr/share/lufs/2.6/lufs.o
  Building modules, stage 2.
  MODPOST
  CC      /usr/share/lufs/2.6/lufs.mod.o
  LD [M]  /usr/share/lufs/2.6/lufs.ko
make: Leaving directory `/usr/src/linux-2.6.11.4-21.8'
+ /bin/rm -rf /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs; /bin/mkdir -p /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs; /bin/ln -s /var/lib/lufs/lufs.ko /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko
+ /sbin/rmmod lufs 2>/dev/null; /sbin/insmod /lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko 2>/dev/null
Failed to prepare lufs.ko module for your Linux kernel 2.6.11.4-21.8-.
Detected Linux kernel sources "/usr/src/linux" do not appear to be valid.
Please install kernel-source-x.y.z.i386.rpm or kernel-headers_x.y.z_i386.deb.
The following directory paths were search (first existing directory used):
                /lib/modules/2.6.11.4-21.8-/build
                /usr/src/kernel-headers-2.6.11.4-21.8-
                /usr/src/linux-2.6.11.4-21.8-
                /usr/src/linux-2.6.11.4
                /usr/src/linux
                /usr/src/kernel-source-2.6.11.4-21.8-
 at /usr/share/lufs/captive-prepmod line 181
as you can see, it's actually compiling or doing something to the files, but then stops without a detailed error message :/


P.S. "modprobe lufs" now gives me:
Code:
FATAL: Error inserting lufs (/lib/modules/2.6.11.4-21.8-smp/kernel/fs/lufs/lufs.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Last edited by koy; 08-16-2005 at 04:20 AM.
 
Old 09-06-2005, 06:58 PM   #3
mayhemt
Member
 
Registered: Sep 2005
Location: irving TX
Distribution: SuSe, Kubuntu, Win$ucks
Posts: 50

Rep: Reputation: 15
Thumbs up

i reached this page several times finding a way to solve this thing....
so i figured others too will reach this page & i m posting the solution here..
we are going to tweak some stuff...(thas right..now u can brag to ur frnds..that u hacked ur OS...LOL)...
x.y.z is ur current kernel version....
1. make sure you got all kernel sources in place (usually /usr/src/linux-x.y.z)

2. edit /usr/src/linux-x.y.z/kernel/signal.c in ur fav editor
goto the place where u see somethin like this ..shortcut is Use find option of editor & find for EXPORT
EXPORT_SYMBOL(recalc_sigpending);
EXPORT_SYMBOL_GPL(dequeue_signal);
EXPORT_SYMBOL(flush_signals);
EXPORT_SYMBOL(force_sig);
EXPORT_SYMBOL(kill_pg);
EXPORT_SYMBOL(kill_proc);

3. add this line at the end of all those EXPORTs
EXPORT_SYMBOL(kill_proc_info);
save & close out.

4. goto /usr/src/linux-x.y.z & do
$make bzImage
( i am not sure about <make modules modules_install> ,whether u should do it or no....)

5. issue the following still in same dir
cp arch/i386/boot/bzImage /boot/vmlinuz-x.y.z
(/boot/vmlinuz-x.y.z should already be existing unless u r doing a fresh kernel compile..go ahead & overwrite it)

restart & enjoy
possibly u might have to do /usr/share/lufs/prepmod again..but this time it will be clean
 
Old 09-07-2005, 05:58 AM   #4
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Original Poster
Rep: Reputation: 15
Wow, that worked!

Tanx a lot mayhemt, I had almost given up on this, and now you come and fix my problem with a simple line to edit
---
Btw, could you explain me why it worked with that line in that file?
and is captive secure for writing to ntfs without it messing up the partition?
 
Old 09-07-2005, 06:30 PM   #5
mayhemt
Member
 
Registered: Sep 2005
Location: irving TX
Distribution: SuSe, Kubuntu, Win$ucks
Posts: 50

Rep: Reputation: 15
hehe..i m not that hardcore linux geek....(i do most stuff on mainframes..LOL)
but my idea is this
captive had been in development & support for a while when kernel was in 2.4 stages & in early 2.6 stages... the author Jan finally stopped working on it. Meanwhile Linus & others working on kernels..dropped the dreadful kill_proc_info (which is still needed by lufs modules) from the code post kernel 2.6.6 (or earlier..dont know when it exactly happnd) ...so we hacked kernel to export this variable...dats all

is captive secure? captive is written basically around windows NTFS drivers itself...so it should be pretty safe according to the author of captive. However its slow to write huge files atleast on my linux box. its safer than the kernel's in-built ntfs-write support module.
 
Old 09-08-2005, 04:00 AM   #6
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Original Poster
Rep: Reputation: 15
Tanx for the info, you really helped me out
 
Old 09-26-2005, 12:09 AM   #7
cowlip
LQ Newbie
 
Registered: Sep 2005
Posts: 3

Rep: Reputation: 0
Hi, instead of editing the kernel, you can do it this way, editing only prepmod:

sudo gedit /usr/share/lufs/2.6/inode.c

Search for:

/* notify the daemon that we're going bye-bye */


and then change "kill_proc_info" to just "kill_proc" and its good.
 
Old 11-25-2005, 06:18 PM   #8
ogin
LQ Newbie
 
Registered: Nov 2005
Posts: 11

Rep: Reputation: 1
thanks cowlip, it works nicely.
 
Old 04-01-2006, 08:21 PM   #9
trainpic
Member
 
Registered: Apr 2004
Location: Ohio
Distribution: Ubuntu 6.06 LTS (Ubuntu, Edubuntu, Ubuntu Server)
Posts: 77
Blog Entries: 2

Rep: Reputation: 15
Works for me now too on Ubuntu 5.10

Same problem, same solution
(edit inode.c)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone use captive-ntfs? bosewicht Linux - Newbie 1 06-03-2005 05:16 AM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 09:28 PM
What is Captive-NTFS? allforcarrie Mandriva 24 12-09-2004 07:58 AM
anyone using Captive NTFS? grapier Linux - General 0 01-16-2004 03:51 AM
Captive NTFS -- full r/w ntfs access for Linux spurious Linux - Software 6 01-09-2004 12:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration