LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-06-2006, 03:09 PM   #1
isuck@linux
Member
 
Registered: Jun 2006
Distribution: messed up debian
Posts: 250

Rep: Reputation: 30
Need help with apt-get and dependencies


I need some help with the apt-get output. I started trying to install ethereal using apt-get and I don't know how I ended up downloading X and a lot of other stuff. I downloaded 78 mb and finally got a lot of dependencies problems that I can't fix. If somebody please can guide me a bit on how to fix this kind of issues I'll really appreciate it. This are the outputs:

--(:root@elmotrina)-(/backup)--
--(1342:Sun,06 Aug 06:$)-- apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies...Done
The following extra packages will be installed:
libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev
libglu1-xorg libglu1-xorg-dev libgtk2.0-0 libgtk2.0-bin libxfixes3 mesa-common-dev
synaptic x-window-system-core x11-common xbase-clients xfonts-100dpi xfonts-75dpi
xfonts-base xfonts-encodings xfonts-scalable xfonts-utils xlibmesa-dri
xlibmesa-gl-dev xorg xserver-xorg xutils xutils-dev
Suggested packages:
dwww mesa-utils xfs xserver libglide3 libglide2 pdksh ssh-server rsh-server
ssh-client rsh-client
Recommended packages:
deborphan libgnome2-perl laptop-detect xresprobe discover
The following packages will be REMOVED
libglu1-xorg-dbg x-window-system-dev xlibmesa-gl xlibmesa-gl-dbg xlibosmesa-dev
xlibosmesa4 xlibosmesa4-dbg
The following NEW packages will be installed
libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev
libxfixes3 mesa-common-dev xbase-clients xfonts-encodings xfonts-utils xorg
xserver-xorg xutils xutils-dev
The following packages will be upgraded:
libglu1-xorg libglu1-xorg-dev libgtk2.0-0 libgtk2.0-bin synaptic
x-window-system-core x11-common xfonts-100dpi xfonts-75dpi xfonts-base
xfonts-scalable xlibmesa-dri xlibmesa-gl-dev
13 upgraded, 14 newly installed, 7 to remove and 648 not upgraded.
49 not fully installed or removed.
Need to get 0B/33.8MB of archives.
After unpacking 4135kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
x11-common libxfixes3 libgtk2.0-bin libgtk2.0-0 libglu1-xorg-dev libglu1-xorg
xlibmesa-gl-dev xlibmesa-dri x-window-system-core libgl1-mesa-glx libglu1-mesa
mesa-common-dev libgl1-mesa-dri libgl1-mesa-dev libglu1-mesa-dev xbase-clients
xserver-xorg xfonts-encodings xfonts-utils xfonts-base xfonts-100dpi xfonts-75dpi
xfonts-scalable xutils-dev xutils xorg synaptic
Install these packages without verification [y/N]? y
Preconfiguring packages ...
xserver-xorg config warning: Migrating xserver-xfree86 debconf values to
xserver-xorg.
(Reading database ... 112983 files and directories currently installed.)
Preparing to replace x11-common 6.8.2.dfsg.1-11 (using .../x11-common_1%3a7.0.22_i386.deb) ...
rmdir: `/usr/X11R6/bin': Directory not empty
dpkg: error processing /var/cache/apt/archives/x11-common_1%3a7.0.22_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
System startup links for /etc/init.d/x11-common already exist.
Setting up X server socket directory /tmp/.X11-unix...done.
Setting up ICE socket directory /tmp/.ICE-unix...done.
Errors were encountered while processing:
/var/cache/apt/archives/x11-common_1%3a7.0.22_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

--(:root@elmotrina)-(/backup)--
--(1345:Sun,06 Aug 06:$)-- apt-get install ethereal
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
ethereal: Depends: libadns1 but it is not going to be installed
Depends: libgnutls13 (>= 1.3.5) but it is not going to be installed
Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-1 is to be installed
Depends: libpcap0.8 (>= 0.9.3-1) but it is not going to be installed
Depends: libxfixes3 but it is not going to be installed
Depends: ethereal-common (= 0.99.0-1) but it is not going to be installed
freenx: Depends: xbase-clients but it is not going to be installed
kdelibs4: Depends: xbase-clients but it is not going to be installed
libgksu1.2-0: Depends: xbase-clients but it is not going to be installed
libgksuui1.0-0: Depends: xbase-clients but it is not going to be installed
synaptic: Depends: libapt-pkg-libc6.3-5-3.3 but it is not installable
x-window-system-core: Depends: xserver-xorg but it is not going to be installed
Depends: xbase-clients but it is not going to be installed
Depends: xutils but it is not going to be installed
xfonts-100dpi: Depends: xutils (> 4.0.3) but it is not going to be installed
xfonts-75dpi: Depends: xutils (> 4.0.3) but it is not going to be installed
xfonts-base: Depends: xutils (> 4.0.3) but it is not going to be installed
xfonts-scalable: Depends: xutils (> 4.0.3) but it is not going to be installed
xserver-xfree86: Depends: xserver-xorg but it is not going to be installed
xserver-xorg-core: Depends: x11-common (>= 1:7.0.0) but 6.8.2.dfsg.1-11 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I decided to start with x-window-system-core and tried to find the packages xserver-org in the debian search db but couldn't find it. I only found txt files. The same for most of them, I can't fix it because I don't even understand what's going on or what I did wrong. Thanks for your help!!!
 
Old 08-06-2006, 03:21 PM   #2
isuck@linux
Member
 
Registered: Jun 2006
Distribution: messed up debian
Posts: 250

Original Poster
Rep: Reputation: 30
by the way this is the ouptup when I try to install xfree86-common:
--(:root@elmotrina)-(/backup)--
--(1417:Sun,06 Aug 06:$)-- dpkg -i /home/elmo/xfree86-common_4.3.0.dfsg.1-14sarge1_all.deb
dpkg: regarding .../xfree86-common_4.3.0.dfsg.1-14sarge1_all.deb containing xfree86-common:
x11-common conflicts with xfree86-common (<< 6.8.0)
xfree86-common (version 4.3.0.dfsg.1-14sarge1) is to be installed.
dpkg: error processing /home/elmo/xfree86-common_4.3.0.dfsg.1-14sarge1_all.deb (--install):
conflicting packages - not installing xfree86-common
Errors were encountered while processing:
/home/elmo/xfree86-common_4.3.0.dfsg.1-14sarge1_all.deb

What is the problem, should I remove xfree86 and leave X or viceversa?
 
Old 08-09-2006, 10:19 AM   #3
isuck@linux
Member
 
Registered: Jun 2006
Distribution: messed up debian
Posts: 250

Original Poster
Rep: Reputation: 30
I hate you guys... I hate you very very much.
 
Old 08-09-2006, 11:20 AM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
I have seen several threads in which people tried their best to help you. You don't follow instructions, you mix repositories wildly, You make bigger and bigger messes, and expect someone to somehow provide you with some kind of magic solution.

If you want to use Debian, you have to show the same kind of maturity that Debian has. Do a clean install of Etch. Use the official Etch repositories, and learn to function within those limitations. When you are knowledgeable enough to do that efficiently, you'll be able to ask questions coherently, and use the advice given in a constructive manner.

A political truism says that with freedom comes responsibility. In the free computing world, its very nature suggests that there are rules which must be followed if you are to expect success. Your interpretation of freedom seems to include wild shooting into the darkness and some unlikely expectation that everything will work out by itself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get and dependencies FWSquatch Debian 8 02-02-2006 07:42 PM
Does apt-get has any dependencies Jzarecta Linux - Software 1 01-01-2006 04:15 PM
apt-get failed dependencies but robadawb Linux - Software 3 07-22-2005 12:09 PM
apt-get: don't resolve dependencies? merchtemeagle Debian 7 06-17-2005 02:11 PM
apt doesn't fix all dependencies :(? darkleaf Debian 4 07-25-2004 04:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration