LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Need help with a fserver script for xchat (https://www.linuxquestions.org/questions/linux-software-2/need-help-with-a-fserver-script-for-xchat-72162/)

bling bling 07-12-2003 03:02 PM

Need help with a fserver script for xchat
 
[edited]

I just got the Obsidian FServe 0.8.0 script for xchat. And after I load it, got everything setup and turn it on. I try and test it and after I put the trigger in I get a window but I can't brows files or use commands. I have asked other people if they can and it wont work for them ether.
What am I doing wrong??

unSpawn 07-12-2003 03:13 PM

What am I doing wrong?
Lotsa things :-]

To start with:
Code:

]$ showlines tmp/obsidian-0.9.1-pre3.pl 16 22
#      If You have any problems with this software please try to gather as
#      much information as possible before sending a typical "don't work,
#      help now." email. If You don't know the exact nature and cause of
#      the problem send as much info as possible. This should at least
#      contain the version of xchat, perl, obsidian fserve, operation system,
#      a copy or exception of the file .xchat/obsidian.conf and any
#      messages that appear when loading this script.

Like the author wrote, you're basically saying "don't work" instead of looking at the next four lines where he tells you what to include.
*Also note this version I extracted the lines from is 0.9.1-pre3, so 0.75 definately is WAY OLD.

bling bling 07-12-2003 03:29 PM

Ok I have xchat 2.03, perl 2.03, obsidian 0.8.0, slakware9.0, the file says

10:::2:::20:::5:::9728:::180:::!me-wants-stuff:::#gfaqs-chat:::900:::/mnt/download:::0::::::0:::0:::0:::13:::14:::13:::15:::0:::don't be a leach:::0:::

When I load the script I get
[O▀sidian FServe] Initializing...
[O▀sidian FServe] Config file loaded...

And that is it.

Sorry bout that the one I have is 0.8.0 not 0.7.5.
Sorry I forgot which one I was using.

DrOzz 07-12-2003 03:34 PM

well you almost finished reading but you missed one part...
Quote:

a copy or exception of the file .xchat/obsidian.conf
cause from what you already stated the file says its itializing and loading and thats all cool, but maybe there is something in your config file thats screwing the whole process of allowing someone to view the files....so a copy of that may help someone find something to help you.

bling bling 07-12-2003 03:42 PM

This is a copy of the WHOLE config file

10:::2:::20:::5:::9728:::180:::!me-wants-stuff:::#gfaqs-chat:::900:::/mnt/download:::0::::::0:::0:::0:::13:::14:::13:::15:::0:::don't be a leach:::0:::

That's it.

DrOzz 07-12-2003 03:50 PM

weird i am at a loss....i don't know how to decifer that.
if i knew what all the numbers were for it may make more sense to me.

DrOzz 07-12-2003 03:56 PM

but as i think of it now, it may have something to do with file permissions in the /mnt/downloads folder...did you mount that folder as root, or regular user?

bling bling 07-12-2003 03:57 PM

Hold on let me post what I get when I do /fs vars.

bling bling 07-12-2003 03:58 PM

Ok got it

Quote:

[O▀sidian FServe] Variable Current Value
[O▀sidian FServe] ======== =============
[O▀sidian FServe] max_users 10
[O▀sidian FServe] max_sends 2
[O▀sidian FServe] max_queues 20
[O▀sidian FServe] slots_per_user 5
[O▀sidian FServe] idle_time 180
[O▀sidian FServe] min_speed 9728
[O▀sidian FServe] auto_backup 0
[O▀sidian FServe] trigger !me-wants-stuff
[O▀sidian FServe] notify_channel #gfaqs-chat
[O▀sidian FServe] notify_timeout 900
[O▀sidian FServe] notice_as_msg 1
[O▀sidian FServe] root_dir /mnt/download
[O▀sidian FServe] hilite_color %C13
[O▀sidian FServe] text_color %C14
[O▀sidian FServe] dir_color %C13
[O▀sidian FServe] file_color %C15
[O▀sidian FServe] logo [O▀sidian FServe]
[O▀sidian FServe] note don't be a leach

[O▀sidian FServe] All time values are in seconds, if notify_timeout,
[O▀sidian FServe] min_speed or auto_backup is set to zero, the
[O▀sidian FServe] the function is disabled...

DrOzz 07-12-2003 04:09 PM

so theres your problem:
root_dir /mnt/downloads

so make a share folder lets say in your home folder where you have complete access as a regular user and see if that makes anything different.

bling bling 07-12-2003 04:16 PM

I have access to that folder.
I have checked that just in case and I am sure I have access to it.
But I will try.

bling bling 07-12-2003 04:20 PM

Tried it still the same thing.

Mandra 10-09-2003 04:27 PM

Sorry to bring up an old issue but this was something I had to find out myself. Came here read the thread only to be disapointed with the lack of an anwer.

Obsidian ver was too low. 8.0 no good with xchat 2.*

He needed to load the newest version of Obsidian he could.

Today you can get 0.9.2Pre1 and it works great.







:newbie:


All times are GMT -5. The time now is 12:00 PM.