-   Linux - Software (
-   -   Need help to install Kup Backup System (

snowweb 02-22-2013 02:22 AM

Need help to install Kup Backup System
I'm trying to install Kup Backup System

I cloned the git repository here to my computer and checked the readme file, which I share below:


$ cat README
To compile you need:
 - CMake
 - Development headers for libqt4, libkdeui, libkfile and libsolid.

Run from the source directory:
mkdir build
cd build
cmake ..
sudo make install

Note that this will install a policykit file that allows any user to have kup run 'bup' as root without asking for password.

I have cmake already, but when I tried to install the next item - 'libqt4-dev' (which I guess is what they mean by 'development headers), I got the following output:


$ sudo aptitude install libqt4-dev
The following NEW packages will be installed:
  libdrm-dev{a} libdrm-nouveau2{a} libgl1-mesa-dev{a} libglu1-mesa-dev{a} libkms1{a} libpthread-stubs0{a}
  libpthread-stubs0-dev{a} libqt4-dev libqt4-opengl-dev{a} libqtwebkit-dev{a} libx11-dev{a} libx11-doc{a}
  libxau-dev{a} libxcb1-dev{a} libxdmcp-dev{a} libxext-dev{a} mesa-common-dev{a} qt4-linguist-tools{a}
  qt4-qmake{a} x11proto-core-dev{a} x11proto-input-dev{a} x11proto-kb-dev{a} x11proto-xext-dev{a}
  xorg-sgml-doctools{a} xtrans-dev{a}
The following packages will be upgraded:
  libqt4-dbus libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl
  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-svg libqt4-test libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtgui4 qdbus
17 packages upgraded, 25 newly installed, 0 to remove and 21 not upgraded.
Need to get 25.4 MB of archives. After unpacking 46.7 MB will be used.
The following packages have unmet dependencies:
 libqt4-sql-mysql : Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is to be installed.
                    Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is to be installed.
 libqt4-sql-sqlite : Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is to be installed.
                    Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.1-0ubuntu4.4 is to be installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

      Remove the following packages:
1)      akonadi-backend-mysql
2)      akonadi-server
3)      akregator
4)      apport-kde
5)      apturl-kde
6)      jockey-kde
7)      kaddressbook
8)      kde-config-touchpad
9)      kde-workspace
10)    kde-workspace-bin
11)    kdepim-kresources
12)    kdepim-runtime
13)    kdepim-strigi-plugins
14)    kmail
15)    knotes
16)    kontact
17)    kopete
18)    kopete-message-indicator
19)    korganizer
20)    ktimetracker
21)    kubuntu-desktop
22)    language-selector-kde
23)    libcalendarsupport4
24)    libeventviews4
25)    libincidenceeditorsng4
26)    libkdepim4
27)    libkdepimdbusinterfaces4
28)    libkopete4
29)    libksieveui4
30)    libmailcommon4
31)    libmessagecomposer4
32)    libmessagecore4
33)    libmessagelist4
34)    libmessageviewer4
35)    libmuonprivate1
36)    libqt4-sql-mysql
37)    libqt4-sql-sqlite
38)    libtemplateparser4
39)    muon
40)    muon-installer
41)    muon-notifier
42)    muon-updater
43)    plasma-dataengines-workspace
44)    plasma-desktop
45)    plasma-netbook
46)    plasma-scriptengine-python
47)    plasma-widget-facebook
48)    plasma-widgets-addons
49)    plasma-widgets-workspace
50)    printer-applet
51)    python-kde4
52)    quassel
53)    software-properties-kde
54)    system-config-printer-kde
55)    update-manager-kde
56)    usb-creator-kde
57)    userconfig

      Leave the following dependencies unresolved:
58)    kubuntu-desktop recommends quassel
59)    kubuntu-notification-helper recommends apport-kde | apport-gtk
60)    kontact recommends kmail
61)    kontact recommends knotes
62)    kontact recommends kaddressbook
63)    kopete recommends libqt4-sql-sqlite
64)    libkopete4 recommends kopete (= 4:4.8.5-0ubuntu0.2)
65)    libqt4-sql recommends libqt4-sql-mysql | libqt4-sql-odbc | libqt4-sql-psql | libqt4-sql-sqlite

Accept this solution? [Y/n/q/?]

This looks pretty scary to me. Any advice would be much appreciated!

I'm running Kubuntu 12.04.01.


snowweb 02-22-2013 02:41 AM

I've just solved this.

Below the link the GIt repo in the download page, I found a list of .deb files for each distro! Sorry - should have carried on reading!

All times are GMT -5. The time now is 01:40 PM.