LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Need help setting up virtual users with pure-ftpd (https://www.linuxquestions.org/questions/linux-software-2/need-help-setting-up-virtual-users-with-pure-ftpd-595534/)

GavB 10-29-2007 01:06 PM

Need help setting up virtual users with pure-ftpd
 
Hi,

I am trying to install pure-ftpd with virtual users and it looks like I'm almost there but am getting access denied errors when trying to log in. I'll go through everything that I've done so far:

To install..

./configure --with-everything
make
make install

I then set up a group and user (ftpgroup and ftpuser) as described here

I then set up a virtual user like this:

pure-pw useradd vusername -u ftpuser -d /path/to/user/files

It looks like it has worked because the following line has been added to /etc/pureftpd.passwd

vusername:<encrypted password>:500:500::/path/to/user/files/./::::::::::::

and when I run pure-pw show vusername it shows all of the user info. The problem is that when I log in via ftp, I get "530 Login authentication failed".

Does anyone have any idea how to get this running? any help would be appreciated.

Thanks for reading :)

EDIT: I am running CentOS by the way if that makes a difference

GavB 10-30-2007 09:28 AM

I've worked it out now, just for anyone that searches with the same problem in future, here is what I did:

After setting up the users, run the following command:

pure-pw mkdb

(I'm not sure if you have to run that command after each time you make changes to users or just once)

then stop pure-ftpd (I just did killall pure-ftpd) and run:

/usr/local/sbin/pure-ftpd -j -lpuredb:/etc/pureftpd.pdb &

lukaszp 07-27-2009 11:48 AM

I did what you have written here but instead used /etc/init.d/pure-ftpd restart to restart the server. I did not change anything and my virtual users are still not accepted.

I have the user created with pure-pw adduser. That user has a valid home directory and a password set. I have executed pure-pw mkdb after creating the user. I have also enabled PureDB in the /etc/pure-ftpd.conf file so the option looks like this

PureDB /etc/pureftpd.pdb

Is there any conflict if I'm also using PAM authentication at the same time? There's associated (I think) option:

ExtAuth /var/run/ftpd.sock

Should I disable this authentication module?

Thanks for any help you can spare

Andy_m 08-07-2009 05:26 AM

Quote:

Originally Posted by GavB (Post 2942249)
I've worked it out now, just for anyone that searches with the same problem in future, here is what I did:

After setting up the users, run the following command:

pure-pw mkdb

(I'm not sure if you have to run that command after each time you make changes to users or just once)

then stop pure-ftpd (I just did killall pure-ftpd) and run:

/usr/local/sbin/pure-ftpd -j -lpuredb:/etc/pureftpd.pdb &

This worked for me, although I stopped pure-ftpd this way "service pure-ftpd stop" and then did start when finished. Thank You

scottro11 08-07-2009 05:52 AM

I have a very dated, and FreeBSD-centric page on it. (Very slow site, I fear, and not always up, but...)

http://www.scottro.net/qnd/qnd-pureftpd.html


All times are GMT -5. The time now is 11:24 AM.