LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2005, 01:49 PM   #1
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Rep: Reputation: 30
need help installing kdetv... please


sys is 1.7ghz, 512m ram
120g hdc, 160g hdd
cd-rw, dual cd/dvd-rw
Hauppauge WinTV PVR 350
MDK 10.2, KDE 3.3.2, W98

kdetv-kdetv: 0.8.2

I have read faq after faq, googled the subject all morning.
I need help.

dlw

kdetv hangs while starting.
The following is from a console.

[don@localhost ~]$ kdetv
kdetv: WARNING: Sourcemanager: No screenwidget set! Cannot scan video plugins!
kdetv: WARNING: OSDManager: No screenwidget set! Cannot scan OSD plugins!
kdetv: WARNING: MiscManager: No screenwidget set! Cannot scan Misc plugins!
Try to open v4l2 vbi device, libzvbi interface rev.
$Id: io-v4l2.c,v 1.25 2004/02/18 07:56:45 mschimek Exp $Opened /dev/vbi
Try to open v4l2 (2002-10) vbi device, libzvbi interface rev.
$Id: io-v4l2k.c,v 1.18 2004/04/09 05:18:16 mschimek Exp $Opened /dev/vbi
/dev/vbi (Vanilla iTVC15 card) is a v4l2 vbi device,
driver ivtv, version 0x00000200
Current scanning system is 525
Querying current vbi parameters... success
VBI capture parameters granted: format 59455247, 27000000 Hz, 1443 bpl, offs 248, F1 10+12, F2 273+12, flags 00000000
Nyquist check passed
Request decoding of services 0x60000c7f
Will decode services 0x00000860
Using streaming interface
Fifo initialized
Requesting streaming i/o buffers
Try to open v4l vbi device, libzvbi interface rev.
$Id: io-v4l.c,v 1.20 2003/11/14 05:29:18 mschimek Exp $Opened /dev/vbi
Driver name 'Vanilla iTVC15 card'
Attempt to guess the videostandard
Driver supports VIDIOCGTUNER: 1
Videostandard is NTSC
/dev/vbi (Vanilla iTVC15 card) is a v4l vbi device
Hinted video standard 0, guessed 525
Driver supports VIDIOCGVBIFMT, guessed videostandard 525
Accept current vbi parameters
Guessed videostandard 525
Nyquist check passed
Will decode services 0x00000860
Warning: no read select, reading will block
Capture buffer allocated
Successful opened /dev/vbi (Vanilla iTVC15 card)
kdetv: WARNING: MainWindow::setupInfraRed(): Lirc not available
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
v4ldev::grab() [mmap]: error: wanted 0, got rc = -1
Too many errors. Ending V4L grabbing.
QWidget::updateFrameStrut(): ERROR - no parent
QWidget::updateFrameStrut(): ERROR - no parent
V4LGrabber::~V4LGrabber(): wait().
V4LGrabber::~V4LGrabber(): deleted.

[don@localhost man5]$ xawtv
This is xawtv-3.93, running on Linux/i686 (2.6.11-1mdk)
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x30
Segmentation fault

Last edited by d1l2w3; 03-17-2005 at 03:27 PM.
 
Old 03-17-2005, 02:09 PM   #2
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
To me, it seems possible that your v4l drivers are possibly messed up. Maybe you should try recompiling the driver you use to interface with your hardware. Recompiling v4l itself means recompiling the kernel, and I think that's a bit much for here. Check out http://www.exploits.org/v4l/

However, before you recompile anything, you should check if the problem is with kdetv itself. Try to see if you can find a source package online with a newer version. Or try a different program entirely to see if it can grab from the capture source. For this I recommend TVtime.
 
Old 03-17-2005, 02:26 PM   #3
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 33
hello,

hmm, this does look v4l related. Just guessing here, but it might be worth checking that the xorg v4l module is being loaded by your x server - check xorg.conf / xf86config file. Check also that the xv extension for your graphics card is working correctly - open a console and type 'xvinfo' - a load of information should be returned if all is well.

other than that, how about trying a pre-packaged kdetv - it might be easier...

have to say, i've had plenty of trouble with v4l myself, and any fixes i've made have been more through luck than judgement...

good luck!

PS - i've found TVTime to be a superior application, and if you've got your mandrake cd's handy, you'll find it there... picture quality is better than kdetv; only thing it lacks (at the moment) is a teletext decoder...
 
Old 03-17-2005, 03:23 PM   #4
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Installed tvtime.
First thing is blue screen with 'no signal'
right click for setup, click on 'change video source'
Nothing happens. Other menu idems have drop down menus.

There is a signal on channel three in 'kdetv'.

I used an rpm via 'urpmi'
I've removed it and reinstalled it twice.

[root@localhost X11]# xvinfo
X-Video Extension version 2.2
screen #0
Adaptor #0: "video4linux"
number of ports: 1
port base: 69
operations supported: PutVideo
supported visuals:
depth 24, visualID 0x23
depth 24, visualID 0x24
depth 24, visualID 0x25
depth 24, visualID 0x26
depth 24, visualID 0x27
depth 24, visualID 0x28
depth 24, visualID 0x29
depth 24, visualID 0x2a
number of attributes: 7
"XV_ENCODING" (range -1000 to 1000)
client settable attribute
client gettable attribute (current value is 0)
"XV_BRIGHTNESS" (range -1000 to 1000)
client settable attribute
client gettable attribute (current value is 0)
"XV_CONTRAST" (range -1000 to 1000)
client settable attribute
client gettable attribute (current value is 0)
"XV_SATURATION" (range -1000 to 1000)
client settable attribute
client gettable attribute (current value is 0)
"XV_HUE" (range -1000 to 1000)
client settable attribute
client gettable attribute (current value is 0)
"XV_MUTE" (range 0 to 1)
client settable attribute
client gettable attribute (current value is 0)
"XV_FREQ" (range 0 to 16000)
client settable attribute
client gettable attribute (current value is 0)
number of encodings: 28
encoding ID #0: "PAL-television"
size: 768 x 576
rate: 0.020000
encoding ID #1: "NTSC-television"
size: 640 x 480
rate: 0.016683
encoding ID #2: "SECAM-television"
size: 768 x 576
rate: 0.020000
encoding ID #3: "PAL-Nc-television"
size: 640 x 576
rate: 0.020000
encoding ID #4: "PAL-M-television"
size: 640 x 576
rate: 0.020000
encoding ID #5: "PAL-N-television"
size: 768 x 576
rate: 0.020000
encoding ID #6: "NTSC-JP-television"
size: 640 x 480
rate: 0.016683
encoding ID #7: "PAL-composite1"
size: 768 x 576
rate: 0.020000
encoding ID #8: "NTSC-composite1"
size: 640 x 480
rate: 0.016683
encoding ID #9: "SECAM-composite1"
size: 768 x 576
rate: 0.020000
encoding ID #10: "PAL-Nc-composite1"
size: 640 x 576
rate: 0.020000
encoding ID #11: "PAL-M-composite1"
size: 640 x 576
rate: 0.020000
encoding ID #12: "PAL-N-composite1"
size: 768 x 576
rate: 0.020000
encoding ID #13: "NTSC-JP-composite1"
size: 640 x 480
rate: 0.016683
encoding ID #14: "PAL-svideo"
size: 768 x 576
rate: 0.020000
encoding ID #15: "NTSC-svideo"
size: 640 x 480
rate: 0.016683
encoding ID #16: "SECAM-svideo"
size: 768 x 576
rate: 0.020000
encoding ID #17: "PAL-Nc-svideo"
size: 640 x 576
rate: 0.020000
encoding ID #18: "PAL-M-svideo"
size: 640 x 576
rate: 0.020000
encoding ID #19: "PAL-N-svideo"
size: 768 x 576
rate: 0.020000
encoding ID #20: "NTSC-JP-svideo"
size: 640 x 480
rate: 0.016683
encoding ID #21: "PAL-composite3"
size: 768 x 576
rate: 0.020000
encoding ID #22: "NTSC-composite3"
size: 640 x 480
rate: 0.016683
encoding ID #23: "SECAM-composite3"
size: 768 x 576
rate: 0.020000
encoding ID #24: "PAL-Nc-composite3"
size: 640 x 576
rate: 0.020000
encoding ID #25: "PAL-M-composite3"
size: 640 x 576
rate: 0.020000
encoding ID #26: "PAL-N-composite3"
size: 768 x 576
rate: 0.020000
encoding ID #27: "NTSC-JP-composite3"
size: 640 x 480
rate: 0.016683
Adaptor #1: "ATI Rage128 Video Overlay"
number of ports: 1
port base: 70
operations supported: PutImage
supported visuals:
depth 24, visualID 0x23
depth 24, visualID 0x24
depth 24, visualID 0x25
depth 24, visualID 0x26
depth 24, visualID 0x27
depth 24, visualID 0x28
depth 24, visualID 0x29
depth 24, visualID 0x2a
depth 24, visualID 0x2b
depth 24, visualID 0x2c
depth 24, visualID 0x2d
depth 24, visualID 0x2e
depth 24, visualID 0x2f
depth 24, visualID 0x30
depth 24, visualID 0x31
depth 24, visualID 0x32
number of attributes: 4
"XV_COLORKEY" (range 0 to 16777215)
client settable attribute
client gettable attribute (current value is 30)
"XV_BRIGHTNESS" (range -64 to 63)
client settable attribute
client gettable attribute (current value is 0)
"XV_SATURATION" (range 0 to 31)
client settable attribute
client gettable attribute (current value is 16)
"XV_DOUBLE_BUFFER" (range 0 to 1)
client settable attribute
client gettable attribute (current value is 0)
maximum XvImage size: 2048 x 2048
Number of image formats: 4
id: 0x32595559 (YUY2)
guid: 59555932-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x59565955 (UYVY)
guid: 55595659-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x32315659 (YV12)
guid: 59563132-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
id: 0x30323449 (I420)
guid: 49343230-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
[root@localhost X11]#
[root@localhost X11]# lsmod
Module Size Used by
raw 6560 1
r128 43520 1
drm 57524 2 r128
md5 3808 1
ipv6 226272 19
rfcomm 30972 0
l2cap 20068 5 rfcomm
bluetooth 40612 4 rfcomm,l2cap
snd-seq-dummy 2500 0
snd-seq-oss 30272 0
snd-seq-midi-event 6240 1 snd-seq-oss
snd-seq 46512 5 snd-seq-dummy,snd-seq-oss,snd-seq-midi-event
snd-seq-device 6636 3 snd-seq-dummy,snd-seq-oss,snd-seq
snd-pcm-oss 46240 0
snd-mixer-oss 16320 2 snd-pcm-oss
snd-intel8x0 27808 2
snd-ac97-codec 74104 1 snd-intel8x0
snd-pcm 77096 3 snd-pcm-oss,snd-intel8x0,snd-ac97-codec
snd-timer 19332 2 snd-seq,snd-pcm
snd-page-alloc 7268 2 snd-intel8x0,snd-pcm
snd 45380 11 snd-seq-oss,snd-seq,snd-seq-device,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer
soundcore 6720 2 snd
parport_pc 29956 1
lp 9672 0
parport 31016 2 parport_pc,lp
ppp_synctty 7520 0
ppp_async 8768 1
crc-ccitt 1664 1 ppp_async
ppp_generic 23668 6 ppp_synctty,ppp_async
slhc 6112 1 ppp_generic
af_packet 15912 4
floppy 53552 0
tulip 47296 0
ide-cd 34784 0
loop 12456 0
nls_iso8859-1 3744 1
nls_cp850 4544 1
vfat 11168 1
fat 35612 1 vfat
supermount 31956 1
nvidia-agp 5852 1
agpgart 26120 2 drm,nvidia-agp
bttv 143440 0
video-buf 16836 1 bttv
firmware_class 7008 1 bttv
v4l2-common 4672 1 bttv
btcx-risc 3848 1 bttv
msp3400 23592 0
saa7127 11164 0
saa7115 11640 0
tuner 20036 0
tveeprom 11352 1 bttv
ivtv 803908 2
i2c-algo-bit 8232 2 bttv,ivtv
i2c-core 18964 7 bttv,msp3400,saa7127,saa7115,tuner,tveeprom,i2c-algo-bit
videodev 7200 4 bttv,ivtv
usblp 10560 0
ehci-hcd 26888 0
ohci-hcd 18088 0
usbcore 101720 4 usblp,ehci-hcd,ohci-hcd
reiserfs 254548 1

Section "Module"
Load "v4l" #Video 4 Linux module
Load "dbe" # Double-Buffering Extension
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
Load "/usr/X11R6/lib/modules/extensions/libglx.a"

[don@localhost man5]$ xawtv
This is xawtv-3.93, running on Linux/i686 (2.6.11-1mdk)
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x30
Segmentation fault

Last edited by d1l2w3; 03-17-2005 at 03:29 PM.
 
Old 03-17-2005, 04:28 PM   #5
eadwine
Member
 
Registered: Mar 2005
Distribution: SimplyMepis 6.0
Posts: 37

Rep: Reputation: 15
Quote:
Originally posted by d1l2w3
Installed tvtime.
First thing is blue screen with 'no signal'
right click for setup, click on 'change video source'
Nothing happens. Other menu idems have drop down menus.
Try starting it from a terminal (if possible in your distro) like this: tvtime --device=/dev/video1

Change video1 to whichever your tv card may be set as.


Hopefully that will do the trick for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kdetv and soundstreams floris Linux - Software 0 03-10-2005 04:04 PM
Problem in installing Kdetv on fedora 3 linux_freak_imt Linux - Software 1 01-16-2005 04:36 PM
KDETV no sound ?? ronronson Linux - Software 0 07-19-2004 12:37 PM
No sound with KDETV ronronson Linux - Newbie 0 07-18-2004 03:12 PM
installing kdetv 0.8.1 on fedora core 2 hbsyn Linux - Software 1 06-14-2004 10:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration