LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Need help burning DVDs (https://www.linuxquestions.org/questions/linux-software-2/need-help-burning-dvds-469200/)

Cosmic 07-30-2006 05:21 PM

Need help burning DVDs
 
I'm an Ubuntu 5.10 user. I use Gnome. I've setup and configured a Win-PVR-150 and captured a TV program. I used avidemux to strip out the commercials. What do I need to do to burn this to a DVD? It is an 'mpg' file.

I looked on a DVD I own and see it contains 2 directories:

audio_ts and video_ts.

audio_ts is empty and video_ts contains various 'VOB', 'IFO' and 'BUP files. I understand the 'VOB' files are the 'video object' files, 'IFO' files are 'info' files and 'BUP' files are 'backup' files of the 'IFO' files.

What exactly do I need to do to burn this to a DVD? How do I create the audio_ts and video_ts directories? I have installed and run videotrans (it gives me an error during the dvdauthor portion - I can re-run it if anyone cares to look at the output). I also tried Qdvdauthor, with the same results. I've tried DVDStyler, and when I start it up, I get:

(dvdstyler:6798): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already atta ched to GtkMenuItem

I go thru creating a menu and button and it ends, almost immediately, with:

Segmentation fault

It does create a background, 3 versions of the button and an xml file.

I've tried for 2 days now and am not any closer to creating a DVD than when I started, although I now have a lot of new software installed.

Any help would be appreciated.

--- --- --- EDIT --- --- ---

Upgraded to tovid 0.28, it's now giving me the error below, but did create audio_ts and video_ts directories with vob ifo and bup files. Manually copying these over to DVD didn't work.

INFO: dvdauthor creating table of contents
INFO: Scanning /temp/Untitled_disc/VIDEO_TS/VTS_01_0.IFO
=========================================================
Disc structure successfully created in directory: /temp/Untitled_disc.
Authoring completed.
=========================================================
Please insert a blank DVD+/-R(W) disc into your DVD-recorder
(/dev/hdc) if you have not already done so.
=========================================================
Found blank DVD+R.
=========================================================
Cannot continue! DVD image (1292MB) exceeds the DVD's capacity (0MB).
Exiting...

b0uncer 08-01-2006 02:00 AM

Quote:

Cannot continue! DVD image (1292MB) exceeds the DVD's capacity (0MB).
Exiting...
That's funny - a "0 MB DVD" :) well that might be your problem. Check out that you have a right kind of DVD (if your drive only supports R-, then make sure you have a R- disc or if it supports R+, then make sure you have an R+ disc etc.), and also try if you need to have the disc either unmounted or mounted before the program can use it.

k3b can handle some kind of DVDs but I'm not certain if it can do what you want. You could try it out too. But here the problem is you can't seem to access the disc (or then your program can't recognize it correctly). Make sure the program is searching the disc from the correct drive, and that the disc actually works (and it's empty -- can you burn data on it using some other tool?).

Cosmic 08-01-2006 07:53 AM

Thanks for responding b0uncer,

Quote:

Originally Posted by Cosmic
=========================================================
Found blank DVD+R.
=========================================================

so it appears to find and identify the +R DVD correctly.

I can use:

growisofs -dvd-compat -Z /dev/hdc -dvd-video /temp/Untitled_disc

where '/temp/Untitled_disc' is the directory that contains valid 'audio-ts' and 'video_ts' directories, and it burns a DVD that works (I've tried both +R and +RW and they play fine in my DVD player). I'd just like to be able to use 'one process' to do everything.


All times are GMT -5. The time now is 06:18 AM.