-   Linux - Software (
-   -   ndiswrapper on Linux Mint (

evolver 07-04-2013 11:32 PM

ndiswrapper on Linux Mint
Hi there...

Have been having moderate to severe problems with Wifi connections (slow rates, and even just will not connect to a Base Station), Atheros 9485 Network Card, ath9k driver, kernel version 3.5.0-17. Linux Mint 14 64bit KDE, + apt-get upgrade

Would like to do anything to fix it (update existing Ath9k drivers, find better ones) but keep coming up against problems.

I'm thinking that Ndiswrapper would solve my problems but seem to be having problems trying to get it working.

Tried to follow the instructions here but only got as far as uninstalling ndiswrapper files on my machine already, and installing module-assistant.

However, compiling ndiswrapper then returned:


make -C utils
make[1]: Entering directory `/home/adam/Desktop/ndiswrapper-1.58rc1/utils'
gcc -g -Wall -I../driver  -o loadndisdriver loadndisdriver.c
loadndisdriver.c:15:20: fatal error: stdlib.h: No such file or directory
compilation terminated.
make[1]: *** [loadndisdriver] Error 1
make[1]: Leaving directory `/home/adam/Desktop/ndiswrapper-1.58rc1/utils'
make: *** [utils] Error 2

Don't know what to make of this and would appreciate some help...



evo2 07-05-2013 12:01 AM

Hi Adam,

now I know why you were installing module-assistant :-)

Have you tested your wireless with another OS to ensure it is not a hardware issue? Eg try a live CD/DVD of another distro? If this works, instead of using ndiswrapper have you considered upgrading to Mint 15 which AFAIK is based on Ubuntu 13.04 and has a 3.8 kernel?



evolver 07-05-2013 01:13 AM

Hehe... Yep, I should maybe have explained it all at once, though it did seem like it was too much to ask for so I broke it down...

I'm afraid I don't have another OS handy - I'm currently travelling in the Amazon region and my laptop is all I have, it has no CD drive and the download speeds are pretty terrible here, even if I could get my network card to work properly :)

I suppose I would consider trying to download Mint 15 and installing that if it was nailed on to work, but thought I'd give Ndiswrapper a go first, as I had already noticed that when I first bought the machine and swapped windoze for mint, the wifi was much more patchy with mint. So I figured Ndiswrapper was the way to go... but hey, as you know, I'm no expert... ;)

evo2 07-05-2013 01:46 AM


oh out in the jungle - maybe not such a good place to be doing full system upgrades. I've not had experience with ndiswrapper: it was ditched by most as soon as actual linux drivers became available. I had a quick look at the youtube video you linked to but couldn't make out a single thing that was written in the terminal, so I really have no idea what you are actually doing.

I generally find the Debian wiki to be a good source for information related to kernel modules and drivers. Have you had a look at the following:

Just incase you didn't know, Mint is essentially the same as Ubuntu but with some extra packages (infact Mint uses Ubuntu binaries), and Ubuntu is just a derivative of Debian. As such the underlying nuts and bolts are pertty much the same and many things in the Debian wiki should mostly apply to a Mint system.



k3lt01 07-05-2013 02:19 AM

Install ndiswrapper from the repositories then try this set of commands


##### Make sure drivers are visible on the Desktop and in a terminal type or copy and past (modify when required) these commands 1 by 1

cd Desktop

sudo ndiswrapper -i xxxxXXX.inf #####(where xxxx.XXX.inf is the name of the driver file)

ndiswrapper -l

sudo depmod -a

sudo modprobe ndiswrapper

sudo ndiswrapper -m

echo "ndiswrapper"|sudo tee -a /etc/modules

sudo shutdown -r now

Try that and let us know how you go.

evolver 07-05-2013 02:04 PM

Right... OK.. well everything went fairly smoothly, the only slight hiccup being after


sudo ndiswapper -m

Which returned


module configuration already contains alias directive
However, don't know if I'm missing something here (obviously I am).. but on reboot the ndiswrapper driver fails to load (or the ath9k driver) and no wireless networking is available.

Checking the Windows Wireless Drivers GUI utility, shows Driver is installed and Hardware is present... but as mentioned, not loaded on startup.

Sure it's something straightforward, but a few pointers would be much appreciated...


evolver 07-05-2013 02:09 PM

I should add that 'Additional Drivers' Utility states 'No proprietary drivers are in use on this system' which seems correct as if they were I'd likely have Wifi...


evolver 07-05-2013 02:39 PM

Searching around for likely solutions, I tried:


modprobe ndiswrapper
Which didnt return any error, but didn't load any wifi drivers.


modprobe ath9k
..however, did get the Wifi working again, temporarily...

jefro 07-05-2013 03:20 PM

Just a note. I did try ndiswapper on some distro's a while back. Many have already put part of ndiswrapper in their distro and all you have to do is finish the install. What that last step was I don't remember but it was on some web pages.

evolver 07-05-2013 07:31 PM

OK - resolved... follow the instructions I linked to in my first post, and on the page they link to in the video... just remember to find the right version of your Windoze driver... although I found the right driver for my hardware, Ndiswrapper was not able to deal with the W7 driver, it needed to be XP... simples...

Thanks for all your help...........................

All times are GMT -5. The time now is 04:19 PM.