-   Linux - Software (
-   -   NagiosGraph fails precheck on RRDTool? (

thllgo 05-23-2011 06:02 PM

NagiosGraph fails precheck on RRDTool?

I'm trying to install NagiosGraph for the first time. I have downloaded nagiosgraph 1.4.4, un tar'd and run the " --check-prereq" command. Everything comes back just fine except the line

RRDs... ***FAIL***
I have downloaded and installed RRDTool 1.4.5, it compiled, installed and tested by generating the stripes.png file. What is NagiosGraph looking for? I don't know where to turn at this point.

thllgo 05-23-2011 07:03 PM

If I run the command

perl -MRRDs -le 'print q(ok!)'
I get

Can't load '/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/RRDs/'
for module RRDs: cannot open shared object file: No such file or directory at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/ line 230.
at -e line 0
Compilation failed in require.
BEGIN failed--compilation aborted.
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/RRDs/ exists and is 555 root root, tried to set it to 777, didn't work. got installed to /opt/rrdtool-1.4.5/lib/ (this is curious) should this be somewhere else?

thllgo 05-24-2011 12:32 PM

Found the problem, the install off RRDTool copied all the libs to /opt/rrdtool-1.4.5/lib/... and they needed to be in /usr/lib64. If I didn't need it I'd really dislike nagiosgraph and rrdtool.

keziacp 07-03-2014 03:20 PM

rrd doesnt work
Hi all,
Plese could someone help me?
I need to install nagiosgraph, but I cant do this, I am trying this for about 1 month. Actually I am trying to do the libary works, rrdtool.

It is installed when i put on my server: rrdtool I can see it.

root@nagios:/opt# rrdtool
RRDtool 1.4.3 Copyright 1997-2009 by Tobias Oetiker <>
Compiled Sep 23 2011 05:32:50

Usage: rrdtool [options] command command_options
Valid commands: create, update, updatev, graph, graphv, dump, restore,
last, lastupdate, first, info, fetch, tune,
resize, xport, flushcached

RRDtool is distributed under the Terms of the GNU General
Public License Version 2. (

For more information read the RRD manpages

But I dont know to do it work. Look:

root@nagios:/opt# perl -MRRDs -le 'print q(ok!)'
object version 1.4002 does not match bootstrap parameter %_ at /usr/perl5/5.12/lib/sun4-solaris-64int/ line 223.
Compilation failed in require.
BEGIN failed--compilation aborted.

I dont know now what to do. Some idea?
I am actually workink on a Solaris 11 on a Sun SPARC T3.


All times are GMT -5. The time now is 12:09 AM.