LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-02-2009, 03:45 AM   #1
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 657

Rep: Reputation: 40
Nagios RPM dependency error


Hello.


I'm running Nagios 3.0.3 with 1.4.11 plugins installed on the clients. Due to a bug in nagios-plugins-ntp-1.4.11 I need to upgrade to 1.4.13. The packages are downloaded from the EPEL repository and downloaded on RHEL 5 systems.

I downloaded nagios-plugins-ntp-1.4.13 and tried to install it, but yum claimed that the package has a dependency to nagios-plugins-1.4.13. The rest of the plugins are still version 1.4.11.

So my question is this: What does the nagios-plugins packages do? I thought that this package was just a bundle of all the plugins, but I must clearly be wrong. And furthermore: If the nagios-plugins-ntp package (and all the other packages) has a dependency to the nagios-plugins package, I will not be able to upgrade only one of the plugins to the same version. Is there a way to work around this?

Regards,
kenneho
 
Old 01-02-2009, 05:51 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
The nagios-plugins is a basic package containing
Quote:
/usr/lib/nagios/plugins/
/usr/lib/nagios/plugins/negate
/usr/lib/nagios/plugins/urlize
/usr/lib/nagios/plugins/utils.sh
/usr/share/doc/nagios-plugins-1.4.13
( and more docs ......... )
Have a look here .. 1.4.13
http://rpm.pbone.net/index.php3/stat....i386.rpm.html
....
'rpm -ql nagios-plugins' will display all files in
the installed version.
....

Last edited by knudfl; 01-02-2009 at 05:59 AM.
 
Old 01-02-2009, 06:26 AM   #3
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 657

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by knudfl View Post
The nagios-plugins is a basic package containing

Have a look here .. 1.4.13
http://rpm.pbone.net/index.php3/stat....i386.rpm.html
....
'rpm -ql nagios-plugins' will display all files in
the installed version.
....
Thanks.

So the nagios-plugins package contains some common files necessary for the plugins to work. And following this, it is not possible to have a combination of 1.4.11 and 1.4.13 plugins. Right? If so, I must say I'd rather have the plugins installed separately, and with no depenencies, so that I could choose whatever version I'd like.


Btw, I was puzzled but the "this package.." part (from the site that was referred to):
Quote:
The actual service checks are performed by separate \"plugin\"
programs which return the status of the checks to Nagios. This package
contains those plugins.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
correct .rpm package for freewrl software which doesnt give dependency error rkarthi2k5 Linux - Software 3 12-13-2008 01:19 AM
"Failed Dependency error" while installing RPM for "DateTime" perl modules giridhargopal.cj Linux - Newbie 7 11-19-2008 12:05 AM
RPM dependency help (apt 4 rpm) Cubsy Linux - Software 4 10-08-2004 04:15 PM
RPM dependency Error ministre Linux - Software 2 07-27-2003 03:45 PM
Help : rpm dependency error when install video driver rpm ymdwxm Linux - Software 1 04-04-2003 04:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration