LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-14-2007, 01:05 PM   #1
tgridley
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
Nagios Help ---cisco plugin


Hello,

I am using Naios and have installed a plugin to check memory of a Cisco router. I can get the check to work when I run it on the command line as shown:

check_snmp_cisco_memfree -w 70 -c 60 -h xxx.x.xxx.xx -s xxxxx

this will return:

MEM OK [74% free (45538k of 181338k in use)]


so I know the plugin works, it connects to the router and polls the info.

My problem is when I integrate it into Naios I get a "SNMP Error" under the status info of that device. Does any one know what would cause that? I have been playing around with the defining the command and service in different ways. This is how I have it now:

# check_snmp_cisco_memfree
define command{
command_name check_snmp_cisco_memfree
command_line /usr/local/nagios/libexec/check_snmp_cisco_memfree -w $ARG1$ -c $ARG2$ -h $ARG3$ -s $ARG4$
}


define service{
use generic-service
host_name gatekeeper1
service_description Memory
check_command check_snmp_cisco_memfree!70!60!xx.xxx.xxx.xx!xxxxx
}


Any help would be appreciated. Note the x's are not really x's
 
Old 12-17-2007, 03:19 AM   #2
khaled_h
LQ Newbie
 
Registered: Mar 2007
Distribution: Fedora Core, SuSE, RH
Posts: 6

Rep: Reputation: 0
Hi,

Being able to run the command from the shell is not everything, you have to make sure for example that you run the command using the same username as that of nagios.

Try to run it using the same username as nagios username.
Check the file permissions under /usr/local/nagios/libexec/
 
Old 08-11-2011, 09:42 AM   #3
Majed17
Member
 
Registered: Jul 2011
Posts: 102

Rep: Reputation: Disabled
solution

here is what you need to change to :

# check_snmp_cisco_memfree
define command{
command_name check_snmp_cisco_memfree
command_line /usr/local/nagios/libexec/check_snmp_cisco_memfree -w $ARG1$ -c $ARG2$ -h $HOSTADDRESS$ -s $ARG3$
}


define service{
use generic-service
host_name gatekeeper1
service_description Memory
check_command check_snmp_cisco_memfree!70!60!xxxxx
}

just remove the host address from the command and service
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Nagios and Oreon (Nagios web front end) installation and Configuration LXer Syndicated Linux News 1 05-31-2016 08:26 AM
How to use Nagios plugin? dwarf007 Linux - Software 20 10-03-2011 07:11 AM
Nagios - nrpe plugin configuration nitin-saxena Linux - Software 1 10-27-2006 02:50 PM
Nagios: Raid Plugin kegwell Linux - Software 2 05-01-2005 12:38 PM
Nagios Plugin Compile Anarusis Linux - Software 3 04-10-2005 03:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration