LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-21-2008, 10:32 PM   #1
dad
Member
 
Registered: Sep 2003
Location: Florida
Distribution: Ubuntu
Posts: 139

Rep: Reputation: 16
Mythtv huappuage 350


I installed a Huappuage 350 card and I'm running Madriva 2008 64 bit. I have a Nvidia video card. The card seems to be recognized but I can not get anything to work with it for video capture, freetv, kino, xawtv, tvtime, etc.
Below is an error I get when I try to install Mythtv. I already have FreeType installed.
Does anyone have Mythtv working for this card?

[root@localhost mythtv-0.21]# ./configure
WARNING! An unknown C++ compiler flag in: "-Wall". Option(s) will be ignored.
WARNING! An unknown C++ compiler flag in: "-Wno-switch". Option(s) will be ignored.
WARNING! An unknown C++ compiler flag in: "-Wpointer-arith". Option(s) will be ignored.
WARNING! An unknown C++ compiler flag in: "-Wredundant-decls". Option(s) will be ignored.
WARNING! An unknown C++ compiler flag in: "-Wno-non-virtual-dtor". Option(s) will be ignored.
WARNING! An unknown C++ compiler flag in: "-D__STDC_CONSTANT_MACROS". Option(s) will be ignored.
ERROR! You must have FreeType installed to compile MythTV.
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
mythtv-dev@mythtv.org mailing list or IRC #mythtv on irc.freenode.net
Include the log file "config.err" produced by configure as this will help
solving the problem.

Thanks..
 
Old 05-23-2008, 10:47 AM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
I assume you read the docs at www.mythtv.org and still unhappy?

try freevo
http://www.linux.com/feature/114146

BTW I do not have a tv card so can not help directly
 
Old 05-23-2008, 01:15 PM   #3
dad
Member
 
Registered: Sep 2003
Location: Florida
Distribution: Ubuntu
Posts: 139

Original Poster
Rep: Reputation: 16
Yeah, I went to there web site, installed lame and checked I have everything they said. I'm just not sure about versions.
I went ahead and tried to install the latest version of mythtv 0.20.2 and it almost works. when I do ./ it looks like it is ok. But there is no make. the instruction say do make -j 2 and its says no make, which is true. So I guess something is missing.

Version 0.20.1 also complained about firmware was missing. I could not find any firmware to install. I just remember I need to check this version for that.

Freevo locks up my computer and I can't get out of it.

I still see this in /var/syslog.....

May 23 11:43:38 localhost kernel: ACPI: PCI Interrupt 0000:02:09.0[A] -> Link [APC4] -> GSI 19 (level, low) -> IRQ 19
May 23 11:43:38 localhost kernel: ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
May 23 11:43:38 localhost kernel: ivtv0: unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)
May 23 11:43:38 localhost kernel: ivtv0: did you put the firmware in the hotplug firmware directory?
May 23 11:43:38 localhost kernel: ivtv0: Retry loading firmware
May 23 11:43:38 localhost kernel: ivtv0: unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)
May 23 11:43:38 localhost kernel: ivtv0: did you put the firmware in the hotplug firmware directory?
May 23 11:43:38 localhost kernel: ivtv0: Error initializing firmware
May 23 11:43:38 localhost kernel: ivtv0: Error -19 on initialization

Last edited by dad; 05-23-2008 at 01:19 PM. Reason: spastic brain function
 
Old 05-23-2008, 02:24 PM   #4
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,248
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
Quote:
Originally Posted by dad
ERROR! You must have FreeType installed to compile MythTV.
did you try installing freetype ?


then put the firmware for the hauppague 350 in place as instructed on the ivtv site..
http://ivtv.writeme.ch/tiki-index.ph...rmwareVersions
 
Old 06-03-2008, 11:19 PM   #5
dad
Member
 
Registered: Sep 2003
Location: Florida
Distribution: Ubuntu
Posts: 139

Original Poster
Rep: Reputation: 16
Ok, I'm back after I had to gut my computer and replace everything inside and reinstall Mandriva 2008.

I seem to have have Mythtv close to running, Well I think. I'm not sure exactly how to launch it, I tried mythtv -setup and I get this error now....

mythtv: error while loading shared libraries: libmythtv-0.20.2.so.0: cannot open shared object file: No such file or directory

I did a search and found it in two places, /usr/local/lib and under where in installed in /home/dad
So the library is there just not sure why its not seeing it.
 
Old 06-07-2008, 11:48 PM   #6
dad
Member
 
Registered: Sep 2003
Location: Florida
Distribution: Ubuntu
Posts: 139

Original Poster
Rep: Reputation: 16
Um, well I had to cheat! I made a windozes partition and installed it there. However its a little buggy. I can get one 30 minute VHS-c onto my hard drive but after that its done. If I turn it off for awhile and try again it will work. Seems like heat, likes to lock up in the middle of the second tape.
 
Old 06-08-2008, 01:51 AM   #7
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
maybe its the 64 bit mdv that is an issue....mythtv is 32 bit no?

try a live cd and see if that helps

http://www.mythbuntu.org/

and from knoppmyth wiki on setup
http://www.knoppmythwiki.org/index.p...IntoMytTVsetup
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Huappuage 350 no workie dad Linux - Hardware 1 05-29-2008 05:57 PM
yum install mythtv-suite, Mythtv, nothing found, atrpms THOR_Fedora Linux - Software 5 11-29-2006 04:13 PM
Mythtv and PVR-350 Some advice please! kmarvin Linux - Hardware 3 02-06-2006 01:00 PM
aironet 350 anomalie Linux - Networking 1 01-22-2004 11:15 AM
350 Aironet...Again mrant Linux - Laptop and Netbook 0 08-25-2003 08:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration