LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-26-2017, 05:47 PM   #1
brianiac
LQ Newbie
 
Registered: Jun 2004
Location: USA/WA/Spokane
Distribution: Ubuntu
Posts: 9

Rep: Reputation: 0
MythTV frontend unable to connect to backend after Mythbuntu to Ubuntu 16.04 upgrade


After the do-release-upgrade switched me from the defunct Mythbuntu distro to Ubuntu, and clobbered a bunch of my MythTV packages in the process, I've nearly got everything working again.

I had to reinstall some mythtv-* packages (notably mythtv-database), and set up MySQL after the upgrade removed it. Luckily all the data was intact. In MySQL, I had to enable networking and grant permissions to the mythconverg database. Now I can successfully connect to MySQL on the MythTV master backend server from the client, so the database connection is OK. Also, I'm able to run the MythTV frontend locally on the master backend server, so I know the MythTV stack there is working.

However, both the dedicated MythTV frontend as well as my standard Ubuntu workstation (which did not go through this upgrade) tell me "Connection refused" on the MythTV port 6543 when trying to connect to the master backend. Nothing shows in syslog on the server side, and 6543 is in use ("nc -lp 6543" fails). The UFW firewall is inactive/disabled on client and server (and workstation). This was not a problem before the upgrade, so it's extremely unlikely network hardware is to blame.

I'm out of ideas to figure out what is blocking the traffic to the MythTV backend master server. Does anyone else have suggestions?
 
Old 03-12-2017, 04:30 PM   #2
brianiac
LQ Newbie
 
Registered: Jun 2004
Location: USA/WA/Spokane
Distribution: Ubuntu
Posts: 9

Original Poster
Rep: Reputation: 0
Running netstat -4lnp |grep :6543 returns:

Quote:
tcp 0 0 127.0.0.1:6543 0.0.0.0:* LISTEN -
So this makes me think the port is binding to the 127.0.0.1 address rather than the actual server address I've entered. Even though the local Myth frontend on the server points to the full server address, this could explain things, but I'm not sure how to fix it even if this were the case.
 
Old 05-08-2017, 11:41 PM   #3
brianiac
LQ Newbie
 
Registered: Jun 2004
Location: USA/WA/Spokane
Distribution: Ubuntu
Posts: 9

Original Poster
Rep: Reputation: 0
Lightbulb Simple networking race condition at startup

It turns out the mythtv backend service was just starting before the network was up! Restarting the service manually after startup fixes this issue. (Thanks to pbennett.)
 
  


Reply

Tags
mythtv


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] mythtv frontend can't connect to backend in live tv only pjbgravely Linux - Desktop 3 08-22-2017 11:56 AM
mythtv cannot connect to backend baldur_1 Linux - Software 1 01-04-2015 01:43 PM
LXer: Mythbuntu 7.10: MythTV For Ubuntu LXer Syndicated Linux News 0 11-18-2007 11:00 PM
Mythbuntu or Mythtv on Ubuntu? teek Ubuntu 2 10-29-2007 04:53 PM
Remote mythtv frontend can't connect to backend raytheyounger Linux - Software 2 05-27-2006 09:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration