LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mysql is hosed....can someone plz help (https://www.linuxquestions.org/questions/linux-software-2/mysql-is-hosed-can-someone-plz-help-37736/)

rosko 12-09-2002 09:00 AM

Mysql is hosed....can someone plz help
 
Hey all,
I have a big problem with my system. Last night I was trying to get phpmyadmin to work, and it told me I didn't have the mysql extensions installed. I found the php-mysql rpm off my RH8 cd and installed it....it worked fine. Then my problem was mysql. I can't login to my server from a bash at all. If I go to the mysql directory and attempt to login ./bin/mysql -u root -p and it tells me that it cannot connect to sock....basically tells me the server is not running when in fact it is. I tryed just using mysql safe, and it says there is already a mysql server running. How the hell do I completely uninstall and reinstall mysql? or Stop this "ghost" of mysql from using 3306? Please give me any advice, I'm at the end of my rope here.

oh...and now it tells me I don't have the php extentions for mysql installed....but if I try to reinstall them it says "package already installed".

rosko 12-09-2002 10:42 AM

I tried doing the following.

rpm -qa | grep mysql

that command returned:
mysql-3.23..52-3
php-mysql-4.2.2-8.0.5


Then I tried rpm -e mysql-3.23..52-3
It said it cannot erase because of the dependency of php-mysql.

Then I tried rpm -e php-mysql-4.2.2-8.0.5

It returned the following:
cannot get exclusive lock on /var/lib/rpm/Packages
cannot open Packages index using db3 - Operation no permitted (1)
cannot open Packages database in /var/lib/rpm

Does this indicate I do not have enough priveleges to run the erase on a package?

THanks again.

rosko 12-09-2002 11:16 AM

OK....so now I'm logged in as root and tried rpm -e on the php-mysql package.....and I get no response from my SSH client. It acts like it's doing something.....but never gives me my # back.....any ideas?

lintadsl 12-09-2002 03:21 PM

Check your ps and make sure mysqld is not running.
Then you can do rpm -e.
Sounds like you want to make PHP works with Mysql DB.

Once you make your mysql runs and can access to DB without error, you can just complie PHP with enable mysql db.

Lint.

rosko 12-09-2002 03:44 PM

Lint, I have no idea how to solve this...being a newb.

I have unistalled mysql and deleted all directories.....then reinstalled it and it will not let me start it up. It always throws the error that there is another mysql server running. What's more disturbing is I check the processes....and there is not one related to mysql. Any ideas??

Much appreciated

rosko 12-09-2002 05:17 PM

Ok, I finally got php-mysql removed and mysql completely gone. I reinstalled mysql 4.0.5 beta from tar, and it works now, but php once again doesn't work. phpmyadmin says it needs the mysql extensions installed, but when I try to load the php-mysql rpm it doesn't work, it fails dependencies.
mysql is needed by php-mysql.x.x.x
libmysqlclient.so.10 is needed by php-mysql.x.x....

How can I get the php-mysql rpm to see that I already have mysql installed?


All times are GMT -5. The time now is 04:38 PM.