-   Linux - Software (
-   -   mysql installation weird... (

Red Squirrel 03-06-2004 09:41 PM

mysql installation weird...
I downloaded mysql 4.0 and I'm following this tutorial:

apache went well so far... but mysql is weird. I did the ./configure thing but I got a bunch of stuff and it said that it did not need to do a configure. then I typed make and just got an error make: *** No rule to make target `install'. Stop. and same thing for make install.

But I can't do anything, I can't start mysql. I was even playing with some of the executables and one of them told me I need to do a make install first. what the heck is going on? It should let me do the make install but it's not. and yes I'm doing it from the right folder (main mysql folder).

any suggestions on why this is happening?

Red Squirrel 03-06-2004 09:43 PM

I noticed a few threads here with some of the issues I'm having such as the "mysql ended" when I try to start the mysqld_safe, when I try to start the mysqld I just get some error saying to read the manual about running it under root (I AM under root). Since these issues seem to be known, should I maybe use an older version, would it solve the problems?

MunterMan 03-07-2004 08:45 AM

It looks like it wont install because you already have it.
Is mysql running? It is started by the system at bootup.
Try this;

ps aux|grep mysqld

If it is running, stop it with
/usr/local/bin/mysqld stop

then restart it with
/usr/local/bin/safe_mysql &

I am using version 4.0.15 with Mandrake 9.2 without problems (so far).

Looking_Lost 03-07-2004 09:43 AM

You downloaded the source code yeah, not the binary versions? I've done the same thing myself when I've been a bit quick on the mouse buton.

Red Squirrel 03-07-2004 01:14 PM

That's the thing, I don't know what I downloaded, I just downloaded whatever gave me. How can I tell if it's source or binnary? I don't have it installed already either. If I type mysqld out of nowhere it just says it's an invalid command. I need to go in the bin folder and use the ./ method.

david_ross 03-07-2004 01:20 PM

When you went to you had the choice of binary of source. I can't imagine it "gave" you one in particular. You can see a list of downloads for mysql 4 at:

Red Squirrel 03-07-2004 03:09 PM

I downloaded the first one in the list.
Linux (x86, libc6) Standard 4.0.18 15.1M

Is that the right one?

Looking_Lost 03-07-2004 03:13 PM

Not if you want to compile it. The source code is right down the bottom of the page or click on the source downloads link on the page.

Red Squirrel 03-07-2004 03:26 PM

I noticed that, but what about this?

"For maximum stability and performance, we recommend that you use the binaries we provide."

Does it mean it will crash allot if I use those? They seem to be more of a "use at your own risk" bassis and that, I don't like.

Looking_Lost 03-07-2004 03:57 PM

Well I haven't had it crash on me, the downloadable documention has siggested compiler directives you can use when compiling to make it as stable as possible, I guess all the downloads are "use at your own risk" unless you actually pay the good folk for a license/support or whatever.

Red Squirrel 03-07-2004 05:01 PM

I got it installed, I have no clue wether it's good or not, but now I need to start it, how do I do that? mysqld_safe returns this:

The file /usr/local/mysql/libexec/mysqld doesn't exist or is not executable
Please do a cd to the mysql installation directory and restart
this script from there as follows:

I tried doing what it says, nothing. I also tried mysqld but it can't find it.

Looking_Lost 03-07-2004 05:20 PM

Look in especially for the mysql_install_db


you might want to copy over one of the example configurations i.e mysql_small .cnf to
/etc/my.cnf examples are in the /usr/local/mysql/ subdirectories, have a look around in them.

Red Squirrel 03-07-2004 06:12 PM

well I'm getting somewhere... now when I try to start mysqld I only get this instead of that other error I got before.

[root@localhost mysql]# /usr/local/mysql/bin/mysqld_safe
Starting mysqld daemon with databases from /usr/local/mysql/data
040307 19:10:07 mysqld ended

[root@localhost mysql]#

What what's bothering me is that if I only use mysqld it says it does not exist.... that's the right one, mysqld_safe is only to test right?

Red Squirrel 03-07-2004 06:17 PM

Sweet! I was not done the tutorial and I had to do

chown -R root:mysql /usr/local/mysql
chown -R mysql:mysql /usr/local/mysql/data

Now it works (I think... it does not end). But can someone explain what those commands actually do?

Edit: all is working for me now, apache, php and mysql!!!

only took me a few weeks.:study: :newbie:

MunterMan 03-08-2004 08:19 AM

You have changed the ownerhip of the files.
The first command changed the ownership of the mysql binary to root, so only root can run it.
The second one changed the data to mysql users who are members of the group mysql, so any users who are members of the group 'mysql:' can access the data.

For more on groups and users see the mandrake documentation page.

For more on chown, and other linux commands see;

All times are GMT -5. The time now is 08:57 PM.