-   Linux - Software (
-   -   mysql-installation: Not enough space in /var/lib/mysql/ (

linus123 11-11-2004 08:13 AM

mysql-installation: Not enough space in /var/lib/mysql/
hi you out there.
I need your help

i want to install mysql4.x on my Debian-Computer.(Distribution Debian 3.0)
But i get the error-message

#apt-get install mysql-common mysql-client mysql-server

Unpacking mysql-common (from .../mysql-common_4.0.22-0.dotdeb.1_all.deb) ...
Unpacking libmysqlclient10 (from .../libmysqlclient10_3.23.56-2_i386.deb) ...
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_2.9003-3_i386.deb) ...
Unpacking libmysqlclient12 (from .../libmysqlclient12_4.0.22-0.dotdeb.1_i386.deb) ...
Unpacking mysql-client (from .../mysql-client_4.0.22-0.dotdeb.1_i386.deb) ...
Unpacking mysql-server (from .../mysql-server_4.0.22-0.dotdeb.1_i386.deb) ...

ERROR: There's not enough space in /var/lib/mysql/ (<-------??????????)

dpkg: error processing /var/cache/apt/archives/mysql-server_4.0.22-0.dotdeb.1_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I clean the directory var/cache/apt/archives/ with apt-get clean.

Further information:

#cat /etc/mtab gives back

/dev/sda2 / ext2 rw,errors=remount-ro 0 0
proc /proc proc rw 0 0
/dev/hda1 /backup ext2 rw 0 0
cat /etc/fstab gives back

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass
/dev/sda2 / ext2 errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda1 /backup ext2 auto 0 0

cfdisk gives back

Disk Drive: /dev/hda
Size: 20490559488 bytes
Heads: 255 Sectors per Track: 63 Cylinders: 2491

Name Flags Part Type FS Type [Label] Size (MB)
hda1 Boot Primary Linux ext2 20489.18

i hope someone can help me:confused:

iluvatar 11-11-2004 09:03 AM

you may want to check the available disk space with 'df -h'. don't know how much space mysql needs...

.-=~ iluvatar ~=-.

linus123 11-11-2004 09:13 AM

df -h gives back

Filesystem Size Used Avail Use% Mounted on
/dev/sda2 -2254564460220k 1.0k 0.0k 10% /
/dev/hda1 -1833560400439k 1.0k 0.0k 1% /backup

Jtrick 12-02-2004 03:58 PM

I had a similar problem and have only used 15% of that drive. Is it possible that there may be a problem with the .deb package?

chiahsin 12-02-2004 06:30 PM


you could make soft link for /var/lib/mysql to another partition which gets enough disk space


Jtrick 12-03-2004 02:21 AM

Thanks for the reply chiahsin, but there should be plenty of room on this partition. It seems like there may be something wrong with the installer, although I could be missing something else here. Has anyone else come across something like this or do you have any other suggestions?

Crenfax 12-15-2004 10:15 AM

Yes!! Same issue here. I wonder where we submit MySQL bug reports for Debian?

Hmm, here's a discussion on MySQL's website:,1984,1984

HarveyNeon 06-18-2005 08:06 PM

had this problem, fixed it!
I was only moments away from turning my friday night and saturday into a reinstall sunday... but then i found this forum, SWEET!

Anyways you have to clean up everything, by apt-get remove mysql-server and apt-get remove mysql-client , i threw in a reboot after this step... i don't know if it's my MS background that makes me think this is neccesary, or my general experience with computers that does?

Anywhoos, now that everything's cleaned out:

apt-get update

apt-get install coreutils

there is a problem with the df that comes with our version of debian that means the output of df shows some messed up output. simply upgrading the coreutils means the parsed output of df does not cause the mysql install to error-out.

then apt-get install mysql-server (duh) and it's working for me!

Rock on folks.


cazub 11-10-2006 02:19 PM

"had this problem Fixed it!" awwwwwwwwwww
i was pretty pumped to see somebody fixed this but i'm afraid i still am boned.

did the:
apt-get install coreutils

it says i have the most recent version and that i should run the apt-get -f install
........ so i do, it trys to install mysql-server-5.0 since mysql-server depends on it, and pow, same old error comes up again and nothing has changed :(

All times are GMT -5. The time now is 07:37 PM.