-   Linux - Software (
-   -   mysql install fubared (

Red Squirrel 07-14-2005 06:51 PM

mysql install fubared
I did the mistake of doing an apt-get upgrade on my server. It broke a ton of stuff including mysql.

It just won't start at all. I do /etc/init.d/mysql and nothing happends, at all, no error no nothing. It just won't start and I can't connect to it. I'm panicing because I have tons of data on there, and while I have backups, it's a PIA restoring backups that size.

Here's the exact error I get:

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /data/intranet/main/tools/phone.php on line 104

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /data/intranet/main/tools/phone.php on line 106

Warning: mysql_query(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /data/intranet/main/tools/phone.php on line 108

Warning: mysql_query(): A link to the server could not be established in /data/intranet/main/tools/phone.php on line 108
SQL Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

I also read something about an invalid mysqld.sock file, so if that's the case, how do I get a valid one? I really want to avoid a clean install. I can't afford seperate servers so everything is on this one, including mail, which is #1 PIA to configure on linux. So please help! Thanks.

Red Squirrel 07-14-2005 06:52 PM

Oh, and I can't even find the installation directory for it, I checked everywhere. So I have a feeling the sh$#@thead "apt get upgrade" actually deleted it.

Red Squirrel 07-14-2005 09:00 PM

OMG I never figured it would of been that easy. I just did apt-get install mysql-server and everything magically worked. I only knew to try that because I was trying to setup a php/mysql/apache server at work for development and had read somewhere to install that to make it work, along with a bunch of other things. Given I was in a position to format the server, I had to try a few things first, and it just... worked. And all my data is still there. I have no clue where it's stored though...

All times are GMT -5. The time now is 12:56 PM.