-   Linux - Software (
-   -   mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. (

Dannux 08-09-2005 09:59 PM

mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.

I have been researching without any luck about this problem. I have read many solutions to this problem but they did not work for me.

Problem: I am getting the following error when I try to run mysql.
Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

1- Please note that I am running as root.
2- I am using Mandrivia 2005 limited edition (I selected mysql when I installed my OS)
3- I do not find neither mysql directory under var/lib not mysql.sock

Any help from the OSC (open source community) will be appreciated.


kingnetwork 08-09-2005 10:06 PM

chown mysql.mysql <directory>

psreenivasulureddy 03-24-2006 06:51 AM


I installed Red Hat Linux 3 in my system which had given Apache, PHP and mysql 3 by default. But, when I tried to give the command '#mysqld' it has given some socket error(mysql.sock). What I did is, I downloaded mysql 5.0 RPM's from the site '' and installed it. And now, when I tried to connect to server, using '#mysqld', the error I got is:

"[ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!"

And when I type the following command,

#rpm -q mysql-server
package mysql-server is not installed.


if I try to reinstall using mysql server rpm,
it says that the package is already installed.

Can somebody please help in solving this problem.
I am new to Linux Environment.
Please suggest me to sort out this problem.

If at all repairing this problem is not possible, can somebody suggest how to uninstall mysql, so that I can try it out once again by installing.


reddazz 03-24-2006 08:44 AM

Hi, your question is different from what the original poster was asking, its probably better to start your own thread so that it get more exposure.

All times are GMT -5. The time now is 09:37 PM.