LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-05-2016, 06:54 PM   #1
TrekJunky
LQ Newbie
 
Registered: Aug 2003
Distribution: OpenSuSE Tumbleweed
Posts: 20

Rep: Reputation: 2
Angry MyCroft AI Install problem


I get this error when I run ./dev_setup.sh
Code:
Making install in .
make[1]: Entering directory '/tmp/install-pygtk-29541/pygtk-2.24.0'
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I/usr/include/python3.4m -I/usr/include/python3.4m -I/home/trekjunky/.virtualenvs/mycroft/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I./gtk  -DDISABLE_THREADING -I/usr/local/include/atk-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -g -O2 -Wall -fno-strict-aliasing -std=c9x -MT atk_la-atkmodule.lo -MD -MP -MF .deps/atk_la-atkmodule.Tpo -c -o atk_la-atkmodule.lo `test -f 'atkmodule.c' || echo './'`atkmodule.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I/usr/include/python3.4m -I/usr/include/python3.4m -I/home/trekjunky/.virtualenvs/mycroft/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I./gtk -DDISABLE_THREADING -I/usr/local/include/atk-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -g -O2 -Wall -fno-strict-aliasing -std=c9x -MT atk_la-atkmodule.lo -MD -MP -MF .deps/atk_la-atkmodule.Tpo -c atkmodule.c  -fPIC -DPIC -o .libs/atk_la-atkmodule.o
atkmodule.c:36:1: warning: return type defaults to ‘int’ [enabled by default]
 DL_EXPORT(void)
 ^
atkmodule.c: In function ‘DL_EXPORT’:
atkmodule.c:37:1: error: expected declaration specifiers before ‘initatk’
 initatk(void)
 ^
atkmodule.c:48:1: error: expected ‘{’ at end of input
 }
 ^
atkmodule.c:48:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
Makefile:609: recipe for target 'atk_la-atkmodule.lo' failed
make[1]: *** [atk_la-atkmodule.lo] Error 1
make[1]: Leaving directory '/tmp/install-pygtk-29541/pygtk-2.24.0'
Makefile:706: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1
I have Opensuse Leap 42.1 and Plasma 5 KDE. I think it is trying to install gtk, but I thought I already have it installed. How can I check to see if it is already installed? How can I fix this error?
 
Old 07-06-2016, 05:41 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,440

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Opensuse 42.1, please use the search : # zypper se python
.... or see the package lists ...
x86_64 http://download.opensuse.org/distrib...s/suse/x86_64/
noarch http://download.opensuse.org/distrib...s/suse/noarch/


Install python-gtk : # zypper in python-gtk python-gtk-devel
... you will get version 2.24.9 .



-

Last edited by knudfl; 07-06-2016 at 09:19 AM.
 
Old 07-06-2016, 01:44 PM   #3
TrekJunky
LQ Newbie
 
Registered: Aug 2003
Distribution: OpenSuSE Tumbleweed
Posts: 20

Original Poster
Rep: Reputation: 2
Quote:
zypper se python-gtk
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+----------------------------+---------------------------------------------------------+-----------
i | python-gtk | Python bindings for the GTK+ widget set | package
| python-gtk | Python bindings for the GTK+ widget set | srcpackage
i | python-gtk-devel | Files needed to build wrappers for GTK+ addon libraries | package
| python-gtk-doc | Python bindings for the GTK+ widget set | package
i | python-gtk-vnc | Python bindings for the gtk-vnc library | package
i | python-gtksourceview | Python bindings for the GTK+ source editing widget | package
| python-gtksourceview | Python bindings for the GTK+ source editing widget | srcpackage
i | python-gtksourceview-devel | Python bindings for the GTK+ source editing widget | package
i | python-gtkspell | Python bindings for GtkSpell | package
The i means already installed...Why doesn't dev_setup.sh see it?

Last edited by TrekJunky; 07-06-2016 at 01:48 PM. Reason: Adding questions
 
Old 07-06-2016, 02:44 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,440

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Quote:
.. gcc -DHAVE_CONFIG_H -I. -I/usr/include/python3.4m -I/usr/include/python3.4m ..
Looks like the default python-2.7 has been tampered with ?

python-base-2.7.9-21.3.x86_64 provides /usr/bin/{ python, python2, python2.7 }

python3-base-3.4.1-6.2.x86_64 provides /usr/bin/{ python3, python3.4, python3.4m }

.... The installed python-gtk, python-gtk-devel are python 2.7 packages, not usable by python3.
If you want to build "mycroft ai", I suggest you change the python link back to default.

See https://github.com/MycroftAI/mycroft-core → → required = python 2.


-

Last edited by knudfl; 07-06-2016 at 02:49 PM.
 
Old 07-07-2016, 12:34 AM   #5
TrekJunky
LQ Newbie
 
Registered: Aug 2003
Distribution: OpenSuSE Tumbleweed
Posts: 20

Original Poster
Rep: Reputation: 2
I manually did a make and installed pygtk, but now I get this error:

Quote:
make[1]: Entering directory '/tmp/install-pygtk/pygtk-2.24.0/gtk'
(/home/trekjunky/.virtualenvs/mycroft/bin/python /usr/share/pygobject/2.0/codegen/codegen.py \
-DHAVE_PYCAIRO -DHAVE_GTK_2_12 -DHAVE_GTK_2_14 -DHAVE_GTK_2_16 -DHAVE_GTK_2_18 -DHAVE_GTK_2_20 -DHAVE_GTK_2_22 -DHAVE_GTK_2_24 -DGDK_TARGET_X11 \
-I . \
--py_ssize_t-clean --register /usr/share/pygobject/2.0/defs/gio-types.defs \
--register ../pango-types.defs \
--register ../atk-types.defs \
--register gdk-types.defs \
--register gtk-types.defs \
--override ./gtkunixprint.override \
--prefix pygtkunixprint gtkunixprint.defs) > gen-gtkunixprint.c \
&& cp gen-gtkunixprint.c gtkunixprint.c \
&& rm -f gen-gtkunixprint.c
File "/usr/share/pygobject/2.0/codegen/codegen.py", line 429
except argtypes.ArgTypeError, ex:
^
SyntaxError: invalid syntax
Makefile:1042: recipe for target 'gtkunixprint.c' failed
make[1]: *** [gtkunixprint.c] Error 1
make[1]: Leaving directory '/tmp/install-pygtk/pygtk-2.24.0/gtk'
Makefile:706: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1
Please help!!!!
 
Old 07-07-2016, 06:18 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,440

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Re #5.
Quote:
I manually did a make and installed pygtk
? What do you mean by that ? You already had {python-gtk, python-gtk-devel}.

Your issues are caused by mixing python versions : See post #4 ;
If you want to build "mycroft ai", I suggest you change the python link back to default.
I.e. /usr/bin/python must be a link to python2.7

I.e. i.e. https://github.com/MycroftAI/mycroft-core → → required = python2, not python3.



-

Last edited by knudfl; 07-07-2016 at 06:22 AM.
 
Old 07-07-2016, 10:26 AM   #7
aatchison
LQ Newbie
 
Registered: Jul 2016
Posts: 2

Rep: Reputation: Disabled
I'm sorry to see that you are having some issues with the Mycroft setup. You might be the first person to try to install it on OpenSUSE. I see that you are using the virtualenv, and the dev_setup script should restrict your python version to 2.7, so I don't see any problem there. Feel free to contact us at #mycroft on freenode.net, join us on slack: https://mycroft-ai-slack-invite.herokuapp.com/ , or open an issue on our github project; https://github.com/MycroftAI/mycroft-core/issues.
Thanks for giving it a shot! Pop by and we will try to help.
 
1 members found this post helpful.
Old 07-07-2016, 07:47 PM   #8
TrekJunky
LQ Newbie
 
Registered: Aug 2003
Distribution: OpenSuSE Tumbleweed
Posts: 20

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by knudfl View Post
Re #5.

? What do you mean by that ? You already had {python-gtk, python-gtk-devel}.

Your issues are caused by mixing python versions : See post #4 ;
If you want to build "mycroft ai", I suggest you change the python link back to default.
I.e. /usr/bin/python must be a link to python2.7

I.e. i.e. https://github.com/MycroftAI/mycroft-core → → required = python2, not python3.



-
I didn't know how to change the version of python, so I thought I would navigate to the downloaded pygtk folder and do a configure, make and make install. Now it skips over the GTK install (I think) and gives my the new error. Would you please tell me HOW I can change the python link back to 2.7? It seems that the link is generated rather than hard coded. I couldn't find it in any of the files.
 
Old 07-08-2016, 11:40 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,440

Rep: Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624Reputation: 3624
Re #8.

Enabling python[version] = python2 :

Code:
cd /usr/bin/
# rm -f python
# ln -s python2.7 python
 
Old 07-08-2016, 10:02 PM   #10
TrekJunky
LQ Newbie
 
Registered: Aug 2003
Distribution: OpenSuSE Tumbleweed
Posts: 20

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by knudfl View Post
Re #8.

Enabling python[version] = python2 :

Code:
cd /usr/bin/
# rm -f python
# ln -s python2.7 python
I erased my hard drive and installed a different OS...will try Mycroft later
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mycroft Releases Key AI Component as Open Source LXer Syndicated Linux News 0 01-07-2016 10:40 AM
LXer: Mycroft Is Now an Official Ubuntu IoT Partner LXer Syndicated Linux News 0 12-15-2015 12:21 AM
LXer: Mycroft AI Already Working on Linux Desktops, Integration Has Started LXer Syndicated Linux News 0 10-28-2015 01:42 PM
LXer: Mycroft's AI Could Power Ubuntu's Unity and Give Users Voice Control LXer Syndicated Linux News 0 08-28-2015 03:51 PM
Firefox: mycroft does not show icons in the search engines list tjoe Linux - Software 0 01-08-2010 07:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration