-   Linux - Software (
-   -   My system on longer boots... (

teeno 05-23-2003 06:40 AM

My system on longer boots...
Hi everyone,

My system has stopped booting!!! Can someone please help me get it up and running again.

Here is the text at boot up:

Partition check:
sda: sda1 sda2 sda3
Loading jbd module
Jouralled Block Device driver loaded
Loading ext3 module
Mounting /proc filesystem
Creating block device
Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 212k freed
Kernel panic: No init found. Try passing init= option to kernel.

System Specification:
Redhat 8
Kernel 2.4.18-14
PII 733
Adaptec 2940U2W SCSI
Quantum Viking II

Thank you.

fancypiper 05-23-2003 10:09 AM

It sounds like your /etc/fstab is using labels rather than the actual devices and the label doesn't correspond to the correct partition.

Boot in rescue mode, mount your / partition and edit /etc/fstab to use partitions rather than labels and it will probably boot then.

Redhat 8.0 Rescue mode

# Redhat links
RedHat Linux Manuals
Maximum RPM
Easier software management: apt4rpm - Red Carpet
RedHat 8.0 Tips & Tricks

# Redhat 7.3 down configuration commands
setup leads to several configuration tools

# Redhat 7.3 up configuration commands
Configure soundcard:
Configure X server:
Configure network:

teeno 05-27-2003 09:33 AM

When I try to enter Rescue Mode I get the following message:


You donít have any Linux partitions. Press return to get a shell. The system will reboot automatically when you exit from the shell.
I have tried to mount the drive from the rescue mode shell but it fails.

I type:


mkdir /foo

mount -t ext3 /dev/sda2 /foo
And get this message:


mount: Mounting /dev/sda2 on /foo failed: Invalid argument
When I type fdisk -l

/dev/sda1 83 Linux
/dev/sda2 83 Linux
/dev/sda3 82 Linux swap

I would like to be able to recover my files. Any help would be gratefully accepted.

Thank you.

fancypiper 05-27-2003 01:35 PM

Is /dev/sda2 perhaps something other than ext3, maybe reiserfs or ext2?

teeno 05-28-2003 02:17 AM

I have tried to mount it as ext2 but I get the same error.

Am I using the mount command correctly?

All times are GMT -5. The time now is 11:41 PM.