LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   My Knoppix 3.7 need root password when I run program (https://www.linuxquestions.org/questions/linux-software-2/my-knoppix-3-7-need-root-password-when-i-run-program-305840/)

AskMe 03-25-2005 05:27 AM

My Knoppix 3.7 need root password when I run program
 
When I run Ethereal network analyser form my live KNoppix CD, it opens but ask root password, when I leave it blank and Click OK, it say wrong password. I did not do any setting in Knoppix 3.7 I just booted my computer with that and start using it. By the way I am posing this messege via Knoppix 3.7 booted CD. Please help me.

Thanks

aus9 03-25-2005 06:47 AM

When knoppix any version boots
open a terminal and your prompt shoutd read knoppix@ etc
type su (means set user to root if no user named)
prompt should change to root@ etc

2) now type command
passwd
(type new password) and then when prompted for root password for future ops like networking you know what to type in
I can't remember if you have to do this new passwd twice but I am using Mdk at the moment

AskMe 03-25-2005 02:55 PM

By the way I am not running Ethereal by command prompt, I don't know the command. I rum this application from selecting K menu, then going to Internet and select Ethereal. When I open, first it open a new windows asking root password. When I leave it blank did not accept.

aus9 03-25-2005 05:47 PM

yes I understand that bit.

can you just click on the shell icon if you are using knoppix......it should be on the panel left hand side......which opens a terminal called konsole then type su then type passwd then type YourpreferredPassword

you may have to enter your new password twice

then navigate to Kmenu to ethereal

Frank616 03-25-2005 08:51 PM

AskMe:

Though not a full solution to your problem, someone in the CompuServe Linux forum told me how to open a shell with root privileges. The easiest way to get a root shell in Knopix is to press Ctrl-Alt-F1. If you can run your software from this shell, then it should have root privileges as well.

Frank.

AskMe 04-15-2005 05:35 AM

Yeah, I made it! But I have realized that, easiest way is to assign a new password first. First open terminal and su, the passwd then assign new password, although there is no password before. After doing this when you run any application, when application ask password then type the assigned password. It solve all the problem


All times are GMT -5. The time now is 10:16 AM.