-   Linux - Software (
-   -   My AppServ woes - PHPAdmin not working (

UltimaGuy 02-10-2004 04:26 AM

My AppServ woes - PHPAdmin not working
Ok guys,

I admit, I've blown it. I downloaded the AppServer(PHP,Apache,MySql combo pack) to impress my cousin .

The installation went beatifully(in Win2k professional).

All was working well, and I was showing my cousin how to administer using PHPAdmin. I set a password for root at localhost to show him how easy it was. Boom...

Now, PHPAdmin refuses to execute saying there is an authentication error(No.145, if it helps :( ). I even tried uninstalling and then reinstalling the whole pack, but PHPAdmin simply refuses to start. With it goes my great scheme to pull my cousin towards the world of open source.

Any help at all will surely be useful.


robertoneto123 02-10-2004 04:49 AM

I got two ideas...

Do you use the http autentication on phpMyAdmin?

(take a look into the

Another thing: on the mysql database, table user, take a look on the root@localhost user. As far as I know, this is the user that is used when you try to access mysql on the local machine(as root).

I hope it helps...

UltimaGuy 02-10-2004 04:59 AM

Ok, thanks for your help robertoneto123.

1) I tried changing the file and had entered my password into every password field. Still the error :(

2) I tried removing the password from the mysql db. No result.

I never thought it was so simple to mess up with an installation huh.

Any other ideas ?

robertoneto123 02-10-2004 05:08 AM

It is strange...

Here I got the same idea as you, but it works here...

If you create a new user on mysql, it works on mysql?

UltimaGuy 02-10-2004 05:24 AM

I think you misunderstood. When I try to access the database, here is what I get -->


C:\Program Files\AppServ\mysql\bin>mysql
mysql: Character set 'usa7' is not a compiled character set and is not specified in the 'C:\mysql\\share\charsets\Index' file
This is the error I get in phpMyAdmin -->


#1045 - Access denied for user: 'root@localhost' (Using password: NO)
What to do now?

All times are GMT -5. The time now is 03:28 PM.