LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-06-2007, 03:38 PM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
mutt - no mailbox


Hi
I use Debian Etch and have never done anything with mutt or fetchmail or ssmtp.
I followed the following tutorial

http://forums.debian.net/viewtopic.p...ht=mail+server

to set up mutt to read my emails from gmail. However, when I start mutt at the bottom of the page it says:

Quote:
/home/sycamorex/mail/inbox/ is not a mailbox.
Why isn't it a mailbox? It's just a normal directory. What do I need to do?
my .muttrc


Quote:
set mbox_type=maildir
set mbox="~/mail/inbox/"
set spoolfile="~/mail/inbox/"
set folder="~/mail/"
set record="~/mail/sent/"
set postponed="~/mail/postponed/"
set editor="vim"
set include=ask-yes
set sendmail="/usr/sbin/ssmtp"

# set up mutt so i can run fetchmail at any time by pressing G
macro index G "!fetchmail\n" "Invoke fetchmail"
macro pager G "!fetchmail\n" "Invoke fetchmail"


# set from to ensure mutt doesn't put user@localhost.localhoset
set from="myemailaddress@gmail.com"
set use_from=yes
set envelope_from="yes"


# use abook with Mutt
set query_command="abook --mutt-query '%s'"
macro index a "|abook --add-email\n" 'add sender to abook'
macro pager a "|abook --add-email\n" 'add sender to abook'
~


my .ssmtp


Quote:
root='''myemailaddress@gmail.com'''

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
# mailhub='''smtp.gmail.com'''

# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
hostname='''myemailaddress@gmail.com'''

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES


AuthUser='''username'''
AuthPass='''password'''

UseTLS=YES
UseSTARTTLS=YES
mailhub=smtp.gmail.com:587
~
~

my .fetchmailrc
Quote:
poll pop.gmail.com with proto POP3 and options no dns
user 'myemailaddress@gmail.com' is 'sycamorex' here options ssl

Can you advise me what is wrong with it?
thank you
 
Old 06-06-2007, 03:51 PM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,342

Rep: Reputation: 341Reputation: 341Reputation: 341Reputation: 341
An mbox type mailbox is not a folder, it's a file.

Delete the folder inbox
touch ~/mail/inbox

Then start mutt and see the next error

Same goes for sent and postponed. Just delete them, mutt will make them as needed.

Last edited by dive; 06-06-2007 at 03:53 PM.
 
Old 06-06-2007, 03:58 PM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
thanks

but.....after I've deleted the three directories and touched the files I got:

Quote:
/home/sycamorex/mail/inbox/: Not a directory (errno = 20)
It would suggest that a program expects a directory, wouldn't it?
 
Old 06-06-2007, 04:36 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
As you said Dive, they are supposed to be files, not folders, whereas my .muttrc indicates folders!!!

Quote:
set mbox_type=maildir
set mbox="~/mail/inbox/"
set spoolfile="~/mail/inbox/"
set folder="~/mail/"
set record="~/mail/sent/"
set postponed="~/mail/postponed/"
set editor="vim"
set include=ask-yes
set sendmail="/usr/sbin/ssmtp"
what do I do next to get my emails?
thanks
 
Old 06-06-2007, 04:39 PM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
I tried to email someone, what I got is:

Quote:
ssmtp: Authorization failed (535 5.7.1 Credentials Rejected ...some long number

Quote:
Output of the delivery process -- (all)
Error sending message, child exited 1 ().
[EDIT] OK - solved this one, just got rid of all single quotes in:

Quote:
AuthUser='''username'''
AuthPass='''password'''

Now the questions remains how can I download the emails or only
the headers to my box.

Last edited by sycamorex; 06-06-2007 at 04:58 PM.
 
Old 06-06-2007, 05:21 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,342

Rep: Reputation: 341Reputation: 341Reputation: 341Reputation: 341
Ok I see you have them specified as maildirs - my mistake for not reading correctly. The solution I gave is for mbox format.

Heres a how to for maildir that might help:

http://www.elho.net/mutt/maildir/
 
Old 06-06-2007, 05:59 PM   #7
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,342

Rep: Reputation: 341Reputation: 341Reputation: 341Reputation: 341
Or you could set 'mbox_type' to 'mbox' and do what I posted first. I'm experimenting with maildir at the moment.

Not sure if mutt supports maildir too well though as I'm getting some errors too.

*edit: It's best to mbox format it seems from here:

http://cygwin.com/ml/cygwin/2003-11/msg00799.html

Last edited by dive; 06-06-2007 at 06:05 PM.
 
Old 06-06-2007, 06:02 PM   #8
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
I can't open the link
 
Old 06-06-2007, 06:08 PM   #9
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,342

Rep: Reputation: 341Reputation: 341Reputation: 341Reputation: 341
This is from a cygwin support mailing list but I believe it applies to mutt running on pure linux.


Quote:
RE: Maildir Support broken with Mutt 1.4.1?

* From: "Gary R. Van Sickle" <g dot r dot vansickle at worldnet dot att dot net>
* To: <cygwin at cygwin dot com>
* Date: Wed, 19 Nov 2003 23:15:38 -0600
* Subject: RE: Maildir Support broken with Mutt 1.4.1?

> After upgrading to Mutt 1.4.1 I was no longer able to access my emails
> properly.
>
> As soon as a new mail arrived in the main folder (inbox), I could not even
> close mutt properly. It always gives me the error "rename file or folder
> does not exist (error=2)" in the status bar.
> It seems to me that Mutt tries to move the message from the "new" to the
> "cur" subfolder or so and fails with this operation.
>
> Downgrading to Mutt 1.4 solved the problem for me.
>
> I use Mutt together with procmail in Maildir mode. A search for previous
> postings showed, that there were already similar problems with an older
> version. The problem was that the filenames of the emails may contain
> characters like ":" that are allowed on POSIX systems, but not on Windows.
>
> Is it possible that a cygwin specific patch has not been applied to the
> most recent 1.4.1 version?

Maildirs have never actually worked properly because they use filenames which
are not POSIX compatible, and were apparently specifically designed to cause
grief for Windows and Mac systems. Compounding this problem, I erroneously
suggested people use Maildirs in older versions, before I knew the tragedy of
Maildirs. Probably what's happened is that mutt's error checking has been
improved, so you're now getting an error message when it would just silently
fail before.

So, to sum up:

1. Don't use Maildir, use mbox.
2. If you do use Maildir, put your mailbox on a Cygwin "Managed mount". This
may or may not work, I don't know.

--
Gary R. Van Sickle

Last edited by dive; 06-06-2007 at 06:10 PM.
 
Old 06-08-2007, 02:24 PM   #10
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
Thanks dive,


Quote:
1. Don't use Maildir, use mbox.
I've changed the label Maildir to mbox in .muttrc
Is that what I was advised to do?

As I said before, I can send email now, but cannot fetch them yet.
Another thing is that when I email somebody, the person receives an email from:
Quote:
"Root at Debian" <myemailaddress@gmail.com>
Whereas I'd like it to be my name - not Root at Debian. Where can I change it? [EDIT] OK - I found it in .muttrc

thanks

Last edited by sycamorex; 06-08-2007 at 02:40 PM.
 
Old 06-08-2007, 02:52 PM   #11
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,825
Blog Entries: 1

Original Poster
Rep: Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221Reputation: 1221
At the moment my configuration files are as follows:

.muttrc

Quote:
set mbox_type=mbox
set mbox="~/Mail/inbox"
set spoolfile="~/Mail/inbox"
set folder="~/Mail/"
set record="~/Mail/sent"
set postponed="~/Mail/postponed"

# Unset Marking Mails Old
unset mark_old
# Cancel a message when subject is blank
set abort_nosubject=yes
# Set default editor
set editor="vim"
# Automatically include message when replying
set include=ask-yes
# Ask before printing
set print=ask-yes
# Delete messages without asking when Mutt is quit
set delete=yes
# Add an item for each mailbox
mailboxes ~/Mail/inbox
# Show only important stuff in the header
ignore *
unignore from resent-from reply-to x-mailer user-agent date to cc subject
# mail send options
set sendmail="/usr/sbin/ssmtp"
# Order to display the headers in
hdr_order From: Resent-From: Reply-To: X-Mailer: User-Agent: Date: To: Cc: Subject:
# sort messages by thread
set sort=threads

# Automatically quote message in reply
set include=yes

# Set quotemark to 1 byte
set indent_str="> "

# Only show the body when I edit a message
unset edit_headers

# set up mutt so i can run fetchmail at any time by pressing G
macro index G "!fetchmail\n" "Invoke fetchmail"
macro pager G "!fetchmail\n" "Invoke fetchmail"



# set from to ensure mutt doesn't put user@localhost.localhoset
set from=myemail@gmail.com
set use_from=yes
set envelope_from="yes"

# set realname
set realname="myname"

# # set some coloring for easier mail reading
# Color messages
color index brightyellow default ~N
color index brightred default ~D


# Use abook with Mutt
set query_command="abook --mutt-query '%s'"
macro index a "|abook --add-email\n" 'add sender to abook'
macro pager a "|abook --add-email\n" 'add sender to abook'
.fetchrc


Quote:
poll gmail.com with proto pop3
user username@gmail.com with password xxxxxxx is user here dropdelivered keep
.ssmtp


Quote:
root=myaddress@gmail.com
hostname=myaddress@gmail.com
FromLineOverride=YES
AuthUser=myaddress@gmail.com
AuthPass=xxxxxxxxx
UseTLS=YES
UseSTARTTLS=YES
mailhub=smtp.gmail.com:587
[EDIT] Is it anything to do with port 25 which is inaccessible on my router?


Quote:
sycamorex@ubacer:~$ fetchmail -v
fetchmail: 6.3.6 querying gmail.com (protocol POP3) at Fri 08 Jun 2007 20:48:45 BST: poll started
Trying to connect to 72.14.253.83/110...connection failed.
fetchmail: connection to gmail.comop3 [72.14.253.83/110] failed: Connection timed out.


thanks

Last edited by sycamorex; 06-08-2007 at 03:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailbox Importing skulbite Linux - Server 3 01-29-2007 11:12 AM
Mailbox Creation w/ Postfix on SuSE 9.0 w/ Mutt ThisGuyIKnow Linux - General 1 06-20-2006 04:24 PM
Move mailbox ugob Linux - Software 2 01-03-2004 09:43 PM
mutt always tries to open one user mailbox ash4stuff Linux - Software 0 12-01-2003 06:50 AM
evolution-mailbox athenerx Linux - Newbie 3 03-21-2002 08:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration