LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-07-2013, 10:45 PM   #1
lucmove
Senior Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Stretch
Posts: 1,062

Rep: Reputation: 83
Mutt - Help with folder-hook


I have these in my .muttrc:

Code:
send-hook . my_hdr From: Myself <myself@mymail.com>
send-hook . my_hdr Reply-To: Myself <myself@mymail.com>
send-hook . set signature="$HOME/sig1.txt"

folder-hook . 'set my_hdr="From: Myself <myself@mymail.com>"'
folder-hook . 'set my_hdr="Reply-To: Myself <myself@mymail.com>"'
folder-hook . 'set pop_host="pop.mymail.com"'
folder-hook . 'set pop_user="georgesr@pop.pop"'
folder-hook . 'set pop_pass="bananas"'
folder-hook . 'set signature="$HOME/sig1.txt"'
folder-hook . 'set smtp_url="smtp.mymail.com"'
folder-hook . 'set smtp_pass="bananas"'

folder-hook beerlovers 'set my_hdr="From: My Other Self <otherself@box2.com>"'
folder-hook beerlovers 'set my_hdr="Reply-To: My Other Self <otherself@box2.com>"'
folder-hook beerlovers 'set pop_host="pop3.beer.com"'
folder-hook beerlovers 'set pop_user="jim72@beer.com"'
folder-hook beerlovers 'set pop_pass="cheers"'
folder-hook beerlovers 'set signature="$HOME/sig-beer.txt"'
folder-hook beerlovers 'set spoolfile="$HOME/Mail/beerlovers"'
folder-hook beerlovers 'set smtp_url="smtp.beer.com"'
folder-hook beerlovers 'set smtp_pass="cheers"'
folder-hook beerlovers my_hdr From: My Other Self <otherself@box2.com>
So when I launch mutt and fetch mail, it fetches mail from mymail.com.

When I compose a message, the identity and reply-to is set to Myself, <myself@mymail.com>.

All fine.

Problem:
When I change folder to =beerlovers and fetch mail, it fetches mail from beer.com. And the messages are correctly stored in $HOME/Mail/beerlovers.

However, when I compose a message, the identity and reply-to is set to Myself, <myself@mymail.com>. That's not what I expected. The second identity should be used when I change folder.

What am I doing wrong?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mutt does not change the "unread" flag on the IMAP server and other Mutt questions TobiSGD Linux - Software 1 10-09-2012 09:44 AM
mutt does not honour mutt.rc 'use_from' entry when accepting piped input davidchall Linux - Software 0 05-28-2012 03:13 AM
Mutt experts - Mutt won't use the Maildir I specify in .muttrc moistTowelette Debian 2 08-24-2009 09:04 AM
Mutt folder navigation CoderMan Linux - Software 2 04-23-2009 07:04 PM
[SVN - post-commit hook] hook failed, did not exit cleanly G00fy Programming 0 01-21-2009 03:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration