LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mutt can't save attachments (https://www.linuxquestions.org/questions/linux-software-2/mutt-cant-save-attachments-86671/)

cage 08-28-2003 01:12 PM

mutt problem with decoding / saving attachments
 
Hello!

I got the following problem with my mail-client mutt (1.5.4i debian unstable):
all attachments (seems not specific to a certain type of file) are displayed encoded and inline in the message body.

I also can't save them in the attachment menu, because there is only one item named "<no discription>" which contains the whole message _and_ the encoded attachment. That's not a thing I really like.... ;)

While looking for solutions (google, mutt manual, sample .muttrcs, etc.) I noticed that it might be s.th. about MIME, but I didn't manage to get it working, though. I see it's a multipart message and the second part is described with the option "Content-Disposition: attachment;", nevertheless it's shown in the body of the message!?

Some minutes ago, I tried the same on a debian stable box, and there it works! The attachment is separated from the message body and can be saved, too. There an attachment in the pager looks like this:
<cut>
[-- Attachment #2: edit --]
[-- Type: text/plain, Encoding: 7bit, Size: 12K --]
</cut>
I didn't find any differences in the config-files, but the version is different, of course: mutt 1.3.28i debian stable

By the way it's not the fault of the local mailserver / fetchmail / procmail, because another mail-client (evolution) has no problem to view the attachment.

After trying to solve this problem for more than two days now, I thought someone could possibly help me.

Thanks in advance.


Carsten
------------------------------------------------------------------
attached a mail, and parts of /etc/mime.types and ./.mailcap

Envelope-to: xxxxxx@localhost
Delivery-date: Wed, 27 Aug 2003 20:05:33 +0200

Received!; Wed, 27 Aug 2003 20:05:33 +0200
X-Flags: 0000
Delivered-To: GMX delivery to xxxxx@gmx.de
Received: from pop.gmx.net [xxxxxxxxxxxxxx]
by localhost with POP3 (fetchmail-6.2.3)
for xxxxx@localhost (single-drop); Wed, 27 Aug 2003 20:05:33 +0200
+(CEST)
Received: (qmail 23766 invoked by uid 65534); 27 Aug 2003 18:05:09 -0000
Received: from smtp2.xxxxx.xx (EHLO smtp2.xxx.xx) (xxxx)
by mx0.gmx.net (mx023-rz3) with SMTP; 27 Aug 2003 20:05:09 +0200
Received: from xxx (xxxxxxx [xxxxxx])
by smtp2.xxxx.de (Postfix) with ESMTP id xxxx
for <xxxxxx>; Wed, 27 Aug 2003 20:05:07 +0200 (MEST)
Message-Id: <xxxxxx@smtp2.xxxxxxx.de>
Date: Wed, 27 Aug 2003 20:05:07 +0200 (MEST)
From: xxxxx@xxx.org
To: undisclosed-recipients:;
X-GMX-Antivirus: -1 (not scanned, may not use virus scanner)
X-GMX-Antispam: -2 (not scanned, spam filter disabled)

Received!; Wed, 27 Aug 2003 20:05:16 +0200
Date: Wed, 27 Aug 2003 20:05:16 +0200
From: cage <xxxxx@xxx.xx>
To: xxxx@xx.xx
Subject: test
Message-ID: <xx27180516.GA892@xxx.xxx>
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="ZPt4rx8FFjLCG7dd"
Content-Disposition: inline
User-Agent: Mutt/1.5.4i


--ZPt4rx8FFjLCG7dd
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

another test with attachments...

--ZPt4rx8FFjLCG7dd
Content-Type: audio/x-wav
Content-Disposition: attachment; filename="beep.wav"
Content-Transfer-Encoding: base64

UklGRjgHAABXQVZFZm10IBAAAAABAAEAQB8AAIA+AAACABAAZGF0YRQHAABs/5z+GP2k+sj2
<lot's of junk like the line above>
--ZPt4rx8FFjLCG7dd--

-------
~/.mailcap
audio/x-wav;/usr/bin/xmms %s

-------
/etc/mime.types
audio/x-wav wav


All times are GMT -5. The time now is 04:49 PM.