-   Linux - Software (
-   -   Music CD's are not found. Slackware 10. (

RHLinuxGUY 10-15-2004 10:37 PM

Music CD's are not found. Slackware 10.
Whenever I try to use a program to play Music CD's it doesn't play. Can someone give me a reason, and how to resolve this. Or do you know of a good program?

baldwonder 10-15-2004 11:25 PM

I was using the built-in CD player in Gnome, but since I have switched to Fluxbox I use workbone. It is a good program with a very simple interface (you use the number pad to control the music) that runs from the command line. I'm not sure if it is included in other distributions, but it is on Slackware 10 (CD1 I think). I can't remember which folder though. What problems are you having? Does the CD look like it is playing but you have no sound or does the program not recognise that you have a CD in the drive? Can you be more specific?

RHLinuxGUY 10-16-2004 12:14 AM

When I try to mount the cd, I get this...

sh-2.05b$ mount /mnt/cdrom/
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems.

And yes I do have workbone.

And yes I did a chmod 666 /dev/cdrom/ (and 777, and a+x)

reddazz 10-16-2004 12:45 AM

you can't mount audio CD's since they don't have a valid filesystem, you need to point your cd player app to the right drive, for example on my system it's /dev/cdrom or /dev/hdc. Also make sure that you have the right permissions to access the disk drive.

baldwonder 10-16-2004 01:08 AM

what happens when you try this:

workbone -p1 -d /dev/cdrom

Does your CD-ROM activity light come on? Any errors?

RHLinuxGUY 10-16-2004 01:50 AM

CD Rom light activity, and I can't run it as a normal user, it says run chmod 666 /dev/cdrom for user previlages, even though I changed /etc/fstab.

baldwonder 10-16-2004 11:45 AM

It sounds like the CD is playing, you just have no sound. Try this (as root)

# alsaconf

It should get your sound card setup and then run alsamixer or rexima to set the volume levels for everything.

As for why you can't run workbone as a normal user, I don't really know. What error did you get when you tried it?

luminousnerd 10-16-2004 12:30 PM

I have the same problem, but I use KDE, and prefer not to enter the terminal. Any suggestions?

320mb 10-16-2004 12:50 PM


Originally posted by luminousnerd
I have the same problem, but I use KDE, and prefer not to enter the terminal. Any suggestions?
HUH,..................why not?? Did Mandrake disable it.............LOL

luminousnerd 10-16-2004 12:57 PM

No, its easy to get into the terminal and I know how, it's just I prefer not to. It makes me uncomfortable and it isn't easy.


RHLinuxGUY 10-16-2004 01:07 PM

Well, my sound has been working, and I did alsaconf again, it works. And workbone says...

as root plz do chmod 666 /dev/cdrom/ to give your self access to cdrom.

Hmmm.... *thinking hard* I tried gnome just recently, and its the only desktop to find the cd, but, its still doesn't play it, tho theres cdrom activity. I did, however, put my headphones in the cdrom sound port. But to no avail :[.

You know what! I think its because I didn't put that line in from my cdrom to that little AUX port on my motherboard. Could that be the problem?

baldwonder 10-16-2004 05:50 PM

Definately! Connecting your CD-ROM to the AUX port (or any of the sound input ports) on your motherboard should fix it. I'm not sure what to do with the workbone problem, but if you use Gnome CD Player and it works, don't worry about it.

RHLinuxGUY 10-16-2004 06:47 PM

Damnit. Now I got to find one of those things.

All times are GMT -5. The time now is 09:24 PM.