LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-14-2006, 01:10 PM   #1
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Rep: Reputation: 31
Unhappy Multiple screwups , MAJOR problem


Hello I am in a desperate condition , my problem is that i am a senior newbie (i mean not so newbie) I sucessfully
compiled a new kernel and ran it and trashed my system with in the past 27 hrs
What happened is , I have a p4 , 2.66 256 mb ram with 64-bit support
I used PCLINUX (for quite a while ) and windows xp
I recompiled my kernel for pclinux but its 32 bit,
I wanted 2 try a 64-bit distro , i only had ubuntu so i tried and
it all fell apart

PCLINUX WAS IN /dev/hda14
WINXP was in /dev/hda5

i installed ubuntu in /dev/hda1 :-D and to add agony IT DIDNOT EVEN GET PROPERLY INSTALLED ! its ok ,
i had lilo before ubuntu with which i used pc-linux and winxp , i kida reinstalled lilo but since /dev/hda1 was FORMATTED (c: ) windows XP would not load , it showed a blank cursor when i selected windows option
SO i the einstine , re-formated /dev/hda1 (c to fat 32 , tried fdisk /fixmbr , re-did lilo , but didnot load winxp
then i inserted my xp cd and did fixmbr, (in recovery console)
rebooted and still none and worse LILO was gone
it showd :-
disk error
then i did fixboot (xp recovery console ) and also fixmbr (difference = earlier just mbr , l8r = boot then mbr )
[Newton re-commited sucide]
now i tried installing GRUB via gnoppix live cd
i asked grub to :- setup (hd0,0) or sorta but (hd0,0)
and it said device cant b accessed

when i did fdisk -l in its terminal it said the device cant b accessed (although i was checking the partitions 2 c if my data
is INTACT and it was fine! )
then i booted from pc-linux live cd and tried lilo and it shows :-
Fatal: Trying to map files from unnamed device 0x000e (NFS/RAID mirror down ?)

[i tried 2 redo lilo by typing lilo in terminal]
I have a paper on wednesday , critical data is in the HD which can b useful only via windows , help on very expedited basis would be admired ,
the following is my current partition table (xp is in /dev/hda5 (D: from windows point of view)
---MY DATA IN ALL PARTITIONS IS INTACT EVEN windows installation takes place (win98 and xp) but when they reboot it shows
DISK ERROR
what can i possibly do , please dont tell me that i have 2 format all my hd (like kinda DM or sorta)

Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 608 4883728+ b W95 FAT32
/dev/hda2 609 14593 112334512+ f W95 Ext'd (LBA)
/dev/hda5 609 1216 4883728+ b W95 FAT32
/dev/hda6 1217 2433 9775521 b W95 FAT32
/dev/hda7 2434 3649 9767488+ b W95 FAT32
/dev/hda8 3650 4865 9767488+ b W95 FAT32
/dev/hda9 4866 6082 9775521 b W95 FAT32
/dev/hda10 6083 7298 9767488+ b W95 FAT32
/dev/hda11 7299 10947 29310561 b W95 FAT32
/dev/hda12 10948 13497 20482843+ b W95 FAT32
/dev/hda13 13498 13639 1140583+ 82 Linux swap / Solaris
/dev/hda14 13640 14593 7662973+ 83 Linux
 
Old 05-14-2006, 05:07 PM   #2
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
If all your data is known to be intact (and I'm not clear on how you learned this), could you possibly get access to a friend's machine and transfer the data temporarily there, and then preferably also to CD-ROM or DVD-ROM, and then just reformat the troublesome disk and repartition it and install your OS's so you know you have a good foundation again, and then return the data to your own machine? It might be quicker and safer than trying to fix what's messed up, at this point.

However, a user here more technically adept than I am, may be able to get you out of trouble easier than that. I hope so.
 
Old 05-14-2006, 05:35 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 21,087

Rep: Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115Reputation: 4115
Backups are never a bad idea - all that data could be backed up from a Linux liveCD to CD/DVD from this same system. No real need to move the disk.
I presume in the past you had lilo pointing to/dev/hda1 when launching XP. XP (re-)install will require access to that primary partition - the loader code will install there, even if you want the main system installed elsewhere (hda5).
What happens when you try to install XP like that, and what is the full error you see on boot ???.
In theory should work o.k.
 
Old 05-15-2006, 01:39 AM   #4
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Original Poster
Rep: Reputation: 31
I tried 2 reinstall lilo but it doesnot and in terminal shows :-
Fatal: Trying to map files from unnamed device 0x000e (NFS/RAID mirror down ?)

I learned my data is intact when I accessed all my partitions , listened 2 songs , watched a movie via LIVECD ,
when i reinstall winxp, its first part goes well , then after reboot , it shows the error
"DISK ERROR
press any key to restart"
Is there no other way?
 
Old 05-16-2006, 02:45 AM   #5
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Original Poster
Rep: Reputation: 31
well I got a programme MS-SYS it writes mic compatable boot records , its very easy , i got my windows back but same problem when trying 2 install LILO or GRUB , can any one tell me how can i run my linux (windows runs)
grub kinda hangs when i type grub-install
lilo says
Fatal: Trying to map files from unnamed device 0x000e (NFS/RAID mirror down ?)

windows is up n running!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Problem - Sos mac_casey Linux - General 9 01-29-2005 07:11 PM
i have a major problem with linux suguname Linux - General 4 01-21-2005 05:19 PM
Major problem (LILO) Mahony Linux - General 14 04-11-2004 12:24 AM
Please Help Me!! Major Problem!! cbe_7093 Linux - Hardware 1 11-14-2003 03:45 PM
Major Problem! Ghettozn Linux - Newbie 7 07-22-2003 05:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration