LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-18-2016, 07:51 PM   #1
TheOrangeRemix
LQ Newbie
 
Registered: Aug 2016
Posts: 19

Rep: Reputation: Disabled
Multilib version problems with glibc


Hello,

I am trying to install the KDCSvc package and when I do so,

I get the following error with glibc:

Quote:
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for glibc which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of glibc of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude glibc.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of glibc installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of glibc installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: glibc-2.12-1.192.el6.i686 != glibc-2.12-1.166.el6_7.7.x86_64

If I do a yum list all glibc, I get the following:

Quote:
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: ftpmirror.your.org
* extras: ftpmirror.your.org
* updates: ftpmirror.your.org
Installed Packages
glibc.x86_64 2.12-1.166.el6_7.7 @updates
glibc.x86_64 2.12-1.192.el6 installed
Available Packages
glibc.i686 2.12-1.192.el6 base
How can I clean up this dependency conflict? I am running CentOS 6.8.
 
Old 11-18-2016, 08:11 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Is this a 64 bit machine or 32-bit?

I'm asking because you have more than one version of glib installed and it's not helping that yum is trying to update the older version for the other architecture.

http://mirror.centos.org/centos/6/os/x86_64/Packages/

Last edited by Ztcoracat; 11-18-2016 at 09:24 PM.
 
Old 11-21-2016, 09:32 AM   #3
TheOrangeRemix
LQ Newbie
 
Registered: Aug 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
It's a 64 bit machine.
 
Old 11-21-2016, 12:35 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Ok than since your machine is 64-bit you don't need this pkg:
Code:
glibc.i686 2.12-1.192.el6 base
You do have these in which you only need one.
Code:
glibc.x86_64 2.12-1.166.el6_7.7 @updates
glibc.x86_64 2.12-1.192.el6 installed
Yum is trying to update glibc.x86_64 2.12-1.166.el6_7.7 which you don't need because you already have "glibc.x86_64 2.12-1.192.el6 installed".

Before you remove the pkg with the missing update run this to make sure what's installed.
Code:
rpm -qa | grep glibc
--- ---- --- --- --- --- --- ---
Looking at what the terminal returned:
Code:
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.
Remove the older glibc, the one with the missing update (glibc.x86_64 2.12-1.166.el6_7.7) and the conflict should stop.
Code:
yum remove glibc.x86_64 2.12-1.166.el6_7.7
 
Old 11-21-2016, 04:08 PM   #5
TheOrangeRemix
LQ Newbie
 
Registered: Aug 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
Thanks, that worked! Once I removed that package, I was able to install the service. I'm not sure how there was a glibc mismatch to begin with, but I'm glad that it's resolved now.
 
1 members found this post helpful.
Old 11-21-2016, 04:30 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
You're Welcome-

Glad you were able to install the service.
 
Old 11-21-2016, 04:40 PM   #7
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Don't forget to mark your thread SOLVED:-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Remove multilib - how to upgrade gcc and glibc? andreas-r Slackware 8 01-26-2013 08:40 AM
Slack64 13.1 multilib: skype 2.1.0.81 not working after glibc upgrade. Tinkster Slackware 7 12-20-2010 10:22 AM
New multilib glibc packages. - security fix from Alien. Martinezio Slackware 8 10-25-2010 10:40 AM
[SOLVED] multilib glibc gcc upgrade bmxcess Slackware 3 05-27-2010 09:48 AM
Blacklisting gcc/glibc with slackpkg in multilib-current damgar Slackware 1 01-04-2010 11:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration