LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-02-2004, 06:02 PM   #1
ptothed
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Rep: Reputation: 0
Mud Client via WINE


Hullo, I've recently switched over from winxp to Suse and I am impressed with the help provided from LQ. It's helped me learn how to use WINE (most of it anyway), but I have a few questions:

I like to play MUD (yes, terribly outdated, "does anyone still play that," mud) and I haven't managed to find a suitable linux equivalent compared to RoA Client - a free Winsock-based, 32-bit GUI MUD client for Win95/98/NT. So, after digging through LQ and wandering the internet for some idea of how to wield WINE I managed to run RoA. But, via WINE, I can only get RoA to pop up the dialog window asking me which profile I wish to use. After I choose which character I want it immediately begins the WINE debug business and I don't quite understand what's happening between the profiles dialog and the actual start up of the client.

Here's what I get from the cli:

fixme:msvcrt:_XcptFilter (-1073741819,0x4069f280)semi-stub
wine: Unhandled exception (thread 0009), starting debugger...
Could not stat /media/cdrom (No such file or directory), ignoring drive M:
WineDbg starting on pid 8
Can't find file for ELF 'wine-kthread' ((nil))
No debug information in ELF 'wine-pthread' ((nil))
Breakpoint 1 at 0x4000d5f0 (_end+0x3fefade0)
No debug information in ELF '/usr/lib/libwine.so.1' (0x40029000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x40041000)
No debug information in ELF '/lib/tls/libc.so.6' (0x40051000)
No debug information in ELF '/lib/libdl.so.2' (0x40166000)
No debug information in ELF '/lib/tls/libm.so.6' (0x40169000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/wine/ntdll.dll.so' (0x4018c000)
No debug information in ELF '/usr/lib/libwine_unicode.so.1' (0x40210000)
No debug information in ELF '/usr/lib/wine/kernel32.dll.so' (0x40420000)
No debug information in ELF '/usr/lib/wine/winmm.dll.so' (0x406a0000)
No debug information in ELF '/usr/lib/wine/user32.dll.so' (0x40713000)
No debug information in ELF '/usr/lib/wine/gdi32.dll.so' (0x40867000)
No debug information in ELF '/lib/libgcc_s.so.1' (0x40a4d000)
No debug information in ELF '/usr/lib/wine/advapi32.dll.so' (0x40a55000)
No debug information in ELF '/usr/lib/wine/msvcrt.dll.so' (0x40a89000)
No debug information in ELF '/usr/lib/wine/ws2_32.dll.so' (0x40ad3000)
No debug information in ELF '/usr/lib/wine/iphlpapi.dll.so' (0x40afc000)
No debug information in ELF '/usr/lib/wine/crtdll.dll.so' (0x40b1c000)
No debug information in ELF '/usr/lib/wine/shell32.dll.so' (0x40c2a000)
No debug information in ELF '/usr/lib/wine/ole32.dll.so' (0x40cba000)
No debug information in ELF '/usr/lib/wine/rpcrt4.dll.so' (0x40d37000)
No debug information in ELF '/usr/lib/wine/comctl32.dll.so' (0x40d82000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x40e55000)
No debug information in ELF '/usr/lib/libfontconfig.so.1' (0x40ebe000)
No debug information in ELF '/usr/lib/libexpat.so.0' (0x40ee8000)
No debug information in ELF '/usr/lib/wine/x11drv.dll.so' (0x40f07000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40f9f000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40fa8000)
No debug information in ELF '/usr/X11R6/lib/libXrandr.so.2' (0x40fc0000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x40fc4000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40fcc000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40fdb000)
No debug information in ELF '/usr/lib/libGL.so.1' (0x410d7000)
No debug information in ELF '/usr/X11R6/lib/libXxf86vm.so.1' (0x41156000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x4115b000)
Unsupported debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcUTF8Load.so.2' (0x40f8e000)
Unsupported debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x411a8000)
No debug information in ELF '/usr/lib/wine/imm32.dll.so' (0x411c6000)
No debug information in ELF '/usr/lib/wine/msacm.drv.so' (0x411e3000)
No debug information in ELF '/usr/lib/wine/msacm32.dll.so' (0x411fb000)
No debug information in ELF '/usr/lib/wine/midimap.drv.so' (0x41330000)
No debug information in 32bit DLL 'C:\Program Files\RoAClient\RoAClient.exe' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x401b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x40450000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x40a60000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x408a0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40740000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WINMM.DLL' (0x406b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x40aa0000)
No debug information in 32bit DLL 'C:\PROGRAM FILES\ROACLIENT\SHLWAPI.DLL' (0x70bd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IPHLPAPI.DLL' (0x40b10000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WS2_32.DLL' (0x40ae0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\CRTDLL.DLL' (0x40b20000)
No debug information in 32bit DLL 'C:\PROGRAM FILES\ROACLIENT\ZLIB.DLL' (0x10000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MFC42.DLL' (0x40b38000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\RPCRT4.DLL' (0x40d50000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x40cd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x40d90000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x40c50000)
No debug information in 32bit DLL 'C:\PROGRAM FILES\ROACLIENT\MSVCIRT.DLL' (0x40e33000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x40f20000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IMM32.DLL' (0x411d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSACM32.DLL' (0x41200000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSACM.DRV' (0x411f0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MIDIMAP.DRV' (0x41340000)
Unhandled exception: page fault on read access to 0x53e589c5 in 32-bit code (0x40e35f64).
In 32-bit mode.
0x40e35f64 (MSVCIRT.DLL.?sync@filebuf@@UAEHXZ+0xa4 in MSVCIRT.DLL): movb 0x4(%edi,%eax,4),%al

~~

I did notice the "MSVCRT" bit on at the beginning of this mess above and I looked it up at dlldump and placed it into the false system folder, but that only stopped WINE from even starting up the profile dialog window.

I doubt that I need to get something like WINEX or Crossover to use this small thing, but I may consider buying into these two later on when I get settled and feel more comfortable with Linux.

By the way I'm using the 20040213 release of WINE. I installed it via YAST. If the solution is to simply get a newer version of WINE could someone give me a how-to on uninstalling WINE? With Suse I just need to do it via YAST (at least I think that's all I need to do), but somehow I don't think the world of Linux is easy enough to rely upon it forever (YAST has been very helpful regardless).


Thanks in advance.
 
Old 12-03-2004, 09:23 AM   #2
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
rpm -e wine (as root)

then try installing the latest version. That build is very old. Maybe the new version will work better?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I mud (telnet) behind a firewall tavarius Linux - Networking 1 11-06-2006 03:17 PM
Cant Compile Mud Codebase Ryan450 Programming 2 12-30-2004 12:41 PM
Sendmail slow as MUD Cor Koelewijn Linux - Software 3 05-31-2004 03:25 PM
MUD Servers??? AMMullan Linux - Games 1 01-11-2004 02:17 PM
Mud Server quozt Linux - General 1 07-31-2003 09:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration