LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-21-2005, 09:03 AM   #1
RaelOM
Member
 
Registered: Dec 2004
Posts: 110

Rep: Reputation: 16
MRTG Issue of wierdness....


Ok, riddle me this. (Will provide logs on request)

I have setup MRTG and have it running successfully against several machines using the public community string so my problem machine's hrpdb1.cfg file looks like this:

Code:
HtmlDir: /var/www/mrtg2/hrpdb1
ImageDir: /var/www/mrtg2/images
LogDir: /etc/mrtg/logs/hrpdb1
Options[_]: growright, transparent, nobanner
XSize[_]: 300
YSize[_]: 100

Target[hrpdb1_WAN]: 3:public@10.72.33.60:
SetEnv[hrpdb1_WAN]: MRTG_INT_IP="10.72.33.60" MRTG_INT_DESCR="eth1"
MaxBytes[hrpdb1_WAN]: 1000000
Options[hrpdb1_WAN]: bits, growright
Title[hrpdb1_WAN]: Traffic Analysis for -- hrpdb1
PageTop[hrpdb1_WAN]: <H1>Traffic Analysis for -- hrpdb1</H1>
 <TABLE>
   <TR><TD>System:</TD>     <TD>hrpdb1.hrpdb1</TD></TR>
   <TR><TD>Maintainer:</TD> <TD>RAEL_MUSSELL@denso-diam.com</TD></TR>
   <TR><TD>Description:</TD><TD>eth1  </TD></TR>
   <TR><TD>ifType:</TD>     <TD>ethernetCsmacd (6)</TD></TR>
   <TR><TD>ifName:</TD>     <TD></TD></TR>
   <TR><TD>Max Speed:</TD>  <TD>1000.0 kBytes/s</TD></TR>
   <TR><TD>Ip:</TD>         <TD>10.72.33.60(hrpdb1)</TD></TR>
 </TABLE>

LoadMIBs: /usr/share/snmp/mibs/UCD-SNMP-MIB.txt

#
# CPU Utilization
#

Target[hrpdb1_activeCPU]:ssCpuRawUser.0&ssCpuRawUser.0:public@10.72.33.60 + ssCpuRawSystem.0&ssCpuRawSystem.0:public@10.72.33.60 + ssCpuRawNice.0&ssCpuRawNice.0:public@10.72.33.60
RouterUptime[hrpdb1_activeCPU]: public@10.72.33.60
MaxBytes[hrpdb1_activeCPU]: 100
Title[hrpdb1_activeCPU]: CPU LOAD
Unscaled[hrpdb1_activeCPU]: ymwd
ShortLegend[hrpdb1_activeCPU]: %
YLegend[hrpdb1_activeCPU]: CPU Utilization
Legend1[hrpdb1_activeCPU]: Active CPU in % (Load)
Legend2[hrpdb1_activeCPU]:
Legend3[hrpdb1_activeCPU]:
Legend4[hrpdb1_activeCPU]:
LegendI[hrpdb1_activeCPU]:  Active
LegendO[hrpdb1_activeCPU]:
Options[hrpdb1_activeCPU]: growright, nopercent,
PageTop[hrpdb1_activeCPU]: <H1>Active CPU Usage -- hrpdb1</H1>
Now the problem is that I have 0 data returned for the CPU monitor:

Log info for the hrpdb1_activecpu.log
Code:
[root@diam-ora-central hrpdb1]# cat hrpdb1_activecpu.log
1108997701 555629721 555629721
1108997701 0 0 0 0
1108997642 0 0 0 0
1108997400 0 0 0 0
1108997100 0 0 0 0
1108996800 0 0 0 0
1108996500 0 0 0 0
1108996200 0 0 0 0
1108995900 0 0 0 0
1108995600 0 0 0 0
1108995300 0 0 0 0
1108995000 0 0 0 0
1108994700 0 0 0 0
1108994400 0 0 0 0
1108994100 0 0 0 0
1108993800 0 0 0 0
1108993500 0 0 0 0
1108993200 0 0 0 0
1108992900 0 0 0 0
1108992600 0 0 0 0
1108992300 0 0 0 0
1108992000 0 0 0 0
1108991700 0 0 0 0
1108991400 0 0 0 0
1108991100 0 0 0 0
1108990800 0 0 0 0
Now, this CPU monitor is the EXACT same as the CPU monitor of all my other machines, except the target machine is different.

The snmpd.conf file on EACH machine is the exact same and every other machine I have works as expected and return valid CPU data.

This machine just won't return any valid CPU information.

*NOW* When I snmpwalk the CPU mib by hand I return valid info:

Code:
[root@diam-ora-central clients]# snmpwalk -v 1 -c public 10.72.33.60 ssCpuRawUser.0
UCD-SNMP-MIB::ssCpuRawUser.0 = Counter32: 535856030

So my very basic question is WTF?! Any help would be GREATLY appreciated as this has just hit a wall for me febel(spelling?) mind.
 
Old 02-21-2005, 09:26 AM   #2
RaelOM
Member
 
Registered: Dec 2004
Posts: 110

Original Poster
Rep: Reputation: 16
Nevermind. I just used cpuinfo in the contrib directory to skip the MIB and run the small script for this machine and it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LIBPNG & MRTG Issue mrigor Linux - Software 1 10-05-2005 01:59 PM
Gentoo wierdness short101 General 8 03-21-2005 04:28 AM
rrd mrtg & mrtg-rrd.cgi ducati620 Linux - Newbie 0 06-03-2004 07:29 PM
nmap wierdness. bleah-man Linux - Security 7 12-09-2002 12:49 PM
X wierdness barazor Linux - General 2 12-16-2001 03:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration