LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   MRTG is misbehaving: updates graphs once or twice, then stops. (https://www.linuxquestions.org/questions/linux-software-2/mrtg-is-misbehaving-updates-graphs-once-or-twice-then-stops-716734/)

boxfive 04-04-2009 02:34 AM

MRTG is misbehaving: updates graphs once or twice, then stops.
 
A few hours ago I installed MRTG on a Debian Lenny server. It worked fine for about 20-30 min, then the graphs stopped updating.

I tried restarting the snmpd service, daemonizing mrtg, undaemonizing mrtg, pretty much anything I could think of to no avail. 'ps aux | grep mrtg' shows that it is still running - which makes sense as the graphs keep updating with zero values.

I tried running 'snmpwalk -v1 localhost -c public' to see if snmp wasn't feeding the data properly, but it seems to come back okay. /var/log/mrtg/mrtg.log also has absolutely no errors.

The only thing that gets the graphs to update properly again is to do a system reboot, after which the updates work for 2-3 times (10-15min) and then stop again.

Here's what the graph looks like now.

Any ideas? I googled the hell out of this but couldn't find any concrete ideas to try apart from running MRTG as a daemon.

Code:

aesop:~# uname -a
Linux aesop.<>.com 2.6.27.10-grsec-xxxx-grs-ipv4-32 #4 SMP Wed Feb 18 16:30:23 UTC 2009 i686 GNU/Linux

aesop:~# apt-cache madison mrtg
      mrtg |  2.16.2-3 | http://mir1.ovh.net lenny/main Packages
      mrtg |  2.16.2-3 | http://mir1.ovh.net lenny/main Sources

aesop:~# apt-cache madison snmpd
    snmpd | 5.4.1~dfsg-12 | http://mir1.ovh.net lenny/main Packages
  net-snmp | 5.4.1~dfsg-12 | http://mir1.ovh.net lenny/main Sources


kirukan 04-05-2009 03:20 PM

Did you try with crontab and execute mrtg in a time interval?

Gnisten 05-14-2009 01:42 PM

Hi.

I'm havin' the exact same problem.
I'm running:
Linux "my.server.domain" 2.6.27.10-grsec-xxxx-grs-ipv4-32 #5 SMP Wed Apr 1 13:09:49 UTC 2009 i686 GNU/Linux

I have tried installing it tree times and I have also formated it one time, without any luck.

I hope someone knows anything :)

/Gnisten


All times are GMT -5. The time now is 07:40 PM.