-   Linux - Software (
-   -   mplayer - xv driver can't run (

killy9999 02-02-2006 10:42 AM

mplayer - xv driver can't run
I have a problem with mplayer. When I try to run any movie I get something like this:

When I run mplayer from command line, I get:

[killy@staticline23775 : /dane/donagrania/filmy] gmplayer
MPlayer 1istribution-Packman-4.0.2 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0" => local display)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support.
You will not be able to use your remote control.
[GUI] Adding video filter: pp
Playing /dane/donagrania/filmy/American.Pie.Band.Camp.avi.
AVI file format detected.
VIDEO: [XVID] 624x352 12bpp 25,000 fps 981,5 kbps (119,8 kbyte/s)
Clip info:
Software: VirtualDubMod (build 2540/release)
SUB: Detected subtitle file format: microdvd
SUB: Read 695 subtitles.
SUB: Adjusted 425 subtitle(s).
SUB: added subtitle file (1): /dane/donagrania/filmy/American.Pie.Band.Camp.txt
Trying to force audio codec driver family libvorbis...
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128,0 kbit/8,33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
It seems there is no Xvideo support for your video card available.
Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
Error opening/initializing the selected video_out (-vo) device.

Can someone tell me where exactly is DOCS/HTML/en/video.html, so I can read it, and most important can someone tell me what to do? I belive this is some kind of X/driver configuration issue. I'm using ati proprietary driver (fglrx module).

EDIT. Oh yeah, and xvinfo output:

[killy@staticline23775 : /dane/donagrania/filmy] xvinfo
X-Video Extension version 2.2
screen #0
no adaptors present

druuna 02-02-2006 10:59 AM


DOCS/HTML/en/video.html#xv is part of the sourcetree (probably not present on your computer).

You can try using other video out settings.

In your gui.conf (~/.mplayer/gui.conf) there's an entry that looks like this:

vo_driver = "xv" or vo_driver = "x11"

The xv/x11 can be changed into something else. To get a list of possible video output drivers run the following command in a terminal:

mplayer -vo help

Output should look like this:


MPlayer 1.0pre6-3.3.3 (C) 2000-2004 MPlayer Team

Available video output drivers:
        xv      X11/Xv
        x11    X11 ( XImage/Shm )
        xover  General X11 driver for overlay capable video output drivers
        gl      X11 (OpenGL)
        gl2    X11 (OpenGL) - multiple textures version

If you have gl/gl2 drivers, try those first.

Hope this helps.

killy9999 02-02-2006 11:07 AM


in fact I don't want any other drivers. x11 isn't capable of running fullscreen (well it is, but it doesn't scale the movie) and gl/gl2 have very low performance (audio desyncs). But they work.

I found that documents on mplayer homepage:

So there are 5 points in that document. I have a problem with fourth point (xvinfo). Other things seem ok (XVideo extension is loaded, mplayer has xv support)

killy9999 02-06-2006 05:30 AM

Ok, I solved my problem by running aticonfig with these options:

aticonfig --initial -f --ovt=Xv --ovon=1 --resolution=1152x864,1024x768,800x600,1280x1024 --hsync=30.0-70.0 --vrefresh=50.0-160.0 --tls=on --iagp=on --agpl=on -v

I believe the options for solving this problem are: --ovt=Xv --ovon=1

dj_prime 02-11-2006 08:53 AM

thanks druuna
using the gl video output worked for me

cheers mate

All times are GMT -5. The time now is 06:17 PM.