LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-19-2015, 09:31 AM   #1
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,267

Rep: Reputation: 32
mplayer won't play sound from capture device


I have an empia28xx that receives composite connections from a video source (originally used to convert VHS tapes to DVD players) and I was experimenting with it a bit. I have the device working but only the video part of it with this command

Code:
mplayer -tv driver=v4l2:device=/dev/video0:norm=NTSC:alsa=1:adevice=hw.2 tv://
But whatever I put into the alsa portions of the command, it doesn't seem to want to capture the sound from my card. I know that Linux is capable of doing this since I ran audacity with the empia28xx card and it picked up the sound crisp and clearly. Why isn't mplayer picking it up? after all of what I have been putting in the command string nothing seems to be working. Don't reccomend any other software programs for this problem because I am not interested. I plan on streaming the input of this device over a network and want to know what configurations work and which one's don't. here is the list of cards from my /proc/asound/cards

Code:
root@baron:~# cat /proc/asound/cards 
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xfbbf8000 irq 47
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbcbc000 irq 48
 2 [Em28xxAudio    ]: Em28xx-Audio - Em28xx Audio
                      Empia Em28xx Audio
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VLC/mplayer can't play x264 HD-TV capture. large_satchell Linux - Software 1 02-06-2009 06:18 AM
Alsa device recognized (and unmuted!) but won't play sound Kevschef Linux - Hardware 6 11-08-2006 11:26 AM
mplayer won't play in english blackdragonblood Linux - Software 2 06-24-2005 09:32 PM
Mplayer won't play DVD's kaega2 Mandriva 3 06-10-2004 11:29 PM
Having a hard time getting mplayer to capture sound from TV tuner Electrode Linux - Software 6 06-17-2003 01:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration