-   Linux - Software (
-   -   mplayer with vo=gl2 on compiz - missing osd and subtitles (

hikari 09-12-2010 03:34 PM

mplayer with vo=gl2 on compiz - missing osd and subtitles
Recently I have updated my video drivers and at last was able to run mplayer with vo=gl2 on compiz. The problem is: there is no text in mplayer at all! No OSD, no subtitles, nothing. What I've tried so far to solve this:

1. Rolled back to vo=xv. OSD and subs are there, but video flickers awfully when I'm trying to move mplayer window, change desktop, etc.

2. Played with ccsm "Render text to texture" and "Video" options. No effect.

3. Used vdpau for vo. Hmm, text is there, but mplayer does not respect -subfont-osd-scale and -subfont-text-scale options in config file. Text though is HUGE. Also, "subcp=enca:ru:en" entry in the config file is ignored completely. But, when I launch mplayer with vo=vdpau AND -subfont-osd-scale 2 -subfont-text-scale=2 -subcp enca:ru:en from the console, it is magically working. :(

4. Activated -ass switch (my subtitles are in srt format). Oh, now I can see subtitles (which are ugly yellow), but NOT the OSD.

So, my only solution so far is to create alias for mplayer in bash, which is just temporary, because not all video codecs in mplayer are supporting vdpau.

Any help will be appreciated. I've googled for an hour with keywords "mplayer compiz text osd" without any result.

mf93 09-30-2010 11:16 PM

try a different video player...maybe banshee?

coldmug 01-01-2011 04:27 AM

If you look at the man page for mplayer:

Select the type of YUV to RGB conversion. If set to anything except 0 OSD will be disabled and brightness, contrast and gamma setting is only available via the
global X server settings. Apart from this the values have the same meaning as for -vo gl.
so in the mplayer command line just use

mplayer vidoefile.avi -vo gl2:yuv=0
Or if you dont want to type that in every time. Open up ~/.mplayer/config and put the following line in it



hikari 01-03-2011 10:32 AM

Porblem solved!
Thanks, that worked. A bit late, because after some driver update the flickering gone (and I'm using -vo vdpau as the default output now). Thank you anyway.

coldmug 01-04-2011 12:18 PM

np. Just wanted to share anyway, someone else might be having the same issue. I myself watched a lot of movies without the display :)

All times are GMT -5. The time now is 07:46 AM.