LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-13-2004, 04:06 PM   #1
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, Espaņa/Spain
Distribution: Ubuntu Linux
Posts: 69

Rep: Reputation: 15
Mplayer tells me my C Compiler is not the right version.


I don't know what to do. It doesn't let me install MPlayer.

Can you help me?

Ufff, Linux is so difficult... but I like it
 
Old 04-13-2004, 04:13 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What version do you have?

Perhaps you can copy and paste the exact error message.
 
Old 04-14-2004, 08:40 AM   #3
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, Espaņa/Spain
Distribution: Ubuntu Linux
Posts: 69

Original Poster
Rep: Reputation: 15
.

Thanks a lot for answering me.

My version of gcc is 3.3.1

Mplayer tells me that 3.3.1 version is not suitable to compile the program and that I should "downdate" to version: 2.95.3.

What can I do?
 
Old 04-14-2004, 10:05 AM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
What version of Mplayer is that? Mplayer 1.0pre3 compiles fine with gcc-3.3.1 for me.
 
Old 04-14-2004, 12:46 PM   #5
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, Espaņa/Spain
Distribution: Ubuntu Linux
Posts: 69

Original Poster
Rep: Reputation: 15
.

Yes, it's that version of MPlayer (although I have also tried with 0.91). I'm a little bit exhausted...

I don't know why but I don't success compiling any program I try to install from binaries (except quake 3).

All the programs I have were in one of SuSE's cd's (they have self-installation). I knew Linux is not easy but right now I'm full of pain ;-)

Sorry, tonight I'll paste the error message. And thanks a lot for trying to help me.







 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GCC3.3-version C Compiler not working etto2004 Linux - Newbie 2 03-04-2004 07:55 AM
problem with compiler version?? miha Linux - General 4 01-03-2004 12:08 PM
compiler version albean Linux - Newbie 1 11-22-2002 03:33 PM
Compiler version max2878 Linux - Software 0 03-01-2002 09:58 AM
compiler version max2878 Linux - General 0 02-27-2002 04:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration