-   Linux - Software (
-   -   MPlayer: syntax for playing a DVD. (

stf92 08-16-2010 04:32 AM

MPlayer: syntax for playing a DVD.
Kernel, GNU (slackware 12.0).
KDE 3.5.7.
MPlayer 1.0rc2-4.1.2.

I'm trying to play a DVD-Video disc (that is, an out-of-the-shelf video, or those you rent in a video club) with gmplayer (the GUI version of mplayer). The syntax is specified thus in the man page:

      mplayer [dvd|dvdnav]://[title|[start_title]-end_title] [options]
I do, in KDE, Main Menu>Run Command and, in the dialog box, I type 'gmplayer dvd://1 -dvd-device /dev/hdd', where dvd-device is an option to select the dvd unit. Unfortunately, I get 'No stream found to handle url dvd://1. I don't get it. Am I not following the syntax? Thanks in advance.

business_kid 08-16-2010 04:44 AM

gmplayer is the gui fromtend. You usually don't need to mount or specify the device. Track 1 might not be correct, you may want track 2. I would do

mplayer dvd://1 or
gmplayer, and use the menus.

stf92 08-16-2010 05:20 AM

The device is not mounted. I tried
(a) gmplayer dvd://2 ******** Same error.
(b) mplayer dvd://1 ********* Exits immediately.
(c) gmplayer **************** Here in Preferences>Misc I can set the dvd device and the cd-rom device. After this, all I can do is to click an icon that takes me to a window entitled Select File. But of course I don't want to select any files but a device. It's the media I want to select; not any particular file. mplayer seems not to understand this. Well, thanks for your reply and regards.

P.S: in said window, I can select /dev but among the subdirs of /dev I do not find any which seems appropriate for the case at hand.

business_kid 08-17-2010 03:48 AM

From memory.

gmplayer without filename, click or right click on the open disc symbol, select dvd from the menu. You could also put a symlink /dev/dvd pointing at the dvd device.

konsolebox 08-17-2010 03:59 AM

Try to play the files directly. Mount the dvd somewhere then:

mplayer dvd:///mount/point

mplayer dvd:////mount/point

stf92 08-17-2010 01:20 PM


I think it's a problem inherent to the DVD unit. By ejecting and ("opposite action of eject", I do not know the verb) the tray several times, at last clicking the Play icon on the wheel, I make it start. I've also had problems in mounting DVDs in that unit. However, several times when mplayer would not play the DVD, I did 'cdrecord -media-info dev=1001,0,0' and cdrecord saw the DVD. I'll begin by throwing the unit to the trash can and buying a new one. Lite-on never more. Thanks anyway for all your help. Regards.

All times are GMT -5. The time now is 03:53 AM.