-   Linux - Software (
-   -   Mplayer Options (

Philips 09-08-2004 02:13 PM

Mplayer Options
I have slackware installed on my pc and i also have Mplayer on it. Whenever i play something put in "-vo x11 -framedrop" so that it runs better. Is there a way i can set these options to always stay on without typing it everytime?

Joubert79 09-08-2004 02:22 PM

Are you using bash? You could alias the mplayer command in your /etc/profile, ie add
alias mplayer='mplayer -vo x11 -framedrop'

You might need to do the same for gmplayer if you use the gui, dunno though.

bulliver 09-08-2004 02:30 PM

Add/uncomment these lines in /etc/mplayer.conf:

vo = x11
framedrop = yes

This will enable the settings system wide. To do it on a per user basis, add the lines to ~/.mplayer/config instead.

Philips 09-08-2004 03:30 PM

Before I read the replys i was experimenting and in the .Mplayer folder i edited the config file and now Mplayer dosent work. I tried to play a file and it played for a second before breaking. Can i uninstall Mplayer completly and install it again fresh?

bulliver 09-08-2004 08:36 PM

No need to reinstall...just delete the entire ~/.mplayer folder and it will start up with the default settings...

SciYro 09-08-2004 08:40 PM

/usr/share/mplayer/mplayer.conf is the one mplayer turns to if it cant find itself in your home directory

Philips 09-08-2004 09:14 PM

Ok i did that and the options are reset but it still dosent work. Can u just tell me how to uninstall it so that i can reinstall a fresh version. I tried installing it again with the old one still there and it says that the files already exist.

bulliver 09-08-2004 10:43 PM

Never used Slack, and don't know about how to use it's package system. Sorry...

OK, just had a quick look at the slack docs:

Seems it's as simple as:

removepkg mplayer && installpkg mplayer
but perhaps a slack user could interject here....

Philips 09-09-2004 06:01 PM

ok i put in a fresh mplayer and it works but now i cant mount a cd rom. when i try to mount a cd it says wrong fs type, bad option,bad superblock on dev/cdrom, or to many mounted file systems. I dont have any other things mounted

SciYro 09-09-2004 06:12 PM

umm, clean the cd?

(happens to me to a few times ... just fiddle around with the fstab, or cd device and maybe it'll start working again ... hmm, can u mount it as root?

Philips 09-09-2004 06:29 PM

It must be a bad cd cuz other work but this 1 dont. Well any way it works now :D

Philips 09-10-2004 08:57 PM

How do i edit the config file? use xedit? and also can u tell me exactly what to type once i am able to edit it correctly.

slackie1000 09-11-2004 03:06 AM

hi there,

this sounds weird... mount a cdrom to see a video??
i am not sure what you are trying to do but just as further reference:

1. you don't need to mount a dvdrom to be able to watch it
2. in slackware if you installed from the source with the classical

./configure &&  make && make install
there is not automatic way to remove the package.


Seems it's as simple as:

removepkg mplayer && installpkg mplayer
but perhaps a slack user could interject here....
this only works if you installed using pkgtool or something equivalent

I also need to point that Mplayer has a great docu. how to edit the config file is included there.



All times are GMT -5. The time now is 05:22 PM.