LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mplayer .mp4 playback (https://www.linuxquestions.org/questions/linux-software-2/mplayer-mp4-playback-387708/)

Cyber Maid 11-29-2005 06:09 PM

mplayer .mp4 playback
 
Hello,

I cant seem to play .mp4 extention video files with mplayer.
I've tried it with xine too but it hangs at the first frame.

Mplayer gave me this error while running in a terminal:

Code:

[h264 @ 0x85b9cb0]QP 57 out of range
Error while decoding frame!
gmplayer: h264.c:2306: mc_dir_part: Assertion `pic->data[0]' failed.           


MPlayer interrupted by signal 6 in module: decode_video
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

Am i missing a codec or something?
I've checked everything and updated the "all" win32 codecs, i have x264 codec installed too and it plays video encoded in that format too.



Why does mplayer says it supports .mp4 files when you can't even see them with the default "Video Files"...you have to change it to "All Files"...

Cyber Maid 12-01-2005 02:29 AM

anyone?

I'd like to watch my show...and not on windoze :(

jtfrizzell 12-01-2005 09:38 AM

I too am having that problem with Mplayer. And also it won't play some quick time files.

elrohir_telperi 12-05-2005 07:44 AM

Hi,

Have you tried different codecs family?

In mplayer's preference, there's a tab for "Codecs & demuxer"

When mplayer failed to play a .wmv file, giving a singal 11 decode_video error, I changed the video codec family to Win32/....

It was quite random, actually.

But it works. See if it works for you too.

Cheers.

JJNova 10-11-2007 10:14 AM

Thanks
 
I know this thread hasn't been updated since 2005, but I just wanted to point out that it was just now helpful for me, here at the end of 2007.

Thanks :)


All times are GMT -5. The time now is 09:38 PM.