LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-15-2004, 05:22 PM   #1
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
MPlayer instalation prolems


Hello,
I am trying to install MPlayer on redhat 9. It requirers libpng and libpng-dev to compile.
I managed to install libpng 1.2.7, however i cannot find libpng-devel for 1.2.7 anywhere.
I found a libpng-dev for 1.2.7-1 but it wouldnt work with my 1.2.7, i guess they have to be exactally the same version.
Please help me out!
 
Old 09-15-2004, 05:33 PM   #2
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 31
try using 1.2.6-1 of both libpng and libpng-dev

http://www.linuxquestions.org/questi...oto=nextnewest
 
Old 09-15-2004, 05:46 PM   #3
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
When I try to install the libpng i get this:

[root@localhost downloads]# rpm -ivh libpng-1.2.6-1.i386.rpm
warning: libpng-1.2.6-1.i386.rpm: V3 DSA signature: NOKEY, key ID 30c9ecf8
Preparing... ########################################### [100%]
file /usr/lib/libpng.so.3 from install of libpng-1.2.6-1 conflicts with
file from package libpng-1.2.2-16
file /usr/lib/libpng12.so.0 from install of libpng-1.2.6-1 conflicts with file from package libpng-1.2.2-16
file /usr/share/man/man5/png.5.gz from install of libpng-1.2.6-1 conflicts with file from package libpng-1.2.2-16
file /usr/lib/libpng.so.3 from install of libpng-1.2.6-1 conflicts with
file from package libpng-1.2.2-20
file /usr/lib/libpng12.so.0 from install of libpng-1.2.6-1 conflicts with file from package libpng-1.2.2-20
file /usr/share/man/man5/png.5.gz from install of libpng-1.2.6-1 conflicts with file from package libpng-1.2.2-20
[root@localhost downloads]#

I guess i cant install it because i have the later version installed. I compiled the version thats already on my computer from source not an rpm tho so i have no idea how to get rid of it..
 
Old 09-15-2004, 05:56 PM   #4
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 31
it looks like you have libpng-1.2.2 installed as well. uninstall both 1.2.7 and 1.2.2. don't ask me how to do this though cause i don't use rpms.
 
Old 09-15-2004, 06:08 PM   #5
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
when i try and get rid of it i get the following:

rpm -e libpng-1.2.2-16
error: Failed dependencies:
libpng12.so.0 is needed by (installed) gdk-pixbuf-0.18.0-7
libpng12.so.0 is needed by (installed) ImageMagick-5.4.7-10
libpng12.so.0 is needed by (installed) cups-libs-1.1.17-13
libpng12.so.0 is needed by (installed) gtk2-2.2.1-4
libpng12.so.0 is needed by (installed) imlib-1.9.13-12
libpng12.so.0 is needed by (installed) netpbm-progs-9.24-10
libpng12.so.0 is needed by (installed) dia-0.90-11
libpng12.so.0 is needed by (installed) gimp-1.2.3-16
libpng12.so.0 is needed by (installed) pilot-link-0.11.5-4
libpng12.so.0 is needed by (installed) emacs-21.2-33
libpng12.so.0 is needed by (installed) qt-3.1.1-6
libpng12.so.0 is needed by (installed) xsane-0.89-3
libpng12.so.0 is needed by (installed) xsane-gimp-0.89-3
libpng12.so.0 is needed by (installed) gnome-panel-2.2.0.1-9
libpng12.so.0 is needed by (installed) gqview-1.2.1-3
libpng12.so.0 is needed by (installed) gthumb-2.0.1-1
libpng12.so.0 is needed by (installed) gnuplot-3.7.3-2
libpng12.so.0 is needed by (installed) arts-1.1-7
libpng12.so.0 is needed by (installed) kdelibs-3.1-10
libpng12.so.0 is needed by (installed) kdegames-3.1-4
libpng12.so.0 is needed by (installed) gstreamer-plugins-0.6.0-6
libpng12.so.0 is needed by (installed) kdeartwork-3.1-3
libpng12.so.0 is needed by (installed) kdemultimedia-3.1-4
libpng12.so.0 is needed by (installed) kdeaddons-3.1-4
libpng12.so.0 is needed by (installed) kdenetwork-3.1-5
libpng12.so.0 is needed by (installed) kdeutils-3.1-4
libpng12.so.0 is needed by (installed) cups-libs-1.1.17-13.3.0.3
libpng12.so.0 is needed by (installed) netpbm-progs-9.24-10.90.1
libpng12.so.0 is needed by (installed) gdk-pixbuf-0.22.0-6.1.0
libpng12.so.0 is needed by (installed) kdelibs-3.1-13
libpng12.so.0 is needed by (installed) ghostscript-7.05-32.1
libpng12.so.0 is needed by (installed) XFree86-4.3.0-2.90.55
libpng12.so.0 is needed by (installed) kdebase-3.1-15
libpng12.so.0 is needed by (installed) kdegraphics-3.1-5
libpng12.so.0 is needed by (installed) eog-2.2.0-2
libpng is needed by (installed) ImageMagick-5.4.7-10
libpng is needed by (installed) librsvg2-2.2.3-1
libpng is needed by (installed) gnuplot-3.7.3-2
libpng is needed by (installed) ghostscript-7.05-32.1
[root@localhost downloads]#
 
Old 09-15-2004, 06:12 PM   #6
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 31
lol, don't you just love rpm dependency hell?

what distro are you using? if you're using FC/Redhat, i would suggest using up2date to install the newest versions of these package
 
Old 09-15-2004, 06:30 PM   #7
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Well i got both the libpng and libpng-dev installed!
Once i remembered why i needed them in the first place i tried to compile MPlayer again and got the same error msg i got over 5 hours ago:

Error: PNG support required for GUI compilation, please install libpng and libpng-dev packages.

back to the drawing board i guess...
 
Old 09-15-2004, 06:33 PM   #8
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 31
what versions of libpng and libpng-dev do you now have installed? and what version of mplayer are you trying to install?

again, if you have up2date or some other system update utility, i would recommend using that to get the lib files and/or install mplayer.
 
Old 09-15-2004, 06:41 PM   #9
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
How do you use up-2-date to install a spesific package? when I run it all that comes up atm is redhat-config-printer and mozzila mail.

The versions of both packages are 1.2.6-1 and im trying to compile MPlayer 1.0-pre5

Last edited by Stan the caddy; 09-15-2004 at 06:53 PM.
 
Old 02-11-2005, 04:03 PM   #10
walker
Member
 
Registered: Nov 2003
Posts: 84

Rep: Reputation: 16
Simply try to install libpng 1.2.6 with this option
rpm -Uhv libpng..... --test
if it says libraaries conflict with file of older package

use

rpm -Uhv libpng.... --replacefiles

You should not have trouble with other installed program.

cheers

walker
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
encoder prolems storywizard Linux - Software 1 02-11-2005 01:55 PM
Mplayer instalation error.. CHambeRFienD Linux - Software 3 10-05-2004 11:04 PM
Tux Racer prolems Posty Slackware 7 12-17-2003 01:35 PM
Mplayer Instalation Azain Linux - Newbie 4 06-06-2003 04:16 PM
prolems forwarding ip and pppd the_cowt Linux - Networking 3 02-11-2003 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration