LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-18-2005, 12:07 AM   #1
visualnoise
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Rep: Reputation: 0
Unhappy Mplayer Illegal Instruction error


Hi there. I am running Ubuntu Warty on a homebuilt AMD XP system and trying to get Mplayer up and running. I have installed it using the package manager and verified it is there, etc, but when I try and run it from the command line all I get is some startup info about what it thinks my proc is, some other tech. info, and then this bit:

Reading config file /etc/mplayer/mplayer.conf
Illegal instruction

I have tried using 'mplayer -vvv' to find out just what this illegal instruction is, but to no avail.

I am brand new to linux, so while I have looked at the config file, it is beyond me what might be causing the problem.

thanks in advance
 
Old 02-18-2005, 02:25 PM   #2
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
I probably can't help much, but others would probably appreciate some details to work with.

That technical info that you mentioned: If you don't know what it is specifically, it might contain an error message (one that's not clearly spelled out). You might want to post it anyway.

You may also consider posting your config file for review.
 
Old 02-18-2005, 02:52 PM   #3
visualnoise
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Here is the full output of mplayer:
MPlayer 1.0pre5-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 1053 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /etc/mplayer/mplayer.conf
Illegal instruction

Here is the config file:

##
## MPlayer config file
##
## This file can be copied to /etc/mplayer.conf and/or ~/.mplayer/config .
## If both exist, the ~/.mplayer/config's settings override the
## /etc/mplayer.conf ones. And, of course command line overrides all.
## The options are the same as in the command line, but they can be specified
## more flexibly here. See below.
##

vo=x11, # To specify default video driver (see -vo help for
# list)

ao=alsa, # To specify default audio driver (see -ao help for
# list)

fs=no # Enlarges movie window to your desktop's size.
# Used by drivers: all

vm=no # Tries to change to a different videomode
# Used by drivers: dga2, x11, sdl

bpp=0 # Force changing display depth.
# Valid settings are: 0, 15, 16, 24, 32
# may need 'vm=yes' too.
# Used by drivers: fbdev, dga2, svga

zoom=no # Enable software scaling (powerful CPU needed)
# Used by drivers: svga, aalib

double=yes # use double-buffering (recommended for xv with
# SUB/OSD usage)

# x=800 # scale movie to <x> pixels width
# y=600 # scale movie to <y> pixels height

osdlevel=1 # don't display OSD at stratup

monitoraspect=4:3 # standard monitor size, with square pixels
# monitoraspect=16:9 # use this for widescreen monitor! non-square pixels

cache = 1024 # Disk cache 1 MB

##
## Specify your preferred default skin here
## (skins are searched in /usr/share/mplayer/Skin/yourskin
## and ~/.mplayer/Skin/yourskin)
##

skin = default


##
## Multiple languages are available
##
## Hungarian igen nem
## English yes no
## German ja nein
## Spanish si no
## Binary 1 0
##
## You can also use spaces and/or tabs.
##

#sound = 1
#nosound = nein
#mixer = /dev/mixer

##
## resample the fonts' alphamap
## 0 plain white fonts
## 0.75 very narrow black outline (default)
## 1 narrow black outline
## 10 bold black outline
##

#ffactor = 0.75

##
## FBdev driver:

# fb = /dev/fb0 # framebuffer device to use
# fbmode = 640x480-120 # use this mode (read from fb.modes!)
# fbmodeconfig = /etc/fb.modes # the fb.modes file

## VESA and FBdev driver: specify your monitor's timings
##
## (see for example /etc/X11/XF86Config for timings!)
## ** CAUTION! IF YOUR DISPLAY DOESN'T SUPPORT AUTOMATICALLY TURNING OFF WHEN
## OVERDRIVED (AND EVEN IF IT DOES), THIS MAY CAUSE DAMAGE TO YOUR DISPLAY!
## WE AREN'T RESPONSIBLE, IT'S YOUR DECISION! **
##
## k, K : means multiply by 1000
## m, M : means multiply by 1.000.000
##
# monitor_hfreq = 31.5k-50k,70k # horizontal frequency range
# monitor_vfreq = 50-90 # vertical frequency range
# monitor_dotclock = 30M-300M # dotclock (or pixelclock) range

##
## SDL driver
##

# vo = sdl:aalib # use SDL video driver by default
# use "vo = sdl:aalib" or "vo sdl:dga" and so on,
# for specifying SDL subdrivers
# ao = sdl:esd # use SDL audio driver by default
# use "ao = sdl:esd" to use SDL's ESD driver
# noxv = no # whether to use XVideo hardware acceleration or not
# forcexv = yes # force XVideo even if not detected

##
## Other (preferred to be default from configfile) switches
##

framedrop=no # drop frames, when not in sync (slow CPU, videocard,visualnoise@visualnoise:~ $ more /etc/mplayer/mplayer.conf
##
## MPlayer config file
##
## This file can be copied to /etc/mplayer.conf and/or ~/.mplayer/config .
## If both exist, the ~/.mplayer/config's settings override the
## /etc/mplayer.conf ones. And, of course command line overrides all.
## The options are the same as in the command line, but they can be specified
## more flexibly here. See below.
##

vo=x11, # To specify default video driver (see -vo help for
# list)

ao=alsa, # To specify default audio driver (see -ao help for
# list)

fs=no # Enlarges movie window to your desktop's size.
# Used by drivers: all

vm=no # Tries to change to a different videomode
# Used by drivers: dga2, x11, sdl

bpp=0 # Force changing display depth.
# Valid settings are: 0, 15, 16, 24, 32
# may need 'vm=yes' too.
# Used by drivers: fbdev, dga2, svga

zoom=no # Enable software scaling (powerful CPU needed)
# Used by drivers: svga, aalib

double=yes # use double-buffering (recommended for xv with
# SUB/OSD usage)

# x=800 # scale movie to <x> pixels width
# y=600 # scale movie to <y> pixels height

osdlevel=1 # don't display OSD at stratup

monitoraspect=4:3 # standard monitor size, with square pixels
# monitoraspect=16:9 # use this for widescreen monitor! non-square pixels

cache = 1024 # Disk cache 1 MB

##
## Specify your preferred default skin here
## (skins are searched in /usr/share/mplayer/Skin/yourskin
## and ~/.mplayer/Skin/yourskin)
##

skin = default


##
## Multiple languages are available
##
## Hungarian igen nem
## English yes no
## German ja nein
## Spanish si no
## Binary 1 0
##
## You can also use spaces and/or tabs.
##

#sound = 1
#nosound = nein
#mixer = /dev/mixer

##
## resample the fonts' alphamap
## 0 plain white fonts
## 0.75 very narrow black outline (default)
## 1 narrow black outline
## 10 bold black outline
##

#ffactor = 0.75

##
## FBdev driver:

# fb = /dev/fb0 # framebuffer device to use
# fbmode = 640x480-120 # use this mode (read from fb.modes!)
# fbmodeconfig = /etc/fb.modes # the fb.modes file

## VESA and FBdev driver: specify your monitor's timings
##
## (see for example /etc/X11/XF86Config for timings!)
## ** CAUTION! IF YOUR DISPLAY DOESN'T SUPPORT AUTOMATICALLY TURNING OFF WHEN
## OVERDRIVED (AND EVEN IF IT DOES), THIS MAY CAUSE DAMAGE TO YOUR DISPLAY!
## WE AREN'T RESPONSIBLE, IT'S YOUR DECISION! **
##
## k, K : means multiply by 1000
## m, M : means multiply by 1.000.000
##
# monitor_hfreq = 31.5k-50k,70k # horizontal frequency range
# monitor_vfreq = 50-90 # vertical frequency range
# monitor_dotclock = 30M-300M # dotclock (or pixelclock) range

##
## SDL driver
##

# vo = sdl:aalib # use SDL video driver by default
# use "vo = sdl:aalib" or "vo sdl:dga" and so on,
# for specifying SDL subdrivers
# ao = sdl:esd # use SDL audio driver by default
# use "ao = sdl:esd" to use SDL's ESD driver
# noxv = no # whether to use XVideo hardware acceleration or not
# forcexv = yes # force XVideo even if not detected

##
## Other (preferred to be default from configfile) switches
##

framedrop=no # drop frames, when not in sync (slow CPU, videocard,
# etc)

#vfm=ffmpeg # use FFmpeg's libavcodec video codec family
# See "mplayer -vfm help" for all available codecs

#bps=yes # use this method for playing AVIs (if have problems,
# try removing this)

# slang= en # DVD : display english subtitles if available
# alang= en # DVD : play english audio tracks if available

## This is the correct way to use "subconfig" type options in the
## configuration file. In the command line you use :
## -aop list=resample:fout=44100 , but here it is :
# aop=list=resample:fout=44100

# From Fedora
# the default mpeg audio decoder is currently broken, let's try libmad
# first:
afm=libmad

# get a default OSD font from fontconfig
#fontconfig = yes
#font = "Sans"
#subfont-text-scale = 3

# etc)

#vfm=ffmpeg # use FFmpeg's libavcodec video codec family
# See "mplayer -vfm help" for all available codecs

#bps=yes # use this method for playing AVIs (if have problems,
# try removing this)

# slang= en # DVD : display english subtitles if available
# alang= en # DVD : play english audio tracks if available

## This is the correct way to use "subconfig" type options in the
## configuration file. In the command line you use :
## -aop list=resample:fout=44100 , but here it is :
# aop=list=resample:fout=44100

# From Fedora
# the default mpeg audio decoder is currently broken, let's try libmad
# first:
afm=libmad

# get a default OSD font from fontconfig
#fontconfig = yes
#font = "Sans"
#subfont-text-scale = 3

# etc)

#vfm=ffmpeg # use FFmpeg's libavcodec video codec family
# See "mplayer -vfm help" for all available codecs

#bps=yes # use this method for playing AVIs (if have problems,
# try removing this)

# slang= en # DVD : display english subtitles if available
# alang= en # DVD : play english audio tracks if available

## This is the correct way to use "subconfig" type options in the
## configuration file. In the command line you use :
## -aop list=resample:fout=44100 , but here it is :
# aop=list=resample:fout=44100

# From Fedora
# the default mpeg audio decoder is currently broken, let's try libmad
# first:
afm=libmad

# get a default OSD font from fontconfig
#fontconfig = yes
#font = "Sans"
#subfont-text-scale = 3

Last edited by visualnoise; 02-18-2005 at 02:53 PM.
 
Old 02-26-2005, 11:17 PM   #4
quino
LQ Newbie
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
I'm also running Ubuntu and had the same problem.

do:

"sudo mv /etc/mplayer/mplayer.conf /etc/mplayer/mplayer.conf.original"

to remove the original mplayer.conf file which seems to have invalid options for our processor.

mplayer doesn't seem to require the mplayer.conf file, as it's been working fine without it for me.

Last edited by quino; 02-26-2005 at 11:53 PM.
 
Old 02-28-2005, 03:49 PM   #5
visualnoise
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for responding. I ended up compiling MPlayer from source and it seems to be working ok, though I may remove it and give it a go without the config file. Seems a bit more coherent that way. Thanks again!

matthew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Illegal instruction / Won't Boot after up2date glibc rjesse Fedora 2 10-16-2005 07:20 PM
instruction for installing mplayer on rehl3 Ray-s1971 Red Hat 2 05-27-2005 03:11 AM
Chroot problems in Gentoo 1.4: Illegal Instruction KneeLess Linux - Distributions 4 11-13-2003 09:44 PM
Illegal instruction madsjakob Linux - Software 0 10-28-2003 07:25 AM
MySQL Instruction error verokard Programming 1 07-11-2003 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration