LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mplayer error with wmv (could be encoded) (https://www.linuxquestions.org/questions/linux-software-2/mplayer-error-with-wmv-could-be-encoded-292263/)

darkleaf 02-19-2005 10:43 AM

mplayer error with wmv (could be encoded)
 
Quote:

Failed to open /dev/rtc: No such device (it should be readable by the user.)
Playing hockey.wmv.
ASF file format detected.
VIDEO: [WMV1] 320x240 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 16000 Hz, 1 ch, 16 bit (0x10), ratio: 2000->32000 (16.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffwmv1] vfm:ffmpeg (FFmpeg M$ WMV1/WMV7)
==========================================================================
Checking audio filter chain for 16000Hz/1ch/16bit -> 16000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 1 ch, 16000 hz, little endian signed int
AF_pre: 16000Hz 1ch Signed 16-bit (Little-Endian)
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such device
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 16000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 16000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 16000Hz/1ch/16bit -> 16000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 320 x 240 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12
[wmv1 @ 0x859dce0]warning: first frame is no keyframe
[wmv1 @ 0x859dce0]overreading 3580 bits
[wmv1 @ 0x859dce0]concealing 900 errors
[wmv1 @ 0x859dce0]error, slice code was 1 1/ 1 ??% ??% ??,?% 0 0
[wmv1 @ 0x859dce0]header damaged
Error while decoding frame!
alsa-space: xrun of at least 0.179 msecs. resetting stream?,?% 0 0
alsa-space: xrun of at least 0.176 msecs. resetting stream?,?% 0 0
alsa-space: xrun of at least 0.547 msecs. resetting stream?,?% 0 0
[wmv1 @ 0x859dce0]invalid picture type
[wmv1 @ 0x859dce0]header damaged
Error while decoding frame!
alsa-space: xrun of at least 0.179 msecs. resetting stream1.2% 0 0
alsa-space: xrun of at least 27.371 msecs. resetting stream.3% 0 0
alsa-space: xrun of at least 27.754 msecs. resetting stream.4% 0 0
alsa-space: xrun of at least 0.170 msecs. resetting stream1.7% 0 0
A: 138.3 V: 7.0 A-V:131.328 ct: 0.387 3/ 3 1% 0% 1.7% 0 0

MPlayer interrupted by signal 2 in module: sleep_timer
I installed mplayer with all the codecs packages so shouldn't there be an asf codec around? Also the mplayer interrupted by signal 2 in module is because I killed it with CTRL-C.

The files work in windows media player and I tried recompiling the mplayer source a couple of times as well as installing the unofficial debian packages but that didn't work


All times are GMT -5. The time now is 08:45 AM.