LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-06-2004, 12:22 AM   #1
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Rep: Reputation: 15
MPlayer error message


AAAARRRRGGGGHHHHHH!!!!!!!!!!!!

I'm trying to use the MPlayer gui, but I keep getting this weird error message. When I just use the console, the movie plays fine. I'm confused.

console output:

bash-2.05b$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Tualatin (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/abarnes/.mplayer/config
[cfg] read config file: /home/abarnes/.mplayer/gui.conf
Reading config file /home/abarnes/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/abarnes/.mplayer/codecs.conf: can't open '/home/abarnes/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/abarnes/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/abarnes/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/abarnes/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

Playing /home/Multimedia/Movies/51st State.avi
AVI file format detected.
VIDEO: [DIV3] 576x240 24bpp 25.00 fps 944.5 kbps (115.3 kbyte/s)
Clip info:
Software: Nandub v1.0rc2
Name: The 51st State
Subject: The 51st State
Artist: ViTE
Copyright: -
Comments: Nice Wheels. Dirty Deals. And One Mean Mother In A Kilt
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 14000->192000 (112.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
open: No such device
vo_mga: Couldn't open /dev/mga_vid
Error opening/initializing the selected video_out (-vo) device.


Exiting... (Quit)

btw, I have a nvidia GEForceMX200 card with 32MB. yes, I'm using the real nvidia driver. I even get that cool nvidia splash at login.

Last edited by gnu noob; 06-06-2004 at 12:26 AM.
 
Old 06-06-2004, 01:39 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
delete the folder .mplayer and try it again.

You might have set a video device that you do not have. x11 should work ok.


You can use this

gmplayer -vo x11


Last edited by DavidPhillips; 06-06-2004 at 01:47 AM.
 
Old 06-06-2004, 01:43 AM   #3
headclark
LQ Newbie
 
Registered: Jun 2004
Posts: 20

Rep: Reputation: 0
or try xv ...it's faster. Uses the graphics chip instead of just the cpu.
 
Old 06-06-2004, 01:46 AM   #4
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Original Poster
Rep: Reputation: 15
Nope, no luck. I'll start in on it again tomorrow.
 
Old 06-06-2004, 01:53 AM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
try ..

gmplayer -vo x11


You need to link a font to .mplayer/subfont.ttf
 
Old 06-06-2004, 02:33 AM   #6
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
you just have to change the video oputput plugin to something else.

Look for the video tab in preferences
 
Old 06-06-2004, 03:58 PM   #7
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Original Poster
Rep: Reputation: 15
gmplayer -vo xv lets me scale the screen where -vo x11 doesn't. Also got the fonts thing sorted out.

thanks for the help.
 
Old 06-07-2004, 12:58 AM   #8
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
If xv works you should see less cpu usage then you would with x11
 
Old 06-20-2004, 09:19 AM   #9
a3Rogue
Member
 
Registered: Jun 2004
Location: Liverpool, UK
Distribution: Debian unstable
Posts: 56

Rep: Reputation: 15
Quote:
Originally posted by DavidPhillips
delete the folder .mplayer and try it again.

You might have set a video device that you do not have. x11 should work ok.


You can use this

gmplayer -vo x11
That worked for me, thank you very much!!!
 
Old 06-21-2004, 11:43 PM   #10
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
kewl
 
Old 09-22-2006, 11:58 PM   #11
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: Gentoo Hardened using OpenRC not Systemd
Posts: 1,452

Rep: Reputation: 85
I have the same problem after installing the nvidia driver. MPlayer doesnt complain when I use it from the command line so I don't need to use the -vo option from the command line. I am trying to fix the problem that is the error I get when opening a movie with the mouse. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while parsing chunk header. Mplayer error only under Slack vdemuth Linux - Software 5 02-19-2007 12:09 PM
QMAIL error:554 Transaction failed: message format error mpk25 Linux - Software 1 10-15-2004 01:53 PM
Get an error message when trying to open gui for Mplayer jleakey77 Linux - Software 3 03-22-2004 10:26 PM
error message when run MRTG: SNMP error zhgalaxy Linux - Newbie 0 02-18-2004 01:08 PM
why this error message is appear in xsession-error file? eye Red Hat 0 10-21-2003 08:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration