LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   MPlayer error message (https://www.linuxquestions.org/questions/linux-software-2/mplayer-error-message-190202/)

gnu noob 06-06-2004 12:22 AM

MPlayer error message
 
AAAARRRRGGGGHHHHHH!!!!!!!!!!!!

I'm trying to use the MPlayer gui, but I keep getting this weird error message. When I just use the console, the movie plays fine. I'm confused.

console output:

bash-2.05b$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Tualatin (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/abarnes/.mplayer/config
[cfg] read config file: /home/abarnes/.mplayer/gui.conf
Reading config file /home/abarnes/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/abarnes/.mplayer/codecs.conf: can't open '/home/abarnes/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/abarnes/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/abarnes/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/abarnes/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

Playing /home/Multimedia/Movies/51st State.avi
AVI file format detected.
VIDEO: [DIV3] 576x240 24bpp 25.00 fps 944.5 kbps (115.3 kbyte/s)
Clip info:
Software: Nandub v1.0rc2
Name: The 51st State
Subject: The 51st State
Artist: ViTE
Copyright: -
Comments: Nice Wheels. Dirty Deals. And One Mean Mother In A Kilt
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 14000->192000 (112.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
open: No such device
vo_mga: Couldn't open /dev/mga_vid
Error opening/initializing the selected video_out (-vo) device.


Exiting... (Quit)

btw, I have a nvidia GEForceMX200 card with 32MB. yes, I'm using the real nvidia driver. I even get that cool nvidia splash at login.

DavidPhillips 06-06-2004 01:39 AM

delete the folder .mplayer and try it again.

You might have set a video device that you do not have. x11 should work ok.


You can use this

gmplayer -vo x11


headclark 06-06-2004 01:43 AM

or try xv ...it's faster. Uses the graphics chip instead of just the cpu.

gnu noob 06-06-2004 01:46 AM

Nope, no luck. I'll start in on it again tomorrow.

DavidPhillips 06-06-2004 01:53 AM

try ..

gmplayer -vo x11


You need to link a font to .mplayer/subfont.ttf

vinay_s_s 06-06-2004 02:33 AM

you just have to change the video oputput plugin to something else.

Look for the video tab in preferences

gnu noob 06-06-2004 03:58 PM

gmplayer -vo xv lets me scale the screen where -vo x11 doesn't. Also got the fonts thing sorted out.

thanks for the help.

DavidPhillips 06-07-2004 12:58 AM

If xv works you should see less cpu usage then you would with x11

a3Rogue 06-20-2004 09:19 AM

Quote:

Originally posted by DavidPhillips
delete the folder .mplayer and try it again.

You might have set a video device that you do not have. x11 should work ok.


You can use this

gmplayer -vo x11

That worked for me, thank you very much!!! :D

DavidPhillips 06-21-2004 11:43 PM

kewl :)

fakie_flip 09-22-2006 11:58 PM

I have the same problem after installing the nvidia driver. MPlayer doesnt complain when I use it from the command line so I don't need to use the -vo option from the command line. I am trying to fix the problem that is the error I get when opening a movie with the mouse. Thanks.


All times are GMT -5. The time now is 11:59 PM.