-   Linux - Software (
-   -   Mplayer codecs - running 32bit mplayer on 64bit OS (

sleepyrob 08-11-2006 11:00 AM

Mplayer codecs - running 32bit mplayer on 64bit OS
I have Fedora Core 5 x86_64. To get win32 codecs working I have had to install 32bit versions of players, but I can't seem to get mplayer to find the codecs.

I have the codecs in /usr/lib/codecs, usr/lib/win32 and usr/lib64/codecs (just in case) and I have also tried installing mplayer and mplayer-codecs using yumex --forcei386. It just wont play any wmvs.

Xine I installed in the same way and it works fine, but I want to use the mplayer firefox plugin rather than gxine. Any suggestions would be greatly appreciated.

jlo_sandog 08-11-2006 07:42 PM

The codecs should go in /usr/lib/codecs. I got mplayer from the freshrpms website. There are instructions there on how to set-up a .repo file. Then you can install what you need via yum/yumex. Good luck.

sleepyrob 08-12-2006 05:08 AM

Thanks, but as I said, I have the codecs there (btw different builds of mplayer require codecs in different locations, as do some other players). I have the freshrpms repo, i have tried installing that version. I have also tried the greysector repo, which has a yum package of the codecs (and yes, I have tried installing the greysector mplayer package too). Christ knows where that package put the codecs, but nevertheless, it still doesn't work.

All times are GMT -5. The time now is 11:31 PM.