LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mplayer codec rv40 plays rmvb video, but no sound... (https://www.linuxquestions.org/questions/linux-software-2/mplayer-codec-rv40-plays-rmvb-video-but-no-sound-292721/)

sirpelidor 02-20-2005 04:46 PM

mplayer codec rv40 plays rmvb video, but no sound...
 
Hi, I've followed the instruction from Doc and install alll the codec.
Been having trouble play rmvb format media (got video, no sound, and can't use seek to move fwd ot backward)...
here's the example:

mplayer Seoul.Raiders-Rv9.rmvb

Code:

MPlayer 0.92-3.3.1  (C) 2000-2003 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Playing Seoul.Raiders-Rv9.rmvb
REAL file format detected.
skip_str: 12 bytes skipped
skip_str: 20 bytes skipped
======= WAVE Format =======
Format Tag: 24946 (0x6172)
Channels: 2
Samplerate: 32000
avg byte/sec: 64000
Block align: 256
bits/sample: 16
cbSize: 0
skip_str: 12 bytes skipped
skip_str: 20 bytes skipped
skip_str: 0 bytes skipped
skip_str: 16 bytes skipped
Not audio/video stream or unsupported!
VIDEO:  RV40 [40006000,01481020]  640x352  (aspect 0.00)  23.00 fps
Clip info:
name: Seoul Raiders
 author: Rv9_Badbone
 copyright: www.ydy.com(C)2005
=====================================================================
*** Try to upgrade /home/user1/.mplayer/codecs.conf from etc/codecs.conf
*** If it still does not work, read DOCS/codecs.html!
Cannot find codec for audio format 0x63616172.
=====================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
=====================================================================
Opening video decoder: [realvid] RealVideo decoder
opening shared obj '/usr/local/lib/codecs/drv4.so.6.0'
Selected video codec: [rv40] vfm:realvid (Linux RealPlayer 9 RV40 decoder)
=====================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 352 (preferred csp: Planar I420)
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 1.82:1 - prescaling to correct movie aspect.
VO: [xv] 640x352 => 640x352 Planar I420
Successfully enabled DPMS.0% 0 0 0%

I'm assuming maybe rv40 codec can't play the newest helix codec? thank you for your suggestions


-sirpelidor

320mb 02-22-2005 10:24 AM

Quote:

The source code on this website may damage your hardware.
It is *UNTESTED* and *BROKEN* !

Or, at least, some of it is.
I guess this warning from that site meant nothing to you huh??

sirpelidor 02-22-2005 08:52 PM

thanks for the reply 320mb,

would u plz tell me where u get that "error" msg:

The source code on this website may damage your hardware.
It is *UNTESTED* and *BROKEN* !


p.s.: this rmvb file was download using bittorrent. so i didn't know if it harms the machine or what not, because i'm able to watch the movie when using xp (but i really perfer watch it using linux)

thank you

qtbb 02-23-2005 12:28 AM

i am not sure what with ur mplayer, but i've got gxine having similar problem.
i had sound but no movie.

if you use codecs from realplayer10, though i'm unsure of why, it doesn't help this problem, but keep those codecs. what you need to find first is package include drv3.so.6.0 and drv4.so.6.0 in its codecs. you should try download realplayer7 / 8 / 9 cause they've got those codecs included.

if you do have the codecs drv3.so.6.0, drv4.so.6.0 etc. find codecs from realplayer10. and put them togther.

sirpelidor 02-24-2005 04:52 AM

qtbb, thanks for ur insite, i found out the solution (using mplayer)

ok, codec rv.10 seems is not something mplayer can recongize.

what what i did was: i kept real codec 7,8,9 within mplayer codec (which locates at /usr/local/lib/codecs by default)

and i install realone (which is real player 10 in Unix)

p.s: real 10 codec --- cook.so, rv40.so doesn't seem to be recongize by mplayer's codec path

so when i have to watch realone format media, i just launch realplayer 10 for now.


now i'm able to watch realOne format media....

thank you for for suggestion


-sirpelidor

feta2010 12-04-2008 07:12 PM

hi
 
gooooooooooooooooooooooooog


All times are GMT -5. The time now is 04:31 PM.