LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-08-2015, 06:43 PM   #1
standards
Member
 
Registered: May 2015
Posts: 54

Rep: Reputation: Disabled
Arrow Mplayer audio not working: cant find /dev/dsp on RHEL/CentOS


Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 71.1 kbit/2.32% (ratio: 8893->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
DVB card number must be between 1 and 4

That happens whenever I try to play.
I have alsa but it isnt installed in MPlayer so I cant use it.
 
Old 05-08-2015, 06:59 PM   #2
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
VLC works sometimes
 
Old 05-08-2015, 11:13 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,629

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
WHAT!!! version of RHEL or Cent is this ?
this DOSE make a VERY BIG difference
RHEL 5.11 ?
RHEL 6.6 ?
RHEL 7.1 ?

"AlSA" and "OSS" VS. "pulse audio "



also HOW was mplayer installed ?
and WHAT!!!! version is it ?
is it really the TERMINAL ONLY mplayer ?
or
the Gnome gtk "Gnome-mplayer"

for ffmpeg

how was ffmpeg installed and were the codec's for mplayer installed ?

see the cent wiki
CentOS 7
http://wiki.centos.org/TipsAndTricks...mediaOnCentOS7

CentOS 6
http://wiki.centos.org/TipsAndTricks/MultimediaOnCentOS
 
Old 05-09-2015, 05:04 AM   #4
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
Centos 7 and RHEL 7
i BUILT IT FROM SOURCE
normal mplayer
yes they were installed
 
Old 05-09-2015, 08:27 AM   #5
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
bump
 
Old 05-09-2015, 02:17 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,629

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
For a source build , mplayer needs a ton of prerequisites ( and the -devel.rpm's) to be installed and working first

recheck your "configure.log" file
you might not have built the audio code

but WHY build from source

Quote:
normal mplayer
so you DID NOT build the gtk gui for Gnome
this is the TERMINAL ONLY version
the one that you have to type in a long command line argument to use


mplayer in in the repos

also what version?
the SVN snapshot ?
( svn://svn.mplayerhq.hu/mplayer/trunk mplayer )
or a different version


however the BEST option was to use
http://wiki.centos.org/TipsAndTricks...mediaOnCentOS7
and use the QT frontend to mplayer "smplayer"

Last edited by John VV; 05-09-2015 at 02:28 PM.
 
Old 05-10-2015, 05:54 AM   #7
standards
Member
 
Registered: May 2015
Posts: 54

Original Poster
Rep: Reputation: Disabled
SVN Snapshot and I use ALSA.I cant find the OSS emulation part
 
  


Reply

Tags
alsa, audio, linux, mplayer, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio recording software - can't find /dev/dsp Ian D Fedora 1 11-01-2012 04:07 PM
/dev/audio, /dev/dsp and /dev/mixer missing in Debian Etch 1337_penguin Debian 2 04-11-2007 11:33 AM
Forward audio that should go/come to/from /dev/dsp to a pipe edwinsc Linux - General 2 07-21-2006 03:51 PM
Forward audio that should go/come to/from /dev/dsp to a pipe edwinsc Linux - General 1 07-21-2006 09:25 AM
Audio: /dev/dsp can't be opened marcheikens Linux - Newbie 2 08-27-2003 09:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration