-   Linux - Software (
-   -   Mplayer and Xine create only green outputs on playing video files (

sn_piranha 07-24-2004 05:41 AM

Mplayer and Xine create only green outputs on playing video files
I'm running Slackware 10.0 on an IBM Thinkpad 770x (PII @ 300Mhz w/128MB of RAM, VGA 8MB Trident Cyber 9397) and I'm having difficulties viewing video files with MPlayer and Xine.
When I open a video file (.avi or .mpg or whatever) everything goes smooth, but the output window is green with coloured small lines. The sound works just fine ...the file gets played but I cannot see anything except the green window.
I would like to add that on my previous Linux distros (Mandrake, Suse, Knoppix, Red Hat) these programs worked perfectly (I could watch vido files in full screen mode), except for a small green line at the bottom of the output window.
Any suggestions ? Thank you in advance.

reddazz 07-25-2004 04:26 AM

I had this problem with the default xine packages that come with Slack 10, so I ended up downloading xine rpms from the xine website (, converted them to slackware packages using rpm2tgz and installed the tgz packages on my system. I also compiled mplayer from source and downloaded win32 codecs from the mplayer site and copied them to a folder on my system (/usr/lib/win32). Now Xine and MPlayer work fine and I never have the green screens on Slack 10.

sn_piranha 07-25-2004 09:30 AM

I already installed all the codecs I could find on the Internet...I'm afraid the problem is more complicated than this...
I solved the "green output" problem last night but now something else is bugging me...
I cannot play any file in runs crappy (in other distros it worked just fine, smooth)...could it be the vo? (I've tried x11 and xv).
Any suggestions ?

rntm 07-25-2004 10:04 AM

My Green-Problem was solved when downloading win32 codecs and recompiling mplayer.

My fullscreen problem was I couldn't maximize it, when I pushed 'f' There was everything black and the video played in it's original size in the middle of the screen. This was when no hardware accell was available, so I messed up with the ATI Drivers for my card and now it works perfect.

If that doesn't work and you need fullscreen really bad try to run it from console and use -vo svga, -vo vesa or so.

sn_piranha 07-25-2004 07:43 PM

Thank you for your reply... So I guess it's a driver thing...
The weird thing is that in Mandrake 9.1 and Knoppix and Suse it worked in fullscreen mode smoothly...
I will try to find the driver for my video card (it is kind of hard because my machine is a notebook)
Trident Cyber 9397 (DVD) 8 Megs VRAM.
If anyone has suggestions about a video card driver web page... thanks in advance. the way, thank provided some great hints ;)

worldwiderob 10-10-2004 08:36 PM

This is an old thread, but maybe you are still about...

Yes it is -vo that more than anything decides whether you get smooth playback full screen. You need to use xv (XVideo) if at all possible.

You should be able to play DVDs with 1024x768x16 under Slackware 10.0 with that particular graphics card. I have the same card in my Thinkpad 770X. If you run xvinfo, you will probably find that XVideo is supported. If so, then problems with XVideo are probably because of using too high a video mode or the wrong colour depth. Try starting X with 1024x768 @ 16bpp.

Also, virtual screens take up video memory and could prevent XVideo from having all the space it needs. It is probably not a problem with Slackware's hardware support itself.

All times are GMT -5. The time now is 05:46 AM.